PDA

View Full Version : [ubuntu] MTRR: CPU 0: SYSCFG[MtrrFixDramModEn] not cleared by BIOS



captain_rob
April 30th, 2009, 10:35 AM
I am a newbie. I made a clear install Ubuntu 9.04 64. At start up I get a strange message, which I have not seen under 8.04:

[Firmware Warn]: MTRR: CPU 0: SYSCFG[MtrrFixDramModEn] not cleared by BIOS, clearing this bit

What does this mean and what to do about it?

jamey0824
May 23rd, 2009, 09:10 PM
yeah i get this too, it shows on screen during boot, and is in kern.log. It onlys shows on my screen boot when I enable surrondview( ati integrated graphics and a secondary graphics card. But it might happen when its disabled ,and it just doesn't post it to screen

gnigamica
May 24th, 2009, 02:56 AM
I am experiencing the same issue. This seems to be post-Grub, during startup. I did not see it on earlier versions of Ubuntu. Any way to suppress these warnings? I already have quiet boot set in grub... this does not appear to be grub related.

C. M .Hughes
June 9th, 2009, 04:51 PM
I too have the same problem. My system still boots fine, but I wonder if there is anything I can do about it. Any advice would be greatly appreciated.

C. M .Hughes
June 10th, 2009, 07:41 PM
Hi all,
Myself and some others have received the above message immediately after GRUB and before the Ubuntu splash screen. We have a thread going here:

http://ubuntuforums.org/showthread.php?t=1143681

but so far no suggestions have come. If anyone has any, I'd love to hear them! Thanks for your time.

sdennie
June 10th, 2009, 07:56 PM
Merged this thread and the original thread.

My guess is the problem is that your motherboard/BIOS doesn't correctly support using MTRRs. You should be able to disable the message by booting with nomtrr. An example of how to change boot options can be found here: https://help.ubuntu.com/community/BootOptions#Change%20Boot%20Options%20Temporarily% 20For%20An%20Existing%20Installation. Both temporary and permanent instructions are given.

C. M .Hughes
June 11th, 2009, 12:03 AM
sdennie,
Thanks for your time on this. At present, the entry that I boot from in menu.lst looks like this:

title Ubuntu 9.04, kernel 2.6.28-11-generic
uuid 9a3ea422-4178-4359-9195-a69120ea5f87
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=9a3ea422-4178-4359-9195-a69120ea5f87 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet

From the reading I have done, is it true that I should try changing the kernel line to:

kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=9a3ea422-4178-4359-9195-a69120ea5f87 ro quiet splash, nomtrr

sdennie
June 11th, 2009, 12:09 AM
sdennie,
Thanks for your time on this. At present, the entry that I boot from in menu.lst looks like this:

title Ubuntu 9.04, kernel 2.6.28-11-generic
uuid 9a3ea422-4178-4359-9195-a69120ea5f87
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=9a3ea422-4178-4359-9195-a69120ea5f87 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet

From the reading I have done, is it true that I should try changing the kernel line to:

kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=9a3ea422-4178-4359-9195-a69120ea5f87 ro quiet splash, nomtrr

You shouldn't need the comma actually. Try:



kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=9a3ea422-4178-4359-9195-a69120ea5f87 ro quiet splash nomtrr

C. M .Hughes
June 11th, 2009, 12:21 AM
Hi sdennie,
I tried it as you suggested, but I still get the same messages. Do you have any other suggestions?

Thank you for your time.

C. M .Hughes
June 11th, 2009, 04:55 AM
I tried something else which also hasn't worked. I went into

/etc/X11/xorg.conf

and made this bit

Section "Device"
Identifier "Configured Video Device"
EndSection

look like:

Section "Device"
Identifier "Configured Video Device"
Option "NoMTRR"
EndSection

Still no luck...

C. M .Hughes
July 6th, 2009, 04:51 AM
bump

m13p
July 24th, 2009, 09:33 PM
While installing Ubuntu 9.04 in my acer 5050 laptop, i got the following problem....



[ 0.382240] ACPI: Aborted because broken padding
[ 0.436001]{Firmware Warn]:MTRR:CPU 0:SYSCFG[MtrrFixDramModEn]not cleared by BIOS, clearing this bit
[ 3.914977]crc error
[3.9612081]kernel panic-not syncing:VFS:Unable to mount root fs on unknown-block(104,1)


what is the cause ?
right now i dont have any operating system installed in it...
please help...
thanks

LewRockwell
July 24th, 2009, 09:57 PM
While installing Ubuntu 9.04 in my acer 5050 laptop, i got the following problem....



[ 0.382240] ACPI: Aborted because broken padding
[ 0.436001]{Firmware Warn]:MTRR:CPU 0:SYSCFG[MtrrFixDramModEn]not cleared by BIOS, clearing this bit
[ 3.914977]crc error
[3.9612081]kernel panic-not syncing:VFS:Unable to mount root fs on unknown-block(104,1)


what is the cause ?
right now i dont have any operating system installed in it...
please help...
thanks

does your laptop have the latest BIOS?

http://support.acer-euro.com/drivers/notebook/as_5050.html

.

DarkenSX
August 12th, 2009, 05:18 PM
Im getting the same message with my dell inspiron 1526 laptop running ubuntu 8.04 with the latest dell bios which is A15. Any idea Whats Causing it Since Bios version is not the issue.
My Specs:
Dell Inspiron 1526
CPU: AMD Sempron Single Core 3600+ 2.0Ghz 32-Bit
RAM: 2GB Installed Can handle up to 4GB
Org. OS: Win Vista Home Basic
Curr. OS: Ubuntu 8.04 LTS
Video: ATI Radeon X1270
Sound: Sigmatel Stac 9228

isa saids
April 30th, 2013, 05:44 AM
does your laptop have the latest BIOS?

http://support.acer-euro.com/drivers/notebook/as_5050.html

.

I have same problem, thank you for the link. I have already updated bios to newer but still the same, it might another way I could solve that problem?. But thank you thats helpful

Bucky Ball
April 30th, 2013, 05:52 AM
Thread Closed

Reason: Necromancy. Old thread put to bed.

If a thread has seen no action for around a year or more please post a new thread in the relevant sub-forum with a descriptive title and info pertinent to your problem rather than resurrecting a three and a half year old thread. You stand minimal chance of getting help doing this. Also, things can (and do) change radically in computers in that time.

A new thread will greatly increase your chances of help. Good luck.