PDA

View Full Version : [ubuntu] 9.04 Gnome-ppp fails Zoom USB dialup 3095



jkohler2
April 29th, 2009, 06:05 AM
I just downloaded Ubuntu 9.04 and hoped Gnome-PPP would work better with the Linuxant dgc-1.00 usb modem driver.

It did not.

Here is the dialup listing:

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L3DT*70,,4901941
--> Waiting for carrier.
ATM1L3DT*70,,4901941
CONNECT 57600
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Tue Apr 28 21:52:57 2009
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 4195
--> Using interface ppp0
--> Disconnecting at Tue Apr 28 21:53:28 2009
--> The PPP daemon has died: Authentication error.
--> We failed to authenticate ourselves to the peer.
--> Maybe bad account or password? (exit code = 19)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 19)


Thanks in advance for any help!

John

sir_nasty
April 29th, 2009, 06:11 AM
I'm just throwing out ideas here but perhaps your permissions on these files is set improperly?

--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 4195

google says....

There cure was to (under Ubuntu)
$ sudo chmod a+rw /etc/ppp/pap-secrets
with other distros if would be
$ su - root
# chmod a+rw /etc/ppp/pap-secrets
Then I repeated the dialout, successfully,during which
there was written to /etc/ppp/pap-secrets a line
MyLoginName\@worldnet\.att\.net * MyPassword

jkohler2
May 2nd, 2009, 05:58 PM
You are probably correct. I do not know how to set permissions. since root has all permissions for everything (making it dangerous to play with) maybe that is why it works on this problem:

john@john-laptop:~$ sudo gnome-ppp
[sudo] password for john:
WVCONF: /root/.wvdial.conf
GNOME PPP: Connecting...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.60
GNOME PPP: STDERR: --> Cannot get information for serial port.
GNOME PPP: STDERR: --> Initializing modem.
GNOME PPP: STDERR: --> Sending: ATZ
GNOME PPP: STDERR: ATZ
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Modem initialized.
GNOME PPP: STDERR: --> Sending: ATM1L3DT*70,,4901941
GNOME PPP: STDERR: --> Waiting for carrier.
GNOME PPP: STDERR: ATM1L3DT*70,,4901941
GNOME PPP: STDERR: CONNECT 57600
GNOME PPP: STDERR: --> Carrier detected. Starting PPP immediately.
GNOME PPP: STDERR: --> Starting pppd at Sat May 2 09:49:51 2009
GNOME PPP: STDERR: --> Pid of pppd: 3685
GNOME PPP: STDERR: --> Using interface ppp0
GNOME PPP: STDERR: --> local IP address 69.19.185.61
GNOME PPP: STDERR: --> remote IP address 69.19.217.75
GNOME PPP: STDERR: --> primary DNS address 66.81.1.250
GNOME PPP: STDERR: --> secondary DNS address 66.81.1.252


Now how to get it running as user?

John

jkohler2
May 7th, 2009, 01:31 AM
Here is the answer:

Open Ubuntu.
Open a terminal window =>Accessories=>terminal window
Enter the following: sudo gnome-ppp
Give your user password
When a gnome-ppp graphic window appears, do your setup, i.e., login, password, phone number of your ISP, and the rest.
Click on "connect" in the gnome-ppp window
After the off-hook, dialing, handshake and connect, open Firefox.
Firefox will give an error message because "Work offline" has been checked by default.

Click on the FireFox task bar "File" and drag down to work offline and uncheck the box.

You are on the internet via dialup and with a working browser.


John