PDA

View Full Version : [ubuntu] 9.04 jaunty server: installing calendarserver fails



jiragh
April 24th, 2009, 07:23 PM
Hi,

I'm having major problems installing calendarserver on my newly installed ubuntu 9.04 jaunty i386 server.

Here is what I did (sorry for the german interface, I will translate the interesting part below marking it with '***').

Obviously python-twisted-core conflicts somehow with python-twisted-calendarserver. This problem did not occur with ubuntu 8.10 intrepid. Any hints?



foo@bar:~$ sudo apt-get install calendarserver
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
python-dateutil python-kerberos python-openssl python-pam
python-pkg-resources python-pysqlite2 python-serial python-twisted-bin
python-twisted-calendarserver python-twisted-core python-vobject
python-xattr python-xml python-zopeinterface
Vorgeschlagene Pakete:
python-pydirector python-openssl-doc python-openssl-dbg python-pam-dbg
python-setuptools python-pysqlite2-doc python-pysqlite2-dbg python-wxgtk2.8
python-wxgtk2.6 python-wxgtk python-twisted-bin-dbg python-tk python-gtk2
python-glade2 python-qt3 python-profiler python-xml-doc python-xml-dbg
python-zopeinterface-dbg
Empfohlene Pakete:
python-pyopenssl
Die folgenden NEUEN Pakete werden installiert:
calendarserver python-dateutil python-kerberos python-openssl python-pam
python-pkg-resources python-pysqlite2 python-serial python-twisted-bin
python-twisted-calendarserver python-twisted-core python-vobject
python-xattr python-xml python-zopeinterface
0 aktualisiert, 15 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0B von 2797kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 18,0MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]?
Wähle vormals abgewähltes Paket python-kerberos.
(Lese Datenbank ... 23910 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke python-kerberos (aus .../python-kerberos_1.1-3build1_i386.deb) ...
Wähle vormals abgewähltes Paket python-pysqlite2.
Entpacke python-pysqlite2 (aus .../python-pysqlite2_2.5.0-2ubuntu1_i386.deb) ...
Wähle vormals abgewähltes Paket python-openssl.
Entpacke python-openssl (aus .../python-openssl_0.7-2ubuntu1_i386.deb) ...
Wähle vormals abgewähltes Paket python-dateutil.
Entpacke python-dateutil (aus .../python-dateutil_1.4.1-2_all.deb) ...
Wähle vormals abgewähltes Paket python-vobject.
Entpacke python-vobject (aus .../python-vobject_0.6.0-1_all.deb) ...
Wähle vormals abgewähltes Paket python-zopeinterface.
Entpacke python-zopeinterface (aus .../python-zopeinterface_3.4.0-0ubuntu3_i386.deb) ...
Wähle vormals abgewähltes Paket python-twisted-bin.
Entpacke python-twisted-bin (aus .../python-twisted-bin_8.2.0-2_i386.deb) ...
Wähle vormals abgewähltes Paket python-twisted-core.
Entpacke python-twisted-core (aus .../python-twisted-core_8.2.0-2_all.deb) ...
Entpacke python-twisted-calendarserver (aus .../python-twisted-calendarserver_0.2.0.svn19773-5ubuntu1_i386.deb) ...
*** 'Entpacke' = 'unpacking'
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/python-twisted-calendarserver_0.2.0.svn19773-5ubuntu1_i386.deb (--unpack):
*** 'Fehler beim Bearbeiten von' = 'error while working on'
Versuche, »/usr/share/pyshared/twisted/plugins/__init__.py« zu überschreiben, welches auch in Paket python-twisted-core ist
*** 'Versuche ... zu überschreiben, welches auch in Paket ... ist' = 'Try to overwrite ... which is also available in packages ...'
dpkg-deb: Unterprozess paste mit Signal (Broken pipe) getötet
*** 'Unterprozess ... mit Signal ... getötet' = 'subprocess ... died with signal ...'
Wähle vormals abgewähltes Paket python-pkg-resources.
Entpacke python-pkg-resources (aus .../python-pkg-resources_0.6c9-0ubuntu4_all.deb) ...
Wähle vormals abgewähltes Paket python-xattr.
Entpacke python-xattr (aus .../python-xattr_0.4-4build1_i386.deb) ...
Wähle vormals abgewähltes Paket python-xml.
Entpacke python-xml (aus .../python-xml_0.8.4-10.1ubuntu2_i386.deb) ...
Wähle vormals abgewähltes Paket calendarserver.
Entpacke calendarserver (aus .../calendarserver_1.2.dfsg-8_all.deb) ...
Wähle vormals abgewähltes Paket python-pam.
Entpacke python-pam (aus .../python-pam_0.4.2-12ubuntu3_i386.deb) ...
Wähle vormals abgewähltes Paket python-serial.
Entpacke python-serial (aus .../python-serial_2.3-1_all.deb) ...
Verarbeite Trigger für man-db ...
Fehler traten auf beim Bearbeiten von:
*** 'Fehler traten auf beim Bearbeiten von' = 'errors occured while working on'
/var/cache/apt/archives/python-twisted-calendarserver_0.2.0.svn19773-5ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

jiragh
April 24th, 2009, 08:04 PM
Hmm, seems to be already filed as bug: https://bugs.launchpad.net/ubuntu/+source/twisted-calendarserver/+bug/349837 :(