PDA

View Full Version : [ubuntu] Synapic fails to install package- proken package



paul leo
April 24th, 2009, 09:05 AM
Synaptic can't install

libcurl4-gnutls-dev
because it can't find libgnuls-dev OR libdap2-dev

apt-get also fails ! - broken package!
#################

$ sudo apt-get install libgnutls-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgnutls-dev: Depends: libgnutls26 (= 2.4.1-1ubuntu0.2) but 2.4.1-1ubuntu0.3 is to be installed
E: Broken packages
################################

I need these since I want want to get some R and bioconduction packages working but can't install Rcurl :

libcurl and curl are installed but I think I need libcurl4-gnuls-dev to fix this

Any ideas what to do next?

blazemore
April 24th, 2009, 10:06 AM
try

sudo apt-get install libgnutls26

Big_Croc7
April 24th, 2009, 10:16 AM
No, it needs a different version.


libgnutls-dev: Depends: libgnutls26 (= 2.4.1-1ubuntu0.2) but 2.4.1-1ubuntu0.3 is to be installed
You'll have to find and install the older version of libgnutls26 (2.4.1-1ubuntu0.2).

omycron
January 22nd, 2010, 11:02 PM
So I think if you want to install RCurl (and other Bioconductor-Packages) you need this package:

libcurl4-openssl-dev - Development files and documentation for libcurl (OpenSSL)


sudo apt-get install libcurl4-openssl-dev

Mine is working :D

Hope it helped ...