PDA

View Full Version : [SOLVED] automatic program startup preventing successful login



rockerphil
April 23rd, 2009, 08:13 PM
ok, the title is pretty self explanatory, but here's a quick rundown. i shut down Xubuntu without first closing out all my running programs (xmms Pidgin and Firefox) and since my system resources are pretty limited every time i try to log in to the only account on the system it tries to load all those running programs upon startup, overloads itself and kicks me back to GDM so if anyone has a way i can disable this particular feature i'd be greatly appreciative, and please remember, i can't log in graphically so please keep it either terminal based, or if there's a way i can do it from one of my other Linux installs by editing a config file or something to that effect it'd be greatly appreciated. much thanks in advance,

Phil

LowSky
April 23rd, 2009, 08:15 PM
at GDM, boot into safe mode, then log out, then boot into normal mode

rockerphil
April 23rd, 2009, 08:18 PM
do you mean Failsafe Gnome? cus if so my machine doesn't have the resources to run Gnome

decoherence
April 23rd, 2009, 08:28 PM
I don't know from XFCE, but these things are likely kept in a config file that you can edit. Tell GDM to log in to a failsafe xterm, cd in to your ~/.config directory and see if there's anything that looks promising.

This document might help you figure it out. Particularly, check the Advanced section.

http://www.xfce.org/documentation/4.2/manuals/xfce4-session

good luck,

LowSky
April 23rd, 2009, 08:29 PM
do you mean Failsafe Gnome? cus if so my machine doesn't have the resources to run Gnome

whoops you using XFCE, I need to read better.

ok other suggestion

boot into recovery mode, choose boot to terminal option, log in then type startx

Sir Jasper
April 23rd, 2009, 08:38 PM
Hi,

I can only suggest you have a look at your settings:

Settings>Settings Manager>2nd Icon [Button Label Sessions and start up].

My regards

kanikilu
April 23rd, 2009, 08:44 PM
I haven't tried this yet myself (pretty new to XFCE), so instead of removing, to be on the safe side, just move the sessions cache folder:
mv ~/.cache/sessions ~/.cache/sessions-backup