PDA

View Full Version : [ubuntu] nvidia resolution limited to 640x480



matrixunloaded
April 23rd, 2009, 06:34 PM
I am still a newbie, but just upgraded Intrepid to Jaunty. I am sure it is something dumb I am doing, but any help would be appreciated. My screen resolution is limited to a maximum of 640x480 despite having installed the following:

GeForce 7600 GS
2.6.28.11 #42 kernel
nVidia driver 180.44 (which I installed via Envy and then removed and reinstalled after upgrade)

So it looks like I have the nVidia driver installed. My only thought is it might have something to do with xorg.xconf, which I am afraid to edit at my level of knowledge.

xorg.conf is as follows:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "Emulate3Buttons" "true"
#EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
Gamma 1.0
EndSection

Section "Monitor"
Identifier "monitor1"
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Virtual 640 480
Modes "640x480@60"
EndSubSection
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection

Section "Module"
Load "v4l"
Load "glx"
Disable "dri2"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "vesa"
Busid "PCI:1:0:0"
Screen 0
Driver "nvidia"
EndSection

Section "Device"
Identifier "device1"
Boardname "vesa"
Busid "PCI:1:0:0"
Screen 1
Driver "nvidia"
EndSection

starcannon
April 23rd, 2009, 07:29 PM
In case you get stuck at a CLi be sure to print or write this down.
Okies well I would recommend:


cp /etc/X11/xorg.conf ~/xorg.conf.backup
okies that has your xorg.conf file backed up, so now:


sudo rm /etc/X11/xorg.conf
That removed your xorg.conf from your X11 directory, don't worry were gonna let nvidia write you a new one, and if it fails, we can always restore it from the back up we made before we started.


sudo nvidia-xconfig
You should recieve a message saying it couldn't find the old one and that it wrote a new one (of the xorg.conf).
Reboot, if all went well you should be getting a better resolution, or at least have the resolution you want available in System>Preferences>Screen Resolution.

If things did not work as intended, then we'll restore your old xorg.conf; at a command line:


sudo cp ~/xorg.conf.backup /etc/X11/xorg.conf

That restored your xorg.conf file using the backup we made at the beginning of this post.

Now its time to reboot


sudo reboot
In your original post, wrap that xorg.conf in code tags if you don't mind :)