PDA

View Full Version : [ubuntu] Microphone on acer 5930g



geekluca
April 22nd, 2009, 10:15 PM
Hi there,
I just installed ubuntu jaunty on my acer 5930g, I want to use skype but the microphone doesn't work,sound recorder also doesnt't work...here my alsamixer, alsamixer -V all, and my sound preference...
what can I do? ):P

geekluca
April 23rd, 2009, 10:26 AM
Up!:)

geekluca
April 23rd, 2009, 07:04 PM
up!

geekluca
April 28th, 2009, 03:11 PM
c'mon no one can help me??

geekluca
April 28th, 2009, 11:09 PM
i can't believe....this forum is huge...anyone can help me?

eju
April 29th, 2009, 05:59 PM
I also had the same problem with microphon on skype application,
there is some disscusion about these issue that i read them already but they don't work on my IBM R50e, May be they work for you
in ubuntu forum (http://ubuntuforums.org/showthread.php?t=1133973&highlight=skype)
and in idyllictux (http://idyllictux.wordpress.com) wordpress blog

geekluca
May 4th, 2009, 05:54 PM
Thanks, but nothing change, I just upgrade alsa, but how can I configure it to work with my microphone?someone help me

geekluca
May 15th, 2009, 03:09 PM
Help!

geekluca
May 19th, 2009, 04:11 PM
up!

ptihibou
May 20th, 2009, 01:49 PM
You might want to try this:

Go to www.alsa-project.org (http://www.alsa-project.org/) and download the alsa-driver, alsa-lib, and alsa-utils version 1.0.20. I did it for my AAO D150 with Ubuntu 9.04 Netbook Remix and compiled and install the drivers and now my internal mic works http://www.aspireoneuser.com/forum/images/smilies/icon_e_biggrin.gif Good luck http://www.aspireoneuser.com/forum/images/smilies/icon_e_smile.gif

geekluca
May 20th, 2009, 02:14 PM
ok thanks, but when i compile I have to add certain options?

ptihibou
May 20th, 2009, 10:29 PM
I do not think so but I am not sure as I do not know the characteristics of your machine. I would think that you just have to do, for each of the three categories

sudo ./configure --with-cards=hda-intel --with-kernel=/usr/src/linux-headers-$(uname -r)
sudo make
sudo make install

If the problem you have is due to the Alsa driver this should fix it

before you do anything you can check which version of Alsa you have by doing

cat /proc/asound/version

hope this helps ;)

geekluca
May 22nd, 2009, 02:51 PM
there is an order to install and compile alsa?

geekluca
May 22nd, 2009, 10:27 PM
It works!!!
I upgrade alsa and reboot and now it works :D thanks a lot :D

ptihibou
May 22nd, 2009, 10:39 PM
I do not exactly remember which order I used ( I think alsa-driver, then alsa-lib, then alsa-utils) but I do not think it matters. Just try it and see the results ;)

verby
May 25th, 2009, 02:49 AM
can you give instructions how to do this?


It works!!!
I upgrade alsa and reboot and now it works :D thanks a lot :D

geekluca
May 25th, 2009, 08:56 AM
just upgrade alsa,in this order
alsa-driver
alsa-lib
alsa-utils
with the option
sudo ./configure --with-cards=hda-intel --with-kernel=/usr/src/linux-headers-$(uname -r)
sudo make
sudo make install
for every file
after you upgrade, reboot
and then here's my alsamixer, so you can check the same option, in audio record i use capture 1 and in skype I use Default device for audio in
for audio out and ringing I use HDA Intel(hw:Intel,0)

verby
May 26th, 2009, 06:59 AM
sudo ./configure --with-cards=hda-intel --with-kernel=/usr/src/linux-headers-$(uname -r)

can you explain this line?
do I replace uname with my name?

geekluca
May 26th, 2009, 03:18 PM
no...just unpack the tar.gz file, then open a terminal and with the command

cd PATH OF THE DIRECTORYmove to the directory where you unpack the file, than copy and paste the command in the terminal

sudo ./configure --with-cards=hda-intel --with-kernel=/usr/src/linux-headers-$(uname -r)and hit enter, when the command stops, write
sudo make and press enter
ant then
sudo make install and press enter
for every alsa...first alsa-driver, then alsa-lib and then alsa-utils

xzinkx
October 7th, 2010, 04:56 PM
is it safe for me just to run this .deb version of alsa-driver instead of compiling it myself? http://ftp.debian.org/pool/main/a/alsa-driver/ . Thanks, BTW also using an Acer 5930g and cant get the mic to work in skype.