PDA

View Full Version : [mythbuntu] 9.04 - where are sound preferences?



Brasil
April 20th, 2009, 02:10 PM
Hi, I have a M3N-78EM MB and I'm trying to get the HDMI sound set up in 9.04. I previously had it going in 8.10, I recall updating alsamixer then using alsamixer to unmute IEC958 and choosing the NVIDIA HDMI device (or whatever it was called in sound preferences). I have alsamixer set up ok, but I can't find sound preferences to choose HDMI as a device. I have found the mixer, it seems to have an option to choose the sound card but the only option in there is "HDA NVidia (Alsa mixer)". I've played around with all the volume levels that look like they might relate but none of them seem to help.:(

I'm a total noob here - would appreciate very simple instructions

Bölvağur
April 20th, 2009, 02:15 PM
System → Preferences → Sound

Brasil
April 20th, 2009, 02:25 PM
Sorry, should have clarified - this is Mythbuntu. I have System, but no preferences, and definitely no sound.

Bölvağur
April 20th, 2009, 02:29 PM
alt+f2 or open a terminal

write:
gnome-sound-properties

Brasil
April 20th, 2009, 02:33 PM
alt+f2 or open a terminal

write:
gnome-sound-properties

Thanks for that - I get an error "failed to run... no such file or directory"

Brasil
April 21st, 2009, 12:17 AM
Thanks for that - I get an error "failed to run... no such file or directory"

Any further tips? I'm keen to get this up and running and I must be so close!!

steve101101
April 21st, 2009, 12:22 AM
try this thread. it may help http://ubuntuforums.org/showthread.php?t=940253

Bölvağur
April 21st, 2009, 12:27 AM
ok lets try again. Now I know that mythbuntu uses xfce and that means we just have to google :P or try to remember how it was (been about a year since I used xfce)

gnome-alsamixer
xfce4-mixer (http://www.xfce.org/projects/xfce4-mixer)

yes I guess the second one is it. type it in the terminal.

Brasil
April 22nd, 2009, 11:12 AM
OK, thanks... tried that, got the mixer up but no option for the HDMI. Aplay says it's there, so does Alsamixer. As far as I can tell I've enabled it and unmuted it everywhere I need to, but it just isn't showing up as a device in xfce mixer...

OK, an update, I did speaker-test -c 2 -D plughw:0,3 and yes I get sound - but still nothing with vlc...

OK, a SECOND update, I put ALSA plughw:0,3 into myth setup and it works! Odd that i get nothing elsewhere though...

Bananasdoom
November 11th, 2010, 10:25 PM
I know that this post is really old but i am having the exact same problems, can pleas post what exactly you did.