PDA

View Full Version : [ubuntu] Nvidia Controllers - Ubuntu 9.04



Cryorus
April 19th, 2009, 10:59 PM
Hello everyone.

After googling for hours without any solution, I come here to ask.

I installed Ubuntu 9.04, now it is up to date. Everything goes good... but at the moment to activate Nvidia controllers (v 180) after rebooting the system, i get a blackscreen (no errors, no text, just black) this black screen appears after loading screen (where login screen is supposed to be), I cant change to console (control+alt+f12345567), the only way to get in is with recovery mode executing the option "xfix".

I tried uninstalling everything nvidia related and installing back again, manually and with controller manager.

At hardware controllers, where nVidia version 180, 11x, 9x should be, there is nothing.

I have nVidia FX 6200.
I will post more information if something else is requested.

Thanks in advance.

Edit:
xorg.conf made by xfix (only way to log in)

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

xorg.conf made by nvidia (when iget black screen)


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 23 15:33:27 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


Whike making the last file i get:

cryorus@cryorus-desktop:~$ sudo nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver
line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

cryorus@cryorus-desktop:~$



FIX:

:)

Found a proper fix at ~128 page on google.

What i did:

1.- Install 180 drivers with "Hardware drivers"
2.- Before reboot: sudo nvidia-xconfig
3.- sudo gedit /etc/X11/xorg.conf
4.- Replace/Add/Insert:

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "NvAGP" "1"
Option "NoLogo" "True"
Option "UseDisplayDevice" "DFP-0"
EndSection
5.- Restart x server or reboot.
6.- ??????
7.- PROFIT!

Cryorus
April 20th, 2009, 02:20 AM
bump..

richandcreamy
April 25th, 2009, 09:15 AM
I'm getting the black screen of death too on a geforce go 7600 after installing the 180.51 nvidia driver =/

clearscreen
April 25th, 2009, 11:13 PM
bump

directhex
April 26th, 2009, 12:48 AM
How, exactly, are you enabling the NVIDIA driver? Your xorg.conf looks, for want of a better word, mad. THis is mine, as created by the standard Ubuntu "Hardware Drivers" screen:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

flOOi!ghenTM
April 26th, 2009, 01:55 PM
I've been having the same issue when i enable the driver regardless of the method of installation i just get a blank screen. I'm just glad i'm not the only one maybe we can find a solution soon it would be a pity not to be able to upgrade.

Morientes
April 26th, 2009, 06:43 PM
I also have this problem!
Would be VERY nice with a fix.

Cryorus
April 26th, 2009, 09:20 PM
I enabled the drivers with over 9000 different ways.

With Hardware Drivers -> reboot -> black screen.
Installing manually -> reboot -> black screen.
envy -> reboot -> black screen
downloading from nvidia -> reboot -> black screen
trying older versions of ubuntu -> reboot -> black screen.

This different ways made different xorg.conf files, none of them worked.

I dont know what should i do next =), nothing works.

clearscreen
April 26th, 2009, 09:32 PM
I've been trying to help Cryorus to no avail...

Screen stays black regardless of anything we've tried. We've manually installied with 8.10, 9.04, through jockey, apt, etc. Tried both nvidia-xconfig and a very clean config as proposed above.

- lsmod reports nvidia module is loaded
- installation reports no errors, module is built correctly

The following is an Xorg log after doing the following:
- manually remove nvidia-* through apt
- installing build-essential and linux-headers-`uname -r`
- downloading the 180.51 driver from the nvidia website
- chmod +x on the binary
- successfully installing the driver by running the binary
- running nvidia-xconfig
- rebooting



cryorus@cryorus-desktop:~$ cat /var/log/Xorg.0.log

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux cryorus-desktop 2.6.27-11-generic #1 SMP Wed Apr 1 20:57:48 UTC 2009 i686
Build Date: 09 March 2009 10:48:54AM
xorg-server 2:1.5.2-2ubuntu3.1 (buildd@rothera.buildd)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 26 16:36:25 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81d9a40
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 4.1
X.Org XInput driver : 2.1
X.Org Server Extension : 1.1
X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0@1:0:0) nVidia Corporation NV44A [GeForce 6200] rev 161, Mem @ 0xfb000000/0, 0xe0000000/0, 0xfa000000/0, BIOS @ 0x????????/131072
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[20] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[21] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[22] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[23] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[24] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[25] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[26] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[27] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[28] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[29] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[30] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[31] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[32] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[33] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[34] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[35] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[36] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[37] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[38] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[39] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[40] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[41] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[42] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[43] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[44] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[45] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[46] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[47] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[48] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[49] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[50] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[51] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[52] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[53] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[54] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[55] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[56] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[57] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[58] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[59] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"

(WW) Warning, couldn't open module type1
(II) UnloadModule: "type1"
(EE) Failed to load module "type1" (module does not exist, 0)
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.5.2, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 180.51 Thu Apr 16 19:32:09 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "record"

(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension RECORD
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "nvidia"

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
cryorus@cryorus-desktop:~$


As you can see there's no real error other than (I believe a very common) missing type1 module. Not sure if that's the problem?


edit:

Output of lsmod:


cryorus@cryorus-desktop:~$ lsmod | grep nvidia
nvidia 7237212 0
i2c_core 31892 2 i2c_viapro,nvidia
agpgart 42184 2 nvidia,amd64_agp

Cryorus
April 26th, 2009, 11:32 PM
bump

Sixdown
April 26th, 2009, 11:37 PM
I've been getting error messages and a black screen after trying to install the driver for my 8800GTS numerous ways, uninstalling, manually, envy, whatever way.

Cryorus
April 27th, 2009, 12:52 AM
Sadly.. bump again.

RabidWeezle
April 27th, 2009, 01:53 AM
hrm, using the 8200M G with jaunty amd64 I downloaded the driver from nvidia's site, killed the x server (sudo /etc/init.d/gdm stop), ran the binary like, (sudo sh <name of nvidia driver binary for 64 bit>), it complained about not recognising the kernel, so I had it compile the thing (I did a sudo apt-get install build-essential beforehand), then had it configure xorg.conf for me, then rebooted and it worked. Hope that helps a lil.

Cryorus
April 27th, 2009, 02:08 AM
I tried the same, and i think the other guy too. Still not working :).

Thanks for posting, if you have, had or watever about this problem, bump this. :P

Cryorus
April 27th, 2009, 04:08 AM
:)

Found a proper fix at ~128 page on google.

What i did:

1.- Install 180 drivers with "Hardware drivers"
2.- Before reboot: sudo nvidia-xconfig
3.- sudo gedit /etc/X11/xorg.conf
4.- Replace/Add/Insert:

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "NvAGP" "1"
Option "NoLogo" "True"
Option "UseDisplayDevice" "DFP-0"
EndSection
5.- Restart x server or reboot.
6.- ??????
7.- PROFIT!

Morientes
April 27th, 2009, 07:30 AM
Yeah, I also found out that it's just because it outputs to my secondary monitor, a TV. Either do the above config change in xorg.conf or, if you have a secondary monitor connected, turn that on and use nvidia-settings to enable your computer display instead.

noctis_vulpes
April 27th, 2009, 07:03 PM
:)

Found a proper fix at ~128 page on google.

What i did:

1.- Install 180 drivers with "Hardware drivers"
2.- Before reboot: sudo nvidia-xconfig
3.- sudo gedit /etc/X11/xorg.conf
4.- Replace/Add/Insert:

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "NvAGP" "1"
Option "NoLogo" "True"
Option "UseDisplayDevice" "DFP-0"
EndSection
5.- Restart x server or reboot.
6.- ??????
7.- PROFIT!

This almost worked for my geForce Go 7400 - until I tried to surf the web. It seems opening up too many tabs on firefox simply crashes the machine. -_-

So close and yet so far... T^T

philip.denotto
April 27th, 2009, 07:47 PM
same problem - tried suggestions in this thread - no joy

Cryorus
April 27th, 2009, 09:19 PM
Option "UseDisplayDevice" "DFP-1"

try with 1 instead of 0.

noctis_vulpes
May 18th, 2009, 11:28 AM
Option "UseDisplayDevice" "DFP-1"

try with 1 instead of 0.

Tried this last night... no dice. I guess 96 driver is the last safe version I can use with geForce Go 7400?

Well, relatively safe that is... It seems to randomly crash my system from time to time, I'm afraid.

RabidWeezle
June 27th, 2009, 08:19 AM
new drivers just came out in june with a ton of fixes in there, might want to check them out see if it addressed your bugs. Supposedly some big changes were done on the loooong laundry list of a changelog.