PDA

View Full Version : [ubuntu] Wacom Intuos4 on Ubuntu



Pages : [1] 2

evilkillerfiggin
April 8th, 2009, 08:15 PM
I read this site: https://help.ubuntu.com/community/Wacom

The Intuos4 didn't hotplug, at all. Nothing else on that page worked either - I tried installing the two *.debs and then adding the extra sections to xorg.conf (except I didn't add the "ServerLayout" section because the words 'system' and 'unbootable' were mentioned.)

I'm running Ubuntu 8.10 on a Dell laptop, and am unsure how to proceed.

Favux
April 8th, 2009, 10:30 PM
Hi evilkillerfiggin,

You must have a "ServerLayout" section otherwise xorg.conf wouldn't boot and you wouldn't have video.

You need the "SendCoreEvents" in "ServerLayout" in order for Xserver to detect input from your Wacom stuff.

Do you still have the 0.8.1-6 deb.s installed? If you post your xorg.conf I could help you configure it.

evilkillerfiggin
April 8th, 2009, 11:15 PM
Favux: much appreciated.

I still have the 0.8.1-6s installed, and I added the example "ServerLayout" without success.

xorg.conf currently reads:







# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "gb"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizEdgeScroll" "0"
#EndSection

Section "Device"
Identifier "Configured Video Device"
Option "monitor-TV" "TV"
EndSection

Section "Monitor"
Identifier "TV"
Option "Ignore" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Option "Ignore" "false"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# commented out by update-manager, HAL is now used
# InputDevice "Synaptics Touchpad"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom" # USB ONLY?
# Option "Device" "/dev/ttyS0" # SERIAL ONLY
Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "USB" "on" # USB ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom" # USB ONLY?
# Option "Device" "/dev/ttyS0" # SERIAL ONLY
Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "USB" "on" # USB ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom" # USB ONLY?
# Option "Device" "/dev/ttyS0" # SERIAL ONLY
Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "USB" "on" # USB ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "pad"
Option "Device" "/dev/input/wacom" # USB ONLY
# Option "Device" "/dev/ttyS0" # SERIAL ONLY
Option "Type" "pad"
Option "USB" "on" # USB ONLY
EndSection

# Uncomment the following section if you you have a TabletPC that supports touch
# Section "InputDevice"
# Driver "wacom"
# Identifier "touch"
# Option "Device" "/dev/ttyS0" # SERIAL ONLY
# Option "Device" "/dev/input/wacom" # USB ONLY
# Option "Type" "touch"
# Option "ForceDevice" "ISDV4" # Serial Tablet PC ONLY
# Option "USB" "on" # USB ONLY
# EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents" # For non-LCD tablets only
InputDevice "pad" # For Intuos3/CintiqV5/Graphire4/Bamboo tablets
# InputDevice "touch" "SendCoreEvents" # Only a few TabletPCs support this type
EndSection

Favux
April 8th, 2009, 11:29 PM
Hi evilkillerfiggin,

OK, I spotted the main problem. You have two "ServerLayouts". But I also need to know if your tablet has a Wacom mouse. Also does it have a "pad"? You know the buttons and slider stuff? And is it a usb or serial tablet?

evilkillerfiggin
April 8th, 2009, 11:43 PM
It's USB. Didn't come with a mouse, but if "pad" means all the buttons on the side of the tablet then yeah, it's got those.

What should I do about these two ServerLayouts? Do I just merge them together?

Favux
April 8th, 2009, 11:54 PM
Hi evilkillerfiggin,

OK, try this:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "gb"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizEdgeScroll" "0"
#EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom" # USB ONLY?
Option "Type" "stylus"
Option "USB" "on" # USB ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom" # USB ONLY?
Option "Type" "eraser"
Option "USB" "on" # USB ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "pad"
Option "Device" "/dev/input/wacom" # USB ONLY
Option "Type" "pad"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "monitor-TV" "TV"
EndSection

Section "Monitor"
Identifier "TV"
Option "Ignore" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Option "Ignore" "false"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# commented out by update-manager, HAL is now used
# InputDevice "Synaptics Touchpad"
InputDevice "stylus" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "pad" # For Intuos3/CintiqV5/Graphire4/Bamboo tablets
EndSection
Back in a while.

evilkillerfiggin
April 9th, 2009, 02:04 AM
No joy, sadly.

Favux
April 9th, 2009, 02:57 AM
Hi evilkillerfiggin,

What does no joy mean? No boot or Wacom doesn't work after boot. The Wacom stuff is correct now (I'm sure your stylus has an eraser, doesn't it?). If it's not giving you the desktop then there may be something wrong with your video section.

And just to confirm you are using 8.10 (Intrepid), correct?

evilkillerfiggin
April 9th, 2009, 11:10 AM
Sorry: I meant no Wacom. The system boots fine. And yes, I'm using 8.10 after upgrading from 8.04 just a few weeks ago. And the Intuos4 does indeed have an eraser, yes.

Favux
April 9th, 2009, 06:53 PM
Hi evilkillerfiggin,

Good. So it boots ok, graphics are good, just no Wacom. Your xorg.conf is good so it must be something with the linuxwacom drivers. Try:

dmesg | grep [Ww]acom
and

modinfo -d [Ww]acom
especially after a fresh boot.

Are you leaving it plugged in the whole time? Actually before doing anything try the old hotplug commands.

ctrl-alt-F1 and then ctrl-alt-F7 and then see if the tablet responds.

Also try rebooting and restarting X (ctrl-alt-backspace) several times and see it the tablet responds.

You have two buttons on the stylus correct? We can configure them once Wacom is working.

evilkillerfiggin
April 9th, 2009, 08:39 PM
Yeah, it's got two buttons on the pen and then a whole bunch more on the tablet. I'm more enthusiastic about pressure sensitivity. But yeah, first things first:

Here's the output. Look hopeful?

tog@dell-desktop:~$ dmesg | grep wacom
[ 40.982194] usbcore: registered new interface driver wacom
[ 40.984292] wacom: v1.49:USB Wacom Graphire and Wacom Intuos tablet driver
tog@dell-desktop:~$ modinfo -d wacom
USB Wacom Graphire and Wacom Intuos tablet driver
USB Wacom Graphire and Wacom Intuos tablet driver


Ctrl-Alt-F1->F7 didn't help. Am about to try restarting X.

evilkillerfiggin
April 9th, 2009, 08:55 PM
Didn't work. Gave me some odd error messages, actually. It failed to load the login screen about six times, then a text-only error window came up saying, "Something bad has probably happened." Then it tried to restart a couple more times and it worked. Bemusing.

But, focussing on the stylus, no progress.

Favux
April 9th, 2009, 08:57 PM
Hi evilkillerfiggin,

Yes the output indicates the linuxwacom kernel module is there so it should be detecting usb input.

If it is still not working there may be a problem with your symlinks. See if the file “50-xserver-xorg-input-wacom.rules” or something similar is present in “/etc/udev/rules.d/”.

evilkillerfiggin
April 9th, 2009, 09:00 PM
Yep, it's there.

Favux
April 9th, 2009, 09:05 PM
Ok, see what the output of:

more /proc/bus/input/devices
In the output should be at least one section labeled Wacom. Your vendor and product ID should be in it. The vendor ID for Wacom is Vendor=056a. Check to see that your product ID is in the big "table" in “50-xserver-xorg-input-wacom.rules”.

I keep wondering if something is hinky with your video setup and the newer kernel.

Do you have any other usb devices plugged in? Is there a hub or is the tablet plugged into a usb hub?

evilkillerfiggin
April 9th, 2009, 09:30 PM
It's not there. Here's what /proc/bus/input/devices says:






tog@dell-desktop:~$ more /proc/bus/input/devices
I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input0
U: Uniq=
H: Handlers=mouse0 event0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input1
U: Uniq=
H: Handlers=kbd event1
B: EV=120013
B: KEY=8000 0 0 0 0 0 500f 2102002 380307c f810d001 feffffdf ffefffff ffffffff f
fffffff
B: MSC=10
B: LED=7

I: Bus=0003 Vendor=045e Product=0040 Version=0110
N: Name="Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)"
P: Phys=usb-0000:00:1d.0-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb4/4-1/4-1:1.0/input/input2
U: Uniq=
H: Handlers=mouse1 event2
B: EV=17
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103
B: MSC=10

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input3
U: Uniq=
H: Handlers=event3
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button (CM)"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input4
U: Uniq=
H: Handlers=kbd event4
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button (CM)"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input5
U: Uniq=
H: Handlers=kbd event5
B: EV=3
B: KEY=4000 0 0 0 0

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=/video/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A03:00/device:2e/input/input6
U: Uniq=
H: Handlers=kbd event6
B: EV=3
B: KEY=3f000b 0 0 0 0 0 0 0

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=/video/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A03:00/device:33/input/input7
U: Uniq=
H: Handlers=kbd event7
B: EV=3
B: KEY=3f000b 0 0 0 0 0 0 0

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name="PC Speaker"
P: Phys=isa0061/input0
S: Sysfs=/devices/platform/pcspkr/input/input8
U: Uniq=
H: Handlers=kbd event8
B: EV=40001
B: SND=6

I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="PS/2 Mouse"
P: Phys=isa0060/serio2/input1
S: Sysfs=/devices/platform/i8042/serio2/input/input9
U: Uniq=
H: Handlers=mouse2 event9
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=7321
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio2/input0
S: Sysfs=/devices/platform/i8042/serio2/input/input10
U: Uniq=
H: Handlers=mouse3 event10
B: EV=f
B: KEY=420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=1000003







The only other USB device plugged in is a mouse.

Favux
April 9th, 2009, 09:38 PM
Hi evilkillerfiggin,

OK maybe some progress. The system doesn't recognize your attached tablet. We know the linuxwacom kernel driver wacom.ko is present but must not be receiving any input since your tablet isn't registering.

To rule out a hardware problem do you have Windows? Does your tablet work in Windows?

evilkillerfiggin
April 9th, 2009, 10:05 PM
Yeah, it worked the other day on an XP machine.

Favux
April 9th, 2009, 10:22 PM
Alright, that's good. We know your tablet and its usb connector are OK.

So try plugging it in to another usb port. Try booting with it unplugged and then plugging it in. Try booting with it plugged. And keep restarting X with each attempt.

It looks like it may be some sort of usb problem/confusion with 8.10. I'm not going to be able to help you much with that. See if anything turns up with a search on usb problems with Intrepid.

evilkillerfiggin
April 9th, 2009, 10:59 PM
Doesn't make a difference which USB port I use, nor when I plug the thing in - I've tested both those before.

Googling doesn't show up anything that fits these symptoms. Most wacom how-tos seem to assume the stylus works with hotplugging. I have to confess I don't understand the majority of what I'm reading.

Favux
April 9th, 2009, 11:06 PM
Hi evilkillerfiggin,

At this point I'm not sure the linuxwacom drivers have anything to do with it. I'm leaning more toward there being something messed up with your usb configuration. See if you see the anything hinky with usb and whether you see your tablet with:

sudo lspci
and

sudo lsusb

evilkillerfiggin
April 10th, 2009, 12:59 AM
Neither shows anything Wacom. lsusb just shows me a mouse and seven instances of 'Linux Foundation root hub'.

So what's the next stage?

Favux
April 10th, 2009, 04:37 AM
Hi evilkillerfiggin,

Well it looks to me like something is messed up with Ubuntu Intrepid's usb on your Dell laptop. I don't understand why, since your mouse is recognized. You can hope someone else joins this thread, but they'll think its some wacom thing given the title, so...

So you want to start another thread on either Installation & Upgrades or Hardware & Laptops. Title it something like "USB device not recognized in Intrepid". Give the hardware details of your laptop and tablet and you have the output of lspci and lsusb (use the "#" above to wrap the output in code tags). Then hope some hardware guru who understands usb will help you. That way we'll both learn.

At the worst you would rule out a usb problem and we be back to a linuxwacom problem. Meanwhile I can try and see if there is something I missed.

PS: I just realized something. When you said it worked in XP you meant another machine? You don't have Windows on your Dell laptop? So we've ruled out hardware failure in the tablet but not with your Dell lappies usb ports? Do you have another usb device that you know works you can plug into the port the tablet is in? Have your tried plugging the tablet in the port the mouse is in?

PPS: Is the usb on your Intuos4 2.0 or higher? Is the usb on your Dell 1.1? Because I bet the mouse is only 1.1.

Favux
April 10th, 2009, 08:55 AM
Hi evilkillerfiggin,

I may have found an error in xorg.conf. Instead of:

Section "InputDevice"
Identifier "pad"
Driver "wacom"
Option "Device" "/dev/input/wacom" # USB ONLY
Option "Type" "pad"
EndSection
it may suppose to be:

Section "InputDevice"
Identifier "pad"
Driver "wacom"
Option "Device" "/dev/input/wacom" # USB ONLY
Option "Type" "pad"
Option "USB" "on" # USB ONLY
EndSection

evilkillerfiggin
April 10th, 2009, 03:14 PM
I have no idea what's the difference between USB 1.1 and 2.0, but my USB scanner runs fine under xsane.

Tried that xconf edit you suggested, but no luck.

I'll go ahead and start that thread now, then.

evilkillerfiggin
April 10th, 2009, 03:20 PM
Belay that - I was being an idiot.


lsusb shows me:


tog@dell-desktop:~$ lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 004: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub




It seems all the USB ports on my laptop are 1.1. I have no idea what those two 2.0s are, or where they are physically. Am now very confused.

Favux
April 10th, 2009, 07:19 PM
Hi evilkillerfiggin,

Hopefully you can figure out which ports connect to the usb 2.0 hub. If your tablet is usb 2.0 (which I suspect) that's what you want to plug into.

Obviously a 2.0 port will handle a 2.0 connector and a 1.1 connector, but a 1.1 port won't handle a 2.0 connector. I'm hoping that has been the problem.

evilkillerfiggin
April 10th, 2009, 07:24 PM
The problem is, I've only got four USB ports on the outside of my computer, and they're all 1.1...

Favux
April 10th, 2009, 07:37 PM
Hi evilkillerfiggin,

It sounds like you've verified that the Intuos4 is usb 2.0. Since Intrepid is reporting a 2.0 hub then there is probably one on your motherboard. It's possible it's in use internally already. But it's also possible that Dell has a little usb kit you could use for your motherboard and hook it up and then use the kit's connector to lead to external usb 2.0 connectors. Not very likely with a laptop admittedly. You need the laptop and motherboard manual, should be available on Dell's website, and maybe a visit to your friendly neighborhood computer store.

evilkillerfiggin
April 10th, 2009, 08:14 PM
Wow. Sounds like fun indeed.

I'll go and do that then. Favux, you've spent a lot of time and been very helpful, it's really appreciated.

Wish me luck.

Favux
April 10th, 2009, 08:26 PM
Hi again evilkillerfiggin,

You are welcome. Good luck!

sanette
April 14th, 2009, 11:14 PM
I finally got the intuos4 to work in intrepid
but I had to recompile the kernel and the xorg wacom drivers.

evilkillerfiggin
April 15th, 2009, 09:47 PM
sanette: can you provide some details? I've never compiled a kernel before...

I can confirm that the Intuos4 doesn't work on my laptop running 8.10, doesn't work on a desktop running 8.04, but DOES work on a desktop running 6.06 Dapper Drake.

In the case of the laptop at least, the only remotely pertinent thing I could get out of Dell was that there is nothing wrong with the hardware.

sanette
April 16th, 2009, 10:38 AM
I have also a Dell laptop (d630)

here is what I have done (in fact I have tried several things, I'm just trying to summarize what seems useful)

in fact I was not clear. You do not need to compile the kernel, just the wacom kernel module.

1. get linuxwacom-0.8.3-2.tar.bz2 from http://linuxwacom.sourceforge.net/
(this is the development version)

2.
tar xvf linuxwacom-0.8.3-2.tar.bz2

3.
cd linuxwacom-0.8.3-2/

4.
./configure --enable-wacom

(this will work only if you have installed the package xorg-dev

5.
make

6.
sudo make install

For some reason this was not enough for me. I had to copy manually
the file
src/2.6.27/wacom.ko
in to the proper location:
/lib/modules/2.6.27-11-generic/kernel/drivers/input/tablet/wacom.ko

then also I added an entry in
/etc/udev/rules.d/50-xserver-xorg-input-wacom.rules
but this is probably unnecessary.

7. restart. It should work. (well the xorg.conf should be configured, too.)


Hope this helps !

sanette
April 16th, 2009, 10:52 AM
Here are the results of my compilation.
(see attached archive wacom.tar.gz)

If you are lucky, you don't need to compile anything yourself, just copy the files !

sanette
April 16th, 2009, 11:24 AM
Btw, I confirm that modifying the file
/etc/udev/rules.d/50-xserver-xorg-input-wacom.rules
is not necessary. It might even be a bad idea, since as far as I can see what it does is to add an entry in /dev/input, while
the wacom driver has already added /dev/input/wacom

I was glad to see that the tablet buttons are recognized.
Even the touch ring, which works as a mouse wheel.
(without having to configure it with wacomcpl)

However I don't know how to get the "precision" button to work. It is supposed to slow down the pointer motion while pressed, in order to get pixel-refined motion.

Favux
April 16th, 2009, 08:31 PM
Hi evilkillerfiggin,

If I understand sanette he's saying linuxwacom 0.8.1-6 doesn't handle your Intuos 4. But sanette did you try any other linuxwacom driver version?

You may want to go here: http://ubuntuforums.org/showthread.php?t=1038949 and compile the HOW TO default driver 0.8.2-2. The 0.8.3-2 is a development branch driver, the first to work with Jaunty. Just a thought.

But if this is really a usb problem...

evilkillerfiggin
April 16th, 2009, 10:36 PM
It works. WOOOO!

For some reason it's calibrated upside down. But I am in no way complaining, thanks very much sanette.

Favux: I've been assured that there's nothing wrong with the hardware. Plus it's now working and I've made no changes except those files of sanette's.

Thanks again everyone - now I'm off to find out how to set this thing up properly.

evilkillerfiggin
April 16th, 2009, 10:59 PM
.

sanette
April 17th, 2009, 07:52 AM
evilkillerfiggin: it's upside-down because I am left-handed...

just remove the
Option "Rotate" "HALF" # left-hand
lines in my xorg.conf

I'm glad it worked for you too !

;)

sanette
April 17th, 2009, 07:57 AM
favux:

of course I first tried with the packaged ubuntu wacom drivers, which are
wacom-tools and
xserver-xorg-input-wacom (8.1.4)
and they didn't work.

but you're right I haven't tried to compile 8.2. You suggest that 8.2 would be better than 8.3 ?

indeed I have some problem with 8.3: it seems that I cannot change the config of the tablet buttons
(luckily the touch ring already works)

Favux
April 17th, 2009, 09:20 AM
Hi sanette,

And we know 0.8.1-6 doesn't work.

I don't know that 0.8.2-2 is better, I just wondered whether it had had enough improvement to to get your Intous4 to work. It is the production branch and has been out a couple of months. And you configure your tablet through xorg.conf. Which is well understood. Or use something like Wacom Express Keys.

The development branch driver 0.8.3-2 has been out for about a week. It is the first one to work with Jaunty and now has the HAL features. That means you configure it through the 10-wacom.fdi file. If you try xorg.conf you will most likely break X. You can compile it without libhal1-dev installed, in which case you can use xorg.conf.

So that's why you can't change your tablet button config. You need to do it using the html in the .fdi file. At least that's what I assume the problem is. Plus as a first I guess we don't know how stable it is.

sanette
April 17th, 2009, 01:29 PM
Hi Favux

thanks for the explanations.
So I've just tried 0.8.2-2, and it does *not* work for my intuos4.
It seems that the wacom kernel module is faulty because there is no
/dev/input/wacom created.

On the other hand the 0.8.3 kernel driver + 0.8.2 Xorg driver does work...
(except that "pad" is not recognized by wacomcpl)

Is there any reference for configuring
/usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi ?

Favux
April 17th, 2009, 07:41 PM
Hi sanette,

That's interesting. I'm glad you investigated. I see I forgot to mention the reason for the shift to HAL. The idea is to allow usb hotplugging. This is obviously useful for those with external usb graphics tablets, but not so important to those of us with tablet pc's. For us this has mainly been a pain.

It's been six months since I started learning the .fdi stuff. Then it turned out it wasn't going to work for us in Intrepid after all. So I have forgotten some of what I learned. Part of the problem is I haven't seen any good stuff on writing .fdi's. Here's some: https://help.ubuntu.com/community/Wacom.fdi and https://wiki.ubuntu.com/X/Config/Input If you find a good source please let me know.

So what we've done is collect examples starting on post #70 here: http://ubuntuforums.org/showthread.php?t=1038949&page=7 It turns out it isn't all that difficult to translate the xsetwacom commands into .fdi html. You can see some examples of us doing that. It would be nice if we had some manual explaining all the allowed terms/commands etc.

Additionally you'll see where we link to the thread where rec figures out the problem in Timo's patched 0.8.2-2 and 0.8.3-2 compiled with the libhal1-dev. The callout in the .fdi file is not returning names that linuxwacom recognizes. So he made a script to translate them. I renamed rec's script wacom-names and the original is on the link to his thread.

Good luck!

sanette
April 17th, 2009, 09:45 PM
Hi Favux

thanks for the links. I've been able to configure the stylus in the FDI file
(for instance to keep it left-handed if I plug-out/in the USB cable), but, as they say in one of your links: "only the stylus will work"

So I still don't know how to properly configure the tablet buttons :(
Any clue for this ?

Favux
April 17th, 2009, 10:18 PM
Hi sanette,

Well a clue about sums it up. But we can try.

First what's working? Does your eraser work? Does your stylus have buttons? How many? Do they work?

Do you have an xorg.conf where you configured everything? If so attach it with your current 10-wacom.fdi file.

Edit: Actually thinking about it there may be another way to go. Have you ever used "wacomcpl" to calibrate your tablet? It comes with wacom-tools. When you type it in a terminal a gui should pop up. On the left should be a column with stylus, eraser, cursor (if you have the Wacom mouse), and pad in it. When you click on the entries there are options to calibrate and configure. It saves its settings in a hidden file .xinitrc in your /home/username directory.

Also I may have missed what you meant by "no /dev/input/wacom created". Do you mean that that didn't work in xorg.conf? What that means is the file “50-xserver-xorg-input-wacom.rules” probably wasn't present in “/etc/udev/rules.d/”. So your Wacom symlinks weren't present. If so to get it set up follow appendix 3 here: http://ubuntuforums.org/showthread.php?t=1038949

sanette
April 18th, 2009, 09:10 AM
Hi Favux

I don't want to take too much of you time, because almost everything works, but here it is:

My xorg.conf was included in one of my previous post; I attach it again.
I attach also

/usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi
(this comes from the initial ubuntu package)

/usr/share/hal/fdi/policy/20thirdparty/10-wacom-stylus.fdi
(this one comes from the 8.3 driver; I've just added one line for rotation)

/usr/share/hal/fdi/policy/20thirdparty/10-wacom-eraser.fdi
(this one is a naive attempt of mine for configuring the eraser; this doesn't work at all)


After a fresh start of X

The stylus work, the eraser work
the 2 buttons of the stylus work
(one as the middle mouse button, the other as the right mouse button)
The touch ring on the tablet works (as a mouse wheel)

BUT:
the other buttons of the tablet work partially:
if I use the touch ring, then after this I can press a button, as it has some effect. But if I press the button again, it is not responsive anymore. I can get an anwser from it again after using the touch ring.
This can be verified also using "xev".

xsetwacom and wacomcpl don't work for assigning a KEYSTROKE to a button.
However assigning a mouse button works.

example:

xsetwacom set stylus Button1 "button 3"
works as expected, but

xsetwacom set stylus Button1 "core key Up"
has just the effect to disable the button.

(same for the pad buttons)

After pluging out/in the USB cable

The stylus works. The rotate option that I put in the FDI file is recognized.

BUT
The eraser does not work
No button on the tablet work.
(the touch ring doesn't work either)




Concerning the 8.2 driver:

* it is loaded at boot time
(i can see the message in dmesg)

* but the tablet doesn't work and Xorg.0.log complains that
/dev/input/wacom does not exist (which is true indeed)

Wherease if I just replace wacom.ko by the one I have obtained from 8.3 driver, it works.

In both cases the file
/etc/udev/rules.d/50-xserver-xorg-input-wacom.rules
is present.

sanette
April 18th, 2009, 09:16 AM
Here are the files.

Favux
April 18th, 2009, 09:25 AM
Hi sanette,

Your attachments didn't load (never mind there they are). Having to use the 0.8.3-2 wacom.ko in place of the wacom.ko with 0.8.2-2 is something gali98 had to do too. Before we get too far into things how about looking at post #104 here: http://ubuntuforums.org/showthread.php?t=1038949&page=11 Go to section 2 and consider installing the xsetwacom script wacomtohal if it makes sense to you to do so. Or the wacom-names version of it in post #93 on the page before, because it has the instructions inside it. With luck this may clear up your configuration and hotplugging problem at least partially. I'm not sure where the hotplug starts initiating events.

sanette
April 18th, 2009, 09:28 AM
another remark:

after pluging out/in the USB cable,

xsetwacom set stylus Button1 "button 3"

has no effect at all.

In fact xsetwacom in general seems to have no effect after pluging out/in the USB cable.

Favux
April 18th, 2009, 10:06 AM
Hi sanette,

I may not have been too clear. What I mean is that if you try the script then comment out all the Wacom stuff in your xorg.conf. Don't forget "ServerLayout". Then see if the standard 0.8.2-2 .fdi works for you through a hotplug. Ideally we would like to configure it further through wacomcpl. But if those configurations don't survive through a hotplug then we may have to use the 10-wacom.fdi.

Favux
April 18th, 2009, 10:23 AM
Apologies. Belated afterthought which I should have mentioned first. If you want to keep xorg.conf try the old hot plug commands after you hot plug. First ctrl-alt-F1 and then ctrl-alt-F7.

sanette
April 20th, 2009, 07:25 PM
Hi Favux

I will definitely try what you say, but I will be too busy for the next two or three days.

sanette
April 27th, 2009, 03:58 PM
mmm. now I've upgraded to jaunty, and nothing works anymore :(

sanette
April 27th, 2009, 04:42 PM
more details

after upgrading to jaunty, if I plug in my Intuos 4, nothing happens.
sudo modprobe wacom does not help either.

I noticed that everything in my xorg.conf concerning wacom has been commented out. If I remove the comments and restart X, then it crashes.
So I leave the commented version.

Then I've compiled the wacom 0.8.3 driver and replaced the wacom.ko module. And restart. Nothing happens !
However, if I do manually
sudo modprobe wacom
then I can see in dmesg that the driver is loaded, and when I plug-in the tablet, it is properly recognized (and linked to /dev/input/event12

And the tablet works ! (I do have the .fdi files of my previous experiments, but nothing more)

Well, in fact, X crashed after 2 minutes, when I tried to open firefox.

After several reboots I have been able to open gimp before it crashes, but it seems that pressure and tilt is not recognized.

... and of course the main issue is that X become VERY unstable. Crashes after a couple of minutes when I open apps.

sanette
April 27th, 2009, 07:08 PM
well in fact it is not so bad.

Pressure sensitivity is there, and tilt too. I have been fooled (again) by the fact that the names of the input devices in gimp has changed, so gimp would not recognized them until I re-configured them properly.

Concerning stability, well I've been now running a session for a couple of hours without problem (the session beginning with the 'sudo modprobe wacom'.... Don't know why. Fingers crossed !

Favux: I've not tried yet the /etc/init.d/ rename script that you were mentioning. That will be next step.

Favux
April 27th, 2009, 08:13 PM
Hi sanette,

Looks like solid progress. To give you another option Tom Jaeger posted on the LWP Saturday another way to get the names, instead of using the script. They're not translated so you may have to rename things. But what you do is instead of using "xsetwacom list", which will be empty, you use "xinput --list". And use the "names" that gives you. From: http://sourceforge.net/mailarchive/forum.php?thread_name=cc6cabec0904250703t5dd70a81t 39160dcbb62d1031%40mail.gmail.com&forum_name=linuxwacom-discuss

I think the script makes more sense rather that renaming things. If they fix things then you'd have to go back and rename them again. I guess it depends on how many you have to change.

sanette
April 28th, 2009, 09:41 AM
Hi Favux

thanks for "xinput --list"
I didn't know this. Very useful.

Is it possible not to have to type manually "sudo modprobe wacom" ?
(in intrepid I didn't have to do it, the driver was loaded at boot time)

Favux
April 28th, 2009, 08:29 PM
Hi sanette,

Good deal. Tom's sharp and I think his EasyStroke is a good program.

Yes, I've run into wacom module not loading in Intrepid before and have a couple of fixes described in step 7) of section 1 here: http://ubuntuforums.org/showthread.php?t=1038949 Let me know if one of them works for you.

sanette
May 5th, 2009, 08:43 AM
Hi Favux

thanks for the links. Adding wacom to /etc/modules does the trick. I should have remembered this !
Hope there is no side-effect.

Favux
May 5th, 2009, 09:17 AM
Hi sanette,

None I know of.

geek0101
May 9th, 2009, 02:36 PM
Hello,

I'm a noob with a intuos4 currently running jaunty. My os will not detect my intuos4.

I've tried intrepid and using the xorg.conf procedure. No luck. So, now I'm tring jaunty and the fdi procedure.

I've issued the command lspci and wacom is not listed.
I've done "tail -f /var/log/messages" and plugged the intuos4 in and out. It displays usb messages with no "wacom?" It display usb 3-2....

Any help would be greatly appreciated.

I think this should be a new thread but I cann't find or don't have that feature yet.

Thank you!!

Favux
May 9th, 2009, 07:02 PM
Hi geek0101,

After the painful learning process evilkillerfiggin, sanette and I went through I think I can help.

The Intous4 has only been out a couple months. Apparently because it is so new (according to the LWP changelogs) the 0.8.3 development branch are the first versions of the linuxwacom drivers that support the Intous4. However sanette showed all you really need is the usb kernel driver, wacom.ko, from the 0.8.3 branch.

So you can keep the default Jaunty 0.8.2-2 linuxwacom packages. All you do is replace the 0.8.2-2 wacom.ko with the 0.8.3-3 wacom.ko. This is good news because they have been specially patched to support the HAL/.fdi method, which you are supposed to use in Jaunty. Even better news is that I have a .fdi that I think will work for your tablet.

First go to gali98's HOW TO on page 11 post #104 here: http://ubuntuforums.org/showthread.php?t=1038949&page=11 Just like he does you want to compile linuxwacom 0.8.3-3 but not install it. Like he does copy the 0.8.3-3 wacom.ko to the new location. Now your tablet should be recognized after a reboot.

Next step is to get a working .fdi. Try the .fdi in post #176 here: http://ubuntuforums.org/showthread.php?t=967147&page=18 My bet is it will work for you and you should be able to complete configuration through wacomcpl.

Good luck!

geek0101
May 9th, 2009, 09:19 PM
Hello Favux,

I'm not getting a wacom.ko? For I know not what I'm needing to look for. I went by the thread and post(#104). I tried to start fresh by deleting out all extracted files, reinstalling wacom-tools, and re-install wacom-...-input... package, and downloading the latest: "linuxwacom-0.8.3-4.tar.bz2." There is a 3-4 version now.

I've attached a file of the output : "outputx.txt"

I need to figure out how to paste it in a reply properly(per this forum). Sorry.

I cut some of the output out, but I hope you or another ubuntu member can tell why I'm not compiling a wacom.ko.

I understand about putting the compiled into the older files place.

Thank YOU!!

just in case, output:

sachmo@sachmo-desktop:~/Desktop/linuxwacom-0.8.3-4$ ./configure --enable-wacom
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
...
configure: creating ./config.status
config.status: creating Makefile
config.status: creating mkxincludes
config.status: creating src/Makefile
config.status: creating src/util/Makefile
config.status: creating src/xdrv/Makefile
config.status: creating src/2.6.9/Makefile
config.status: creating src/2.6.10/Makefile
config.status: creating src/2.6.11/Makefile
config.status: creating src/2.6.13/Makefile
config.status: creating src/2.6.14/Makefile
config.status: creating src/2.6.15/Makefile
config.status: creating src/2.6.16/Makefile
config.status: creating src/2.6.18/Makefile
config.status: creating src/2.6.19/Makefile
config.status: creating src/2.6.22/Makefile
config.status: creating src/2.6.24/Makefile
config.status: creating src/2.6.26/Makefile
config.status: creating src/2.6.27/Makefile
config.status: creating src/2.6.28/Makefile
config.status: creating src/wacomxi/Makefile
config.status: creating src/wacomxi/wacomcpl
config.status: creating src/include/xdrv-config.h
config.status: src/include/xdrv-config.h is unchanged
config.status: creating src/include/kernel-config.h
config.status: src/include/kernel-config.h is unchanged
config.status: creating src/include/util-config.h
config.status: src/include/util-config.h is unchanged
config.status: executing depfiles commands

----------------------------------------
BUILD ENVIRONMENT:
architecture - i486-linux-gnu
linux kernel - yes 2.6.28
module versioning - no
kernel source - yes /lib/modules/2.6.28-11-generic/build
XFree86 source - no
Xorg SDK - yes /usr/include/xorg
XSERVER64 - no
dlloader - yes
XLib - yes /usr/lib
xf86config - no
TCL - yes /usr/include/tcl8.4
TK - yes /usr/include/tcl8.4
ncurses - yes

BUILD OPTIONS:
wacom.o - yes
wacdump - yes
xidump - yes
libwacomcfg - yes
libwacomxi - yes
xsetwacom - yes
hid.o - no
wacom_drv.so - yes /usr/lib/xorg/modules/input
wacom_drv.o - no
wacom*_drv quirks - Uninit-called IsXExtensionPointer key-events dixScreenOrigins
----------------------------------------
sachmo@sachmo-desktop:~/Desktop/linuxwacom-0.8.3-4$ make
Making all in src
make[1]: Entering directory `/home/sachmo/Desktop/linuxwacom-0.8.3-4/src'
Making all in .
make[2]: Entering directory `/home/sachmo/Desktop/linuxwacom-0.8.3-4/src'
rm -f wacom.4x.gz
gzip -9c < ./wacom.4x > wacom.4x.gz
make[2]: Leaving directory `/home/sachmo/Desktop/linuxwacom-0.8.3-4/src'
Making all in wacomxi
make[2]: Entering directory `/home/sachmo/Desktop/linuxwacom-0.8.3-4/src/wacomxi'
/bin/bash ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I../../src/include -Wall -g -O2 -I/usr/include/tcl8.4 -MT wacomxi.lo -MD -MP -MF .deps/wacomxi.Tpo -c -o wacomxi.lo wacomxi.c
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I../../src/include -Wall -g -O2 -I/usr/include/tcl8.4 -MT wacomxi.lo -MD -MP -MF .deps/wacomxi.Tpo -c wacomxi.c -fPIC -DPIC -o .libs/wacomxi.o
In file included from wacomxi.c:29:
wacomxi.h:31:35: error: X11/extensions/XInput.h: No such file or directory
In file included from wacomxi.c:29:
wacomxi.h:150: error: expected specifier-qualifier-list before ‘XDevice’
wacomxi.c: In function ‘GetDisplayInfo’:
wacomxi.c:68: error: ‘XDeviceInfoPtr’ undeclared (first use in this function)
wacomxi.c:68: error: (Each undeclared identifier is reported only once
wacomxi.c:68: error: for each function it appears in.)
wacomxi.c:68: error: expected ‘;’ before ‘device_list’
wacomxi.c:72: error: ‘XAnyClassPtr’ undeclared (first use in this function)
wacomxi.c:72: error: expected ‘;’ before ‘any’
wacomxi.c:73: error: ‘XKeyInfoPtr’ undeclared (first use in this function)
wacomxi.c:73: error: expected ‘;’ before ‘k’
wacomxi.c:74: error: ‘XButtonInfoPtr’ undeclared (first use in this function)
wacomxi.c:74: error: expected ‘;’ before ‘b’
wacomxi.c:75: error: ‘XValuatorInfoPtr’ undeclared (first use in this function)
wacomxi.c:75: error: expected ‘;’ before ‘v’
wacomxi.c:104: error: ‘INAME’ undeclared (first use in this function)
wacomxi.c:115: error: ‘device_list’ undeclared (first use in this function)
wacomxi.c:115: error: expected ‘;’ before ‘XListInputDevices’
wacomxi.c:126: error: ‘DeviceInfoStruct’ has no member named ‘xdev’
wacomxi.c:127: error: ‘DeviceInfoStruct’ has no member named ‘id’
wacomxi.c:128: error: ‘DeviceInfoStruct’ has no member named ‘name’
wacomxi.c:129: error: ‘DeviceInfoStruct’ has no member named ‘core’
wacomxi.c:129: error: ‘IsXExtensionDevice’ undeclared (first use in this function)
wacomxi.c:130: error: ‘IsXPointer’ undeclared (first use in this function)
wacomxi.c:131: error: ‘DeviceInfoStruct’ has no member named ‘x_index’
wacomxi.c:132: error: ‘DeviceInfoStruct’ has no member named ‘y_index’
wacomxi.c:133: error: ‘DeviceInfoStruct’ has no member named ‘num_axes’
wacomxi.c:134: error: ‘DeviceInfoStruct’ has no member named ‘num_keys’
wacomxi.c:135: error: ‘DeviceInfoStruct’ has no member named ‘num_buttons’
wacomxi.c:136: error: ‘DeviceInfoStruct’ has no member named ‘focusable’
wacomxi.c:137: error: ‘DeviceInfoStruct’ has no member named ‘proximity’
wacomxi.c:138: error: ‘DeviceInfoStruct’ has no member named ‘feedback’
wacomxi.c:145: error: ‘any’ undeclared (first use in this function)
wacomxi.c:145: error: expected ‘;’ before ‘device_list’
wacomxi.c:150: error: ‘KeyClass’ undeclared (first use in this function)
wacomxi.c:151: error: ‘k’ undeclared (first use in this function)
wacomxi.c:151: error: expected ‘;’ before ‘any’
wacomxi.c:152: error: ‘DeviceInfoStruct’ has no member named ‘num_keys’
wacomxi.c:154: error: ‘ButtonClass’ undeclared (first use in this function)
wacomxi.c:155: error: ‘b’ undeclared (first use in this function)
wacomxi.c:155: error: expected ‘;’ before ‘any’
wacomxi.c:156: error: ‘DeviceInfoStruct’ has no member named ‘num_buttons’
wacomxi.c:158: error: ‘ValuatorClass’ undeclared (first use in this function)
wacomxi.c:159: error: ‘v’ undeclared (first use in this function)
wacomxi.c:159: error: expected ‘;’ before ‘any’
wacomxi.c:160: error: ‘DeviceInfoStruct’ has no member named ‘num_axes’
wacomxi.c:161: error: ‘DeviceInfoStruct’ has no member named ‘axe_info’
wacomxi.c:163: error: ‘DeviceInfoStruct’ has no member named ‘history_size’
wacomxi.c:166: error: ‘DeviceInfoStruct’ has no member named ‘axe_info’
wacomxi.c:168: error: ‘DeviceInfoStruct’ has no member named ‘axe_info’
wacomxi.c:170: error: ‘DeviceInfoStruct’ has no member named ‘axe_info’
wacomxi.c:172: error: ‘DeviceInfoStruct’ has no member named ‘axe_info’
wacomxi.c:182: warning: implicit declaration of function ‘XFreeDeviceList’
wacomxi.c: In function ‘LookupDeviceById’:
wacomxi.c:214: error: ‘DeviceInfoStruct’ has no member named ‘id’
wacomxi.c: In function ‘UpdateCoreMark’:
wacomxi.c:241: error: ‘XChangeDeviceNotifyEvent’ undeclared (first use in this function)
wacomxi.c:241: error: ‘cdne’ undeclared (first use in this function)
wacomxi.c:241: error: expected expression before ‘)’ token
wacomxi.c:256: error: ‘DeviceInfoStruct’ has no member named ‘core’
wacomxi.c:257: error: ‘NewPointer’ undeclared (first use in this function)
wacomxi.c:260: error: ‘DeviceInfoStruct’ has no member named ‘core’
wacomxi.c:264: error: ‘DeviceInfoStruct’ has no member named ‘core’
wacomxi.c:265: error: ‘NewKeyboard’ undeclared (first use in this function)
wacomxi.c:268: error: ‘DeviceInfoStruct’ has no member named ‘core’
wacomxi.c:274: error: ‘DeviceInfoStruct’ has no member named ‘core’
wacomxi.c:278: error: ‘DeviceInfoStruct’ has no member named ‘core’
wacomxi.c:290: error: ‘DeviceInfoStruct’ has no member named ‘id’
...
wacomxi.c:1591: error: expected expression before ‘)’ token
wacomxi.c:1592: error: expected expression before ‘)’ token
wacomxi.c:1597: error: ‘XDeviceMotionEvent’ undeclared (first use in this function)
wacomxi.c:1597: error: expected expression before ‘)’ token
wacomxi.c:1598: error: expected expression before ‘)’ token
wacomxi.c:1599: error: expected expression before ‘)’ token
wacomxi.c:1604: error: ‘XProximityNotifyEvent’ undeclared (first use in this function)
wacomxi.c:1604: error: expected expression before ‘)’ token
wacomxi.c:1605: error: expected expression before ‘)’ token
wacomxi.c:1606: error: expected expression before ‘)’ token
wacomxi.c:1619: error: ‘DeviceInfoStruct’ has no member named ‘valuator_cache’
wacomxi.c: In function ‘AddEventScript’:
wacomxi.c:1669: error: ‘DeviceInfoStruct’ has no member named ‘name’
wacomxi.c:1703: error: ‘DeviceInfoStruct’ has no member named ‘name’
make[2]: *** [wacomxi.lo] Error 1
make[2]: Leaving directory `/home/sachmo/Desktop/linuxwacom-0.8.3-4/src/wacomxi'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sachmo/Desktop/linuxwacom-0.8.3-4/src'
make: *** [all-recursive] Error 1
sachmo@sachmo-desktop:~/Desktop/linuxwacom-0.8.3-4$


Could this be a bug in 3-4?

Favux
May 9th, 2009, 09:36 PM
Hi geek0101,

I'm pretty sure what's happening is you are using the 0.8.3-4 tar and then using some of the HOW TO commands which say 0.8.3-3. So either download the 0.8.3-3 tar or if you want to use 0.8.3-4 make sure you change everything that has 0.8.3-3 in it to 0.8.3-4. I'd stick with 0.8.3-3 because we know it works. If you follow the HOW TO commands that's what should download.

Check Synaptics Package Manager and make sure you have the 0.8.2-2 linuxwacom packages in installed. They are xserver-xorg-input-wacom (the drivers) and wacom-tools. You want them. As you know all you want from 0.8.3-3 or 0.8.3-4 is the wacom.ko. Do that before you do the HOW TO again.

Click edit on your previous post. Click on Advanced. At the top of the text box is "#". Hover over that and you'll see it says "Wrap [code] tags etc.". Click on that and [code][code] will appear. Cut and paste the long output between them. That will box it for you.

geek0101
May 10th, 2009, 12:42 AM
Hello again,

No luck.:(

I was able to get a wacom.ko:) and moved it to "/etc/hal/fdi/policy/wacom_custom.fdi".

Curious, when I do "tail -f /var/log/messages" I get :

May 9 ...more stuff....: usb 4-1 new full speed USB device suing uhci_hcd and address 3
May 9 ...more stuff....: usb 4-1 configuration #1 chosen from 1 choice

Above happens when I plug the intuos4 in and out.

why the messages do not say "wacom" anywhere?

And when I issue the command "lspci" there is not a "wacom" anywhere?

There is Intel, nvidia, audio....

I can do a clean install in a few just 30 minutes, but I don't think that is the best track?

Any ideas?

Thank you sooooo much.

Favux
May 10th, 2009, 04:40 AM
Hi geek0101,

Good, so you successfully compiled 0.8.3-3. Correct? I don't think you need to reinstall.

Hmmm. In gali98's HOW to on page 11 post #104 once you've compiled the 0.8.3-3 wacom.ko you're suppose to (in step 6) ) copy it (cp) to "lib/modules/`uname -r`/kernel/drivers/input/tablet/" using this command:

sudo cp ./src/2.6.28/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/wacom.ko
Did you do this?

Did you check in Synaptics Package Manager that you had the 0.8.2-2 linuxwacom packages?

After that you can replace the 10-wacom.fdi at "/usr/share/hal/fdi/policy/20thirdparty/" using the new 10-wacom.fdi at post #176 here: http://ubuntuforums.org/showthread.php?t=967147&page=18 Then reboot. You could reboot after installing the new wacom.ko too.

Where did you get the "/etc/hal/fdi/policy/wacom_custom.fdi" from? The Wacom.fdi wiki? Anyway you shouldn't have a wacom_custom, it will mess up the 10-wacom.fdi.

geek0101
May 10th, 2009, 02:45 PM
Good Morning!

It looks like I didn't copy the fdi into the same place. I thought that dir was a user custom place(experimental) and not "the" place, and the correct place was "/etc/hal/fdi/policy" ?

Soooo, anyhow, I went ahead and did a fresh install of jaunty and try this again.

Back soon!

Thank you again!

Hey, :cool: I've got 4 beans!

geek0101
May 10th, 2009, 04:11 PM
:(

No go.

I did a clean install of Jaunty on my 32bit asus p4p home built system.
Intuos3 on KDE 8.10 worked.
checked synaptic and I've got 8.2.2 on the wacom-tools and wacom-input...

Compiled a wacom.ko from linuxwacom-0.8.3-3.tar and move it.
"sudo cp ./src/2.6.28/wacom.ko /lib/modules/2.6.28-11-generic/kernel/drivers/input/table/wacom.ko".

copied "Favux_Jaunty ext graphics_test_2_10-wacom.fdi.txt" on post 176 to

"/usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi"

rebooted

My intuos4 blue light stays on(the lower/closest) and doesn't go to the top light
like it does when I run photoshop in XP(I want to start using Gimp and Inkscape).

How can I test that jaunty is reading intuos4 other than usb /var/log/messages?

Thank you so much for efforts Favux !!!

:)

geek0101
May 10th, 2009, 04:21 PM
reply typo, should be:

Compiled a wacom.ko from linuxwacom-0.8.3-3.tar and move it.
"sudo cp ./src/2.6.28/wacom.ko /lib/modules/2.6.28-11-generic/kernel/drivers/input/tablet/wacom.ko".

Favux
May 10th, 2009, 09:39 PM
Hi geek0101,

If the wacom.ko is installed you should get a response to:

dmesg | grep [Ww]acom
and/or see wacom info in either:

lsmod

modinfo -d wacom

Just to be sure when you copied "Favux_Jaunty ext graphics_test_2_10-wacom.fdi.txt" to "/usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi" you renamed it "10-wacom.fdi"?

When you type "wacomcpl" in a terminal the gui that pops up should have stylus, eraser, pad etc. listed and when you click on them options should show. That would mean the names on the output of:

xinput --list
are the same as

xsetwacom list

Maybe you're having the same problem as sanette and the kernel module isn't "sticking". If so try the fixes suggested in step 7 of section 1 here: http://ubuntuforums.org/showthread.php?t=1038949 He had to use martinjochimsen's fix in post #3.

geek0101
May 10th, 2009, 11:53 PM
Hello Javux,

I back, for I have to work two jobs.

I ran the commands:



sach@sach-desktop:~$ dmesg | grep [Ww]acom
sach@sach-desktop:~$ sudo dmesg | grep [Ww]acom
[sudo] password for sach:

no output


sach@sach-desktop:~$ lsmod
Module Size Used by
binfmt_misc 16776 1
bridge 56340 0
stp 10500 1 bridge
bnep 20224 2
video 25360 0
output 11008 1 video
input_polldev 11912 0
lp 17156 0
snd_intel8x0 37532 3
snd_ac97_codec 112292 1 snd_intel8x0
ac97_bus 9856 1 snd_ac97_codec
snd_usb_audio 90400 1
snd_pcm_oss 46336 0
snd_mixer_oss 22656 1 snd_pcm_oss
snd_pcm 82948 4 snd_intel8x0,snd_ac97_codec,snd_usb_audio,snd_pcm_ oss
snd_usb_lib 24320 1 snd_usb_audio
snd_hwdep 15108 1 snd_usb_audio
snd_seq_dummy 10756 0
snd_seq_oss 37760 0
snd_seq_midi 14336 0
snd_rawmidi 29696 2 snd_usb_lib,snd_seq_midi
snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
iTCO_wdt 19108 0
snd_timer 29704 2 snd_pcm,snd_seq
iTCO_vendor_support 11652 1 iTCO_wdt
snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
psmouse 61972 0
snd 62628 20 snd_intel8x0,snd_ac97_codec,snd_usb_audio,snd_pcm_ oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_oss,sn d_rawmidi,snd_seq,snd_timer,snd_seq_device
ppdev 15620 0
pcspkr 10496 0
snd_page_alloc 16904 2 snd_intel8x0,snd_pcm
serio_raw 13316 0
intel_agp 34108 1
soundcore 15200 1 snd
parport_pc 40100 1
parport 42220 3 lp,ppdev,parport_pc
joydev 18368 0
nvidia 7233756 36
agpgart 42696 2 intel_agp,nvidia
shpchp 40212 0
hid_apple 14336 0
usbhid 42336 0
skge 48272 0
floppy 64324 0
fbcon 46112 0
tileblit 10752 1 fbcon
font 16384 1 fbcon
bitblit 13824 1 fbcon
softcursor 9984 1 bitblit



no wacom stuff



sach@sach-desktop:~$ modinfo -d wacom
USB Wacom Graphire and Wacom Intuos tablet driver
USB Wacom Graphire and Wacom Intuos tablet driver

sach@sach-desktop:~$ sudo modinfo -d wacom
USB Wacom Graphire and Wacom Intuos tablet driver
USB Wacom Graphire and Wacom Intuos tablet driver


don't know if sudo will make a difference will show more output


sach@sach-desktop:~$ sudo lsmod
Module Size Used by
binfmt_misc 16776 1
bridge 56340 0
stp 10500 1 bridge
bnep 20224 2
video 25360 0
output 11008 1 video
input_polldev 11912 0
lp 17156 0
snd_intel8x0 37532 3
snd_ac97_codec 112292 1 snd_intel8x0
ac97_bus 9856 1 snd_ac97_codec
snd_usb_audio 90400 1
snd_pcm_oss 46336 0
snd_mixer_oss 22656 1 snd_pcm_oss
snd_pcm 82948 4 snd_intel8x0,snd_ac97_codec,snd_usb_audio,snd_pcm_ oss
snd_usb_lib 24320 1 snd_usb_audio
snd_hwdep 15108 1 snd_usb_audio
snd_seq_dummy 10756 0
snd_seq_oss 37760 0
snd_seq_midi 14336 0
snd_rawmidi 29696 2 snd_usb_lib,snd_seq_midi
snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
iTCO_wdt 19108 0
snd_timer 29704 2 snd_pcm,snd_seq
iTCO_vendor_support 11652 1 iTCO_wdt
snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
psmouse 61972 0
snd 62628 20 snd_intel8x0,snd_ac97_codec,snd_usb_audio,snd_pcm_ oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_oss,sn d_rawmidi,snd_seq,snd_timer,snd_seq_device
ppdev 15620 0
pcspkr 10496 0
snd_page_alloc 16904 2 snd_intel8x0,snd_pcm
serio_raw 13316 0
intel_agp 34108 1
soundcore 15200 1 snd
parport_pc 40100 1
parport 42220 3 lp,ppdev,parport_pc
joydev 18368 0
nvidia 7233756 36
agpgart 42696 2 intel_agp,nvidia
shpchp 40212 0
hid_apple 14336 0
usbhid 42336 0
skge 48272 0
floppy 64324 0
fbcon 46112 0
tileblit 10752 1 fbcon
font 16384 1 fbcon
bitblit 13824 1 fbcon
softcursor 9984 1 bitblit

sach@sach-desktop:~$ wacomcpl
wacomcpl: using TCLLIBPATH="
[list /usr/lib ]"


does show gui but no names are listed in the gui dialog



sach@sach-desktop:~$ xinput --list
"Virtual core pointer" id=0 [XPointer]
Num_buttons is 32
Num_axes is 2
Mode is Relative
Motion_buffer is 256
Axis 0 :
Min_value is -1
Max_value is -1
Resolution is 0
Axis 1 :
Min_value is -1
Max_value is -1
Resolution is 0
"Virtual core keyboard" id=1 [XKeyboard]
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
"Macintosh mouse button emulation" id=2 [XExtensionPointer]
Num_buttons is 32
Num_axes is 2
Mode is Relative
Motion_buffer is 256
Axis 0 :
Min_value is -1
Max_value is -1
Resolution is 1
Axis 1 :
Min_value is -1
Max_value is -1
Resolution is 1
"Apple, Inc Apple Keyboard" id=3 [XExtensionKeyboard]
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
"Logitech USB Receiver" id=4 [XExtensionKeyboard]
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
Num_buttons is 32
"Apple, Inc Apple Keyboard" id=5 [XExtensionKeyboard]
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
"Logitech USB Receiver" id=6 [XExtensionPointer]
Num_buttons is 32
Num_axes is 2
Mode is Relative
Motion_buffer is 256
Axis 0 :
Min_value is -1
Max_value is -1
Resolution is 1
Axis 1 :
Min_value is -1
Max_value is -1
Resolution is 1

no wacom code


sach@sach-desktop:~$ xsetwacom list


no output






I did rename the Favun*.fdi to "10-wacom.fdi".

Hope this helps narrow things down.

I will got to the other post you said in the previous post
and read and try it.

Thank you soooooo much!!

I've got 6, yes 6 beans.

;)

geek0101
May 11th, 2009, 12:22 AM
FAVUX!!!

I've got stylus!!!!!!!!!!!!!

I did the add "wacom" to the "etc/modules" per your advice on post 3 of Mar.. somebodies try and I've got stylus.

Yea!!!):P

I direction is reversed, but it's working. I read somewhere about someone else having that problem, and I think they had to add a line to something? In the 10-wacom.fdi file?

8 beans!

Favux
May 11th, 2009, 12:33 AM
Hi geek0101,

Outstanding! Nice job! I admire how you persevered with it.

What do you mean direction is reversed? Have you used wacomcpl to calibrate yet?

geek0101
May 11th, 2009, 01:58 AM
Hello Favux,

When I go from top to bottom on the tablet, the direction on the display goes bottom to top, and the same reversal for left to right.

Intuos4 is for left-handed and right-handed people, so for now I just turned the tablet around. I'm a lefty.

I've checked out the wacomcpl, a little. I noticed it doesn't have any controls if I select the pad name/button.

The other names on the wacomcpl are: stylus, cursur, and eraser(they have controls).

Thank you so much!!!

Favux
May 11th, 2009, 02:16 AM
Hi geek0101,

Great!

OK, since you are left handed one thing you could do is add these commands to your .xinitrc script:

xsetwacom set stylus rotate HALF
xsetwacom set eraser rotate HALF
xsetwacom set cursor rotate HALF
And you should be able to use your tablet left handed. The .xinitrc file is a hidden file (so click on show hidden files in View in Places) in your /home/username/ directory.

Gali98 tells you how to have .xinitrc run each time you start in his HOW TO as I do in Section 3 of my HOW TO on the first page.

Do you have a Wacom mouse for your tablet?

I don't know what's happening with Pad. Maybe you need to define something somewhere? Or maybe just like the wacom.ko your tablet is so new the 0.8.2-2 wacomcpl can't handle your pad?

geek0101
May 12th, 2009, 03:41 AM
Hello Favux,

Thank you again!!!

O:)

geek0101
May 12th, 2009, 03:53 AM
Hello Favux,

Yes I have a wacom mouse. It's not working.

I don't have a xinit.rc file in my "/home/sach/" dir, I have other hidden files showing.

I did a locate and no go on the xinit.rc.

Thank you!

Favux
May 12th, 2009, 04:40 AM
Hi geek0101,

It should be .xinitrc not xinit.rc. To generate the .xinitrc you have to calibrate with "wacomcpl". See Section 3 here on how to do it: http://ubuntuforums.org/showthread.php?t=1038949

sanette
May 12th, 2009, 12:05 PM
Hi Favux and geek0101

good to see a fellow jaunty+intuos4 in the way. I guess we are almost ready to write a "howto" !

Concerning options, like left-handed (I am too ;) ), well
for me, it seems that .xinitrc is not loaded at start-up (I'm using kubuntu,
maybe this is different in ubuntu)

of course I could add a file to be loaded at startup in the kubuntu settings, but I made it work by adding this line to 10-wacom.fdi

<merge key="input.x11_options.Rotate" type="string">HALF</merge>

(in the first <device> section)

Favux
May 12th, 2009, 12:33 PM
Hi sanette,

Nice. Does it work for the eraser and mouse also? A HOW TO sounds like a great idea.

sanette
May 13th, 2009, 09:36 AM
yes, this does it or for the sylus and the eraser. (I don't have a wacom mouse)

it seems from what I see in Xorg.0.log that this option automatically applies to all devices:

(**) WACOM: Rotation is set to HALF

specific options will appear differently, as for instance

(**) stylus: serial speed 9600

Favux
May 13th, 2009, 10:17 AM
Hi sanette,

Thanks, that is good to know. It makes sense to put it in the .fdi for an external tablet because once you've set up your desk you'd tend to leave it that way. And since the Intuos4 is designed by Wacom to be symmetrical so it can be used by left-handers it would be a nice touch in the HOW TO. Two of you on this thread with Intuos4's are left handed. I bet that isn't a coincidence.

geek0101
May 13th, 2009, 04:26 PM
Hi Favux and Sanette,


I did a autostart on Ubuntu with the command "sh /home/sach/.xinitrc" and that causes the gnome/jaunty desktop to keep reloading(icons appear and disapper) in a loop, thus crashing the system.

When I just run the command "sh /home/sach/.xinitrc" my desktop flickers white once and then sets my tablet for my lefty settings.


Thank yall!

geek0101

Favux
May 13th, 2009, 05:10 PM
Hi geek0101,

Good! Definitely getting there.

The loop may be caused by this. Check "/etc/X11/xinit/xinitrc". Everything in it should be commented out. If you see:

# invoke global X session script
. /etc/X11/Xsession
comment it out like:

# invoke global X session script
#. /etc/X11/Xsession
If it was uncommented and you comment it out then you should be able to autostart the .xinitrc .

geek0101
May 14th, 2009, 01:27 AM
yeap yeap yeapO:)

ceridwen
May 18th, 2009, 07:47 PM
Hi Favux, sanette, evilkillerfiggin and geek0101

thanks for your detailed information on how to get the intuos4 working with Jaunty. I try to follow your hints and i get the intuos4 working. :)

But i have another question. Does the expresskeys also should work? Touch ring works, but the keys doesnt.

Any help would be appreciate.

Kind regards, ceridwen.

alex941021@yahoo.com
May 19th, 2009, 04:12 PM
Hi,

it looks like there were several posts that were describing the steps to get things to work in Jaunty.

Is there a wiki somewhere that recaps the main steps?

My guess was:

1) Install the wacom packages via apt
wacom-tools
xserver-xorg-input-wacom

2) download the linuxwacom-0.8.3-4 development drivers

3) replace the driver files with the prebuilt ones that came with the file downloaded at 2

4) replace the fdi file with ??... which one ? the one that came with the linuxwacom-0.8.3-4 or the on that is referenced in one of the prior posts

5) Update the xorg.conf file by adding several lines. (what are these lines?).

(have tried these steps with mixed results--first time it worked but when touching the pen on the tablet it would stop working. Second time XServer woudn't come up). I must have screwed up in one of the steps.


Anyway, if we had a wiki for this we could just post a single set of instructions and nail this down once for all.

Thanks a lot,

alex

Favux
May 19th, 2009, 09:25 PM
Hi alex941021@yahoo.com,

In Jaunty the default is to use the "native" HAL/.fdi" with the specially patched 0.8.2-2 linuxwacom packages. But the default 10-wacom.fdi doesn't work quite right. If you want to use the new wacom.fdi you should follow the instructions on page 7 in post #63 on this thread. So you have to compile 0.8.3-4 to get its wacom.ko, which is all you want. The instructions say 0.8.3-3. Otherwise you keep the default 0.8.2-2 linuxwacom packages that come with Jaunty.

Or if you want to continue using xorg.conf you could compile 0.8.3-4. You have to use at least 0.8.3-2 because that is the first linuxwacom version that supports the Xserver 1.6 that comes with Jaunty.

One of the special patches for linuxwacom 0.8.2-2 in Jaunty was to make it work with Xserver 1.6. The others were to get it working with the HAL/.fdi method.

So start with post #63 and read through carefully.

Good luck!


Hi ceridwen,

Congratulations on getting your Intuos4 working! I'm not sure I understand what you're asking about the pad.
1) You know how to configure it through wacomcpl or it's .xinitrc but it just doesn't work.
2) You need to know how to configure it. If so to use wacomcpl please see Section 3 here: http://ubuntuforums.org/showthread.php?t=1038949 And then shatterblast shows how he configures his Bamboo pad on post #188 here: http://ubuntuforums.org/showthread.php?t=967147&page=19

If 1) I have a couple ideas.

alex941021@yahoo.com
May 20th, 2009, 05:58 AM
Hi Favux,

After following your advice, everything works perfectly (I was way off on this one!). Thanks a lot for your help. That posting contains everything I needed.

On a different note, I found the wiki page (https://help.ubuntu.com/community/Wacom), but it doesn't describe the same procedure...

- alex

Favux
May 20th, 2009, 06:12 AM
Hi alex941021@yahoo.com,

Great! Glad you got it working.

The Intuos4 is pretty new so I don't think Loic2's updated his Wacom wiki for it yet. We just figured out how to get it working in the last week or so after all. And of course the same applies to the modified .fdi. Anyway it's good you are set-up.

sanette
May 21st, 2009, 08:28 AM
Hi Favux, ceridwen

in fact I haven't figured out how to configure the tablet buttons either.

The bad thing is that the "pad" section in wacomcpl does not show anything !



There is also a strange behaviour that makes me think that the wacom driver
is not working perfectly: using the default setting, the top left button (in fact the bottom-right button in my left-hand setting) semmes to act as the mouse middle button: "paste"
However it only works ONCE, AFTER USING touch ring.

If you press it several times, only the first press has an effect.

But if you keep another finger on the ring (without moving), then
the "paste" button does work everytime you press ! ;)

Strange isn't it ? Anyone experimenting the same behaviour ?

ceridwen
May 21st, 2009, 12:53 PM
Hi sanette, Hi Favux,


I also haven't figured out how to configure the tablet buttons either.
For me it's the same, that the "pad section" in wacomcpl does not show anything.



@sanette


i can't reproduce the strange behaviour of your paste feature. For me every press of each button has no effect. :(

sanette
May 22nd, 2009, 09:07 AM
Hi ceridwen

strange that none of your buttons work.
Have you tried to run xev ?

open a terminal, type

xev

it opens a small white window. Put your mouse cursor in it, and
touch the ring of the tablet. You should see lots of information in the terminal.
Then after playing with the touch ring, press a button.
Does it show something in the terminal?

ceridwen
May 22nd, 2009, 06:48 PM
Hi sanette, Favux

my father would like to say: Someone who can read is in advantage.
That is what i have done to get my buttons work.

1.) read reply #89 from Favux again :)

2.) read Section 3: Calibrating your Tablet PC.

2.1) Call
wacomcpl
This creates .xinitrc in my home directory

2.2) Important! Edit xinitrc in /etc/X11/xinit. Look for

# invoke global X session script
. /etc/X11/Xsession

comment out the last entry like this:


# invoke global X session script
#. /etc/X11/Xsession

this prevent a loop in the startup script

2.3) make .xinitrc executable

chmod +x ~/.xinitrc

2.4) add the following entry in System->Preferences->Startup Applications. Change <username> to your name.

sh /home/<username>/.xinitrc

3.) read the posting #188 http://ubuntuforums.org/showthread.php?t=967147&page=19

3.1) For interest is the code section

xsetwacom set pad Button4 "core key NumpadMinus "
xsetwacom set pad Button3 "core key NumpadPlus "
xsetwacom set pad Button2 "core key F12 "
xsetwacom set pad Button1 "core key Esc"

3.2) I insert manually in a terminal

xsetwacom set pad AbsWDn "+ "
xsetwacom set pad AbsWUp "- "

3.3) The touchring should insert '+' or '-' in the terminal

3.4) Now i edit the .xinitrc in my home directory and I insert
somthing stupid like key 'A' up to Key 'I'


#buttons on the left side of the tablet
xsetwacom set pad Button1 "core key A " #button inside touchring
xsetwacom set pad Button2 "core key B " #top button
xsetwacom set pad Button3 "core key C "
xsetwacom set pad Button4 "core key D "
xsetwacom set pad Button5 "core key E "
xsetwacom set pad Button6 "core key F "
xsetwacom set pad Button7 "core key G "
xsetwacom set pad Button8 "core key H "
xsetwacom set pad Button9 "core key I " #bottom button

3.5) save and restart

3.6) start an editor and you can write with the buttons ABCDEFGHI. Great!:)


Thanks for all your help,

ceridwen

Favux
May 22nd, 2009, 11:28 PM
Hi ceridwen,

Excellent! Great work ceridwen!

So the Intuos4 pad does work with the 0.8.2-2 linuxwacom packages in Jaunty.

Looks like we now have a complete HOW TO. Maybe scattered about a bit. :)

sanette
May 23rd, 2009, 12:40 PM
Wow I'm impressed.

But alas it does not work for me... :(

what is your version of xsetwacom ?

xsetwacom --version
0.1.7

ceridwen
May 23rd, 2009, 03:02 PM
Hi Favux,

i dont use the 0.8.2-2 linuxwacom packages. I've downloaded the 0.8.3-4 and create the 0.8.3-4 wacom.ko and copy it as it is described on page 11 post #104 here: http://ubuntuforums.org/showthread.php?t=1038949&page=11



Hi sanette,

the version of xsetwacom is the same as yours. 0.1.7

sanette
May 23rd, 2009, 04:59 PM
YES ! it works

thanks to you ceridwen I worked hard to see what difference I could have with your configuration.
In fact it seems that my X11 driver wacom_drv.so was not the original one from ubuntu's xserver-xorg-input-wacom 8.2.2.
(indeed I did many compilations and stuff before having a working config)

So I did

sudo apt-get purge xserver-xorg-input-wacom wacom-tools
sudo apt-get install xserver-xorg-input-wacom wacom-tools

(to clean things up)

and then just reinstalled the wacom.ko file from my 8.3-4 compilation
AND the custom 10-wacom.fdi

Restart... and it works !!

sanette
May 23rd, 2009, 05:06 PM
So, in order to sum up

* the X11 driver from ubuntu 8.2.2 is GOOD (wacom_drv.so)
* the kernel driver wacom.ko should be compiled from 8.3-2 (or -3 or -4)
* the fdi file should be replaced with Favux's

I also noticed that

* ubuntu's wacomcpl is not so good (does not display pad buttons) BUT
* the wacomcpl-exec that you get when compiling 8.3-4 DOES show the buttons, and config change works !

Things to be loaded at startup:

* the wacom module (in /etc/modules)
* any config that you put in .xinitrc (for some reason configuring keys in FDI file does not work so good)

yeah ;)

Favux
May 23rd, 2009, 06:54 PM
Hi sanette,

Wow! There you go! Yep, yep we are there.

I'm just a little nervous about suggesting the 0.8.3-4 wacomcpl-exec. I think we're already pushing it with the different wacom.ko. The LWP site specifically tells you to use the same version for wacom-tools and drivers or X can break.

sanette
May 23rd, 2009, 07:13 PM
yes, it's probably not a good idea to suggest the 8.3-4 wacomcpl as a rule.
It might be unstable, as you say.
But I think it's good to know anyway

sanette
May 24th, 2009, 11:49 AM
Hi Favux

For several reasons don't like very much using .xinitrc
One reason is that you need to reload it each time you reconnect the usb tablet.

I'd like to use the FDI file, but
unfortunately there is problem for setting keys:
if I use

<merge key="input.x11_options.Button8" type="string">core key A</merge>

it has no effect and I can see in Xorg.0.log:

(**) Option "Button8" "core key A"
(WW) Option "Button8" requires an integer value

Any hint ?

Favux
May 24th, 2009, 07:11 PM
Hi sanette,

Let's try:

<merge key="input.x11_options.Button8" type="string">core key:A</merge>

And see what that does.

sanette
May 26th, 2009, 09:02 AM
Hi Favux

it doesn't work either:

(**) Option "Button8" "core key:A"
(WW) Option "Button8" requires an integer value

Favux
May 26th, 2009, 09:42 AM
Hi sanette,

OK, but I don't understand why the first one didn't work. It says:

ButtonM integer|keystroke sets button M to button integer click or keystroke

Have you tried?:

<merge key="input.x11_options.Pad.Button8" type="string">core key A</merge>

Where are you placing the line in the .fdi? Have you tried the first line you posted in the Pad subsection?

Favux
May 26th, 2009, 10:07 AM
Also why not try "key A" or just "A" if you haven't already.

sanette
May 26th, 2009, 10:28 AM
Hi Favux

it seems that I am not the only one with this problem:
see message # 172 in
http://ubuntuforums.org/showthread.php?t=967147&page=18&highlight=wacom

My fdi file is well loaded, I can use it for setting things like topx, rotate, etc.
It also works if I want to replace Button8 by "mouse button 1":
<merge key="input.x11_options.Button8" type="string">1</merge>
(I do put in the in PAD section, and it appears so in the Xorg.0.log file)

But I don't manage to have "core key" recognized.

BTW: where did you get this info below ?


Quote:
ButtonM integer|keystroke sets button M to button integer click or keystroke

Favux
May 26th, 2009, 12:32 PM
Hi sanette,

That may be why shatterblast in post #175 and #188 uses .xinitrc.

I got it from the LWP's HOWTO by Ping Cheng here: http://linuxwacom.sourceforge.net/index.php/howto/main Section 9.0. You may want to look at 5.1 too.

HAL stuff from the 5.1 spec.s here: http://people.freedesktop.org/~david/hal-spec/hal-spec.html

I suspect you'll have to post on the linuxwacom-discuss list here: https://lists.sourceforge.net/lists/listinfo/linuxwacom-discuss

Favux
May 31st, 2009, 05:01 AM
Hi sanette,

Lazarusrat here: http://ubuntuforums.org/showthread.php?t=1035029&page=8 was having a problem with TwinView. He added the 0.8.3 series wacom_drv.so and that fixed it. I wonder if that would also help you with core key? He' also posted on linuxwacom-discuss and is trying to put everything in the .fdi.

Edit: So he's doing the opposite of what you did in post #99?

In fact it seems that my X11 driver wacom_drv.so was not the original one from ubuntu's xserver-xorg-input-wacom 8.2.2.
(indeed I did many compilations and stuff before having a working config)

Or was yours not an 0.8.3 series wacom_drv.so?

justbecos
May 31st, 2009, 08:54 AM
Hello fellow Intuos4 owners,

I have been reading and trying most of the installation ideas on from this thread and as yet had no joy and still just have that one blue light on the tablet being on with no communication at all with the computer.

My setup is:
Laptop: Acer 8204 (Travelmate 8200 series)
Operating System: Ubuntu 9.04
Tablet: USB Intuos4 Medium (no mouse)

If someone could point me to the best post# for this setup I would be happy to try that method and update my status as I go.

I am also willing to re-install Ubuntu if need be.

thanks in advance
Tony

Favux
May 31st, 2009, 09:05 AM
Hi Tony,

Start with post #63 on page 7. Then the others to look at are 79,89,95,99,100. That should cover it. Good luck!

justbecos
May 31st, 2009, 09:49 AM
Thank you Favux,

I truly appreciate the rapid response to my request.
Off to try the suggestions now.

Thank you so much
Tony

justbecos
June 1st, 2009, 06:19 AM
Hi Favux,

I tried the instructions on post#63 and no joy. No sign of the intuos4 coming to life at all.( I have tested it on a windows PC and it works fine)

Do you think I should do a clean install of 9.04 and try again?


Tony


Hi Tony,

Start with post #63 on page 7. Then the others to look at are 79,89,95,99,100. That should cover it. Good luck!

Favux
June 1st, 2009, 06:33 AM
Hi justbecos,

Before you try that a couple things. When you look in Synaptic Package Manager does it tell you both linuxwacom 0.8.2-2 packages are installed (xorg-xserver-input-wacom and wacom-tools)? Also see Section 1 step 7 here: http://ubuntuforums.org/showthread.php?p=6546012#post6546012 You may need the fix in post #3 below. Where you put wacom in modules.

justbecos
June 1st, 2009, 06:51 AM
Favux,

thank you once again for a quick response. I will try your suggestions in an hour or so when I get home. I didn't realise that multiple restarts might be needed so that is new information as well. The battle continues.

Thanks again.
Tony

justbecos
June 1st, 2009, 09:28 AM
Favux,

Well I have had success at last! Just need a little more guidance.

here the story so far as per your instructions:

Before you try that a couple things.

When you look in Synaptic Package Manager does it tell you both

linuxwacom 0.8.2-2 packages are installed

xserver-xorg-input-wacom (yes)
wacom-tools (yes)

Also see Section 1 step 7 here: http://ubuntuforums.org/showthread.p...12#post6546012

Did step 7 - result
tony@tony-laptop:~$ modinfo -d wacom
USB Wacom Graphire and Wacom Intuos tablet driver
USB Wacom Graphire and Wacom Intuos tablet driver

You may need the fix in post #3 below. Where you put wacom in modules.
Did this
sudo nano /etc/modules

y /etc/modules looks like this:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp

This was missing :
wacom
powernow-k8

so added it, saved and rebooted

it works!!! :D I can move the cursor on both screens now.

did this again to be sure I had the jaunty wacom.ko installed:

cd linuxwacom-0.8.3-5
sudo cp ./src/2.6.28/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/wacom.ko

rebooted

still can move the cursor across both monitors

Now that I am this far I have a few more questions:

1. How do I flip the tablet as I am left handed and prefer the buttons on the right of the tablet.
2. I have no activity on the buttons on the tablet itself.
I think I need to update the .fdi but am confused about which post suits the
intuos 4 on ubuntu 9.04
3. how do I get the sensitivity to work. Its all at full pressure right now

Thank you so much for getting me this far, at least I can draw now with gimp and inkscape. :D

Tony

pointym5
June 2nd, 2009, 05:34 AM
First go to gali98's HOW TO on page 11 post #104 here:

You know, post number 104 is only on page 11 for certain forum preferences.

Favux
June 2nd, 2009, 06:19 AM
True, but it is the forum default and I give post # along with the page number along with the link.

pointym5
June 2nd, 2009, 02:44 PM
True, but it is the forum default and I give post # along with the page number along with the link.

Of course; I don't know why that seemed important to me last night.

Anyway that driver works, at least basically - the device is now recognized and it kind-of works. The Intuos4 mouse does not really work - it works if I hold it about a centimeter above the tablet, but not otherwise. That makes me think that it's a configuration deal. Is there some reference linked in the thread already that goes over what options exist and what they do?

Thanks for the help. This is somewhat bewildering because things seem to have changed so much over the last 3 Ubuntu releases.

pointym5
June 2nd, 2009, 08:04 PM
OK I've had a little more time to play with this now, but it's still not really working properly. The "wacdump" utility does not recognize the tablet. The how-to at the Linux Wacom site seems to be describing an inappropriate process, so it's not of much use.

pointym5
June 3rd, 2009, 05:16 AM
Back again. The pen more-or-less works the way I'd like it to, but the Intuos 4 mouse doesn't work so good. By setting the "CursorProx" parameter to 45 (with xsetwacom) I can get the mouse to act something like a mouse, the problem is that the mouse's internal thingy that the tablet "sees" remains active when I lift the mouse off the tablet. What I think is needed is a way to have the proximity of the "hot" component of the mouse only drive tablet behavior when it's in a very narrow range of proximity, corresponding to where it is while the mouse is sliding across the surface of the tablet.

Anybody figured out how to do this?

pointym5
June 3rd, 2009, 09:02 PM
Using xinput test -proximity cursor I've been able to see the following. When I have CursorProx set to 46 or above, I get a "proximity in" when I move the mouse from far above the tablet down to a centimeter or two from the surface. When I drop the cursor all the way to the tablet, it keeps working.

When I set CursorProx to something less than that (less than 46, that is), the driver issues a "proximity out" when I drop the mouse to the surface. That is, as I move the mouse from far away slowly towards the tablet, I first get a "proximity in", then some movement events, and finally a "proximity out" when the cursor gets to the tablet.

I turned up debug in the driver and noticed that while the mouse is moving along the surface the reported distance is around 20. I would think, therefore, that ideally I should be able to set CursorProx to something around 30, and that would make the mouse behave more-or-less normally. That does not work, however, because after that bogus "proximity out" the driver drops all the movement and button events.

Favux
June 3rd, 2009, 09:43 PM
Hi pointym5,

Sorry, I don't have a Wacom mouse so I can't really help you debug it. Other than the info. I've already given you. You need one of the Intuos4 guys to help. None of them have reported mouse problems that I'm aware of. I don't know what that tells us.

Or you could try posting on linuxwacom-discuss at: https://lists.sourceforge.net/lists/listinfo/linuxwacom-discuss

Good luck!

pointym5
June 3rd, 2009, 09:57 PM
Hi pointym5,

Sorry, I don't have a Wacom mouse so I can't really help you debug it. Other than the info. I've already given you. You need one of the Intuos4 guys to help. None of them have reported mouse problems that I'm aware of. I don't know what that tells us.

Or you could try posting on linuxwacom-discuss at: https://lists.sourceforge.net/lists/listinfo/linuxwacom-discuss

Good luck!

I'll try that list.

Apparently not all Intuos 4 packages include the mouse, so maybe some Intuos 4 users simply don't have one.

sanette
June 5th, 2009, 08:50 PM
Hi Favux

yes, exactly, I did the opposite:

my wacom.ko is 8.3.4
but if I use wacom_drv.so from 8.3.4 then
I cannot set keys (I cannot with .fdi and I cannot with xsetwacom either)

If I use the ubuntu wacom_drv (8.2.2) then xsetwacom
works (but still not .fdi)

sanette
June 5th, 2009, 08:54 PM
Hi pointym5

you're right: my intus4 package did not include a mouse.
Maybe this is a matter of size: mine has a sensitive area of size approx a5

kaialii
June 8th, 2009, 08:54 PM
Hi sanette

Sorry to inform you but, it's more to do with where you live than the size of your Intuos4. European sales of the Intuos4 does NOT include the mouse.

I'm still sifting through all of the messages on getting Intuos4 to work in Ubuntu 8.04. Thanks everyone.

The Intuos4 that I purchased is the small version and it does come with the mouse. It does work great out of the box, but that's not why I bought it. My goal is to get my tablet working with Gimp and Blender.

animone
June 10th, 2009, 05:17 PM
I thought I'd detail exactly what I've done so far, since most of the information is scattered around between many different posts and threads.

First, make sure your system is up to date:


sudo apt-get update

sudo apt-get upgrade
Now install wacom-tools and xserver-xorg-input-wacom:


sudo apt-get install wacom-tools xserver-xorg-input-wacom
The packaged version of wacom-tools for jaunty does not include support for your new Intuos4, so we'll have to compile a new kernel module. This is slightly easier than it sounds.

Download the latest linuxwacom source package from their website. Make sure to download the development version, and not the stable one.
(See http://linuxwacom.sourceforge.net/)
.
Grab build dependencies:


sudo apt-get install build-essential libx11-dev libxi-dev x11proto-input-dev xserver-xorg-dev tk8.4-dev tcl8.4-dev libncurses5-dev

.
Extract and make it. Do NOT make install:


tar jxvf linuxwacom-0.8.3-5.tar.bz2

cd linuxwacom-0.8.3-5

./configure --enable-wacom

make
.
Copy our updated module to the correct location, after backing up the current version:


cp /lib/modules/`uname -r`/kernel/drivers/input/tablet/wacom.ko ~/wacom.ko.bak

sudo cp ./src/2.6.28/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/wacom.ko
.
Add the module into /etc/modules, so the kernel will load it automatically:


sudo echo "wacom" >> /etc/modules
.
Grab favoux's updated .fdi file and copy it to the correct location.
(See http://ubuntuforums.org/showpost.php?p=7234134&postcount=176)


cp /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi ~/10-wacom.fdi.bak

sudo cp the_fdi_you_just_downloaded.txt /usr/share/hal/fdi policy/20thirdparty/10-wacom.fdi

.
After rebooting try this to see if the module is loaded:


dmesg | grep [wW]acom
If it is, you should see something that looks like:


[ 27.248321] usbcore: registered new interface driver wacom
[ 27.248323] wacom: v1.49-pc-1:USB Wacom Graphire and Wacom Intuos tablet driver
Anyway, that's as far as I've gotten. I'll update with the rest when I have a chance to finish and properly test things.

kaialii
June 10th, 2009, 09:35 PM
I have success. :D
My Intuos4 small is now working on Ubuntu 8.04 with linux wacom project package 0.8.3-5. The command "sudo make install" doesn't work you have to copy wacom.ko manually.

Next up is to fine tune it's setup. Currently, pressure, stylus buttons, and the 6 buttons on the tablet are not set-up. The ring works like a mouse wheel. The mouse works like a usb mouse, though I haven't fully tested it yet.

Thanks everyone for your help in this forum.

animone
June 11th, 2009, 11:22 PM
I haven't really had a chance to update my writeup above yet, but I wanted to note down a few quirks here:

* I had to use the new version of wacom_drv.so, as the old one segfaulted.
(sudo cp ./src/xdrv/wacom_drv.so /usr/lib/xorg/modules/input/wacom_drv.so)

* Must remember to add the appropriate sections in xorg.conf!

* Must remember to configure GIMP!

* No need to run wacomcpl if just using default settings

* Buttons work(!), but seem to currently be mapped to strange things. At least the updated driver seems to recognize them now.
(Using xsetwacom in a script works fine for this. Button1 is in the center of the trackwheel, Button2 is the bottom button (if you have buttons on the right side), ascending upwards.)

* xsetwacom set stylus rotate HALF
xsetwacom set eraser rotate HALF
xsetwacom cursor rotate HALF
- the magic commands for us left-handers. Put them in your favourite startup place.

* http://linuxwacom.sourceforge.net/index.php/howto/xsetwacom - very useful link for tweaking reference.

kaialii
June 14th, 2009, 03:54 AM
Here's an update of my last post. I now have pressure sensitivity working using PressCurve "a b c d", though I haven't figured out what the 4 values represent.

Favux
June 14th, 2009, 04:35 AM
Hi kaialii,

In case you haven't seen it the LWP's HOWTO says:

PressCurve i1 i2 i3 i4 sets the pressure bezier curve, where i1+i4=100; i2+i3=100
From here: http://linuxwacom.sourceforge.net/index.php/howto/xsetwacom

justbecos
June 24th, 2009, 01:38 AM
Just in case anyone using Ubuntu 9.04 has had their functional wacom intuos4 tablet stop working in the last few days.

After a largish update last night the tablet was not recognised again.

I just had the copy the wacom.ko file back again as it obviously had been overwritten with the latest update.

cd linuxwacom-0.8.3-5

sudo cp ./src/2.6.28/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/wacom.ko

Anyone else have this problem?

Tony

BLaFrance
July 3rd, 2009, 02:06 AM
Of course; I don't know why that seemed important to me last night.

Anyway that driver works, at least basically - the device is now recognized and it kind-of works. The Intuos4 mouse does not really work - it works if I hold it about a centimeter above the tablet, but not otherwise. That makes me think that it's a configuration deal. Is there some reference linked in the thread already that goes over what options exist and what they do?

Thanks for the help. This is somewhat bewildering because things seem to have changed so much over the last 3 Ubuntu releases.

I'm having the same issue here, has anyone found a fix? The pen and eraser work well.

crazybus
July 5th, 2009, 03:02 PM
Just in case anyone using Ubuntu 9.04 has had their functional wacom intuos4 tablet stop working in the last few days.

After a largish update last night the tablet was not recognised again.

I just had the copy the wacom.ko file back again as it obvious has been part of the update.


Thank you so much. I got the update while switching to KDE so I thought that was the problem till I saw your post. Once I releaised the problem and fix it was all downhill.

I need some help though. I've found the fix to make your pad keys do things by changing xintrc but I would prefer to make it in the .Fdi file since I would prefer to not have to restart every time I make a change. I'm using the .fdi which was attached at the start of another thread (from around may this year) The eraser, pen and touch wheel all work. Just none of the buttons.

Thanking everyone again for all their help

justbecos
July 6th, 2009, 12:38 AM
Thank you so much. I got the update while switching to KDE so I thought that was the problem till I saw your post. Once I releaised the problem and fix it was all downhill.

I need some help though. I've found the fix to make your pad keys do things by changing xintrc but I would prefer to make it in the .Fdi file since I would prefer to not have to restart every time I make a change. I'm using the .fdi which was attached at the start of another thread (from around may this year) The eraser, pen and touch wheel all work. Just none of the buttons.

Thanking everyone again for all their help

Hi Crazybus,

Glad that you found the post useful to get your tablet back up and running from my post. So it was worth posting!

I haven't been able to use any of those 4 side buttons either. I tried changing the .fdi file have had no joy at all so just keep using my tablet in right hand mode too. I am left handed so would love to just be able to do that. What post did you find the xintrc info from. Does it work with the Intuos4 on Ubuntu 9.04?

Tony

Favux
July 6th, 2009, 01:14 AM
Hi crazybus and justbecos,

The stuff for wacomcpl and .xinitrc is in Section 3 here: http://ubuntuforums.org/showthread.php?t=1038949

See ceridwen's post #95 on this thread. To set the tablet up for left handed use see my post #76 and sanette's post #80 on this thread.

For the .fdi syntax see mzuther's post #169 here: http://ubuntuforums.org/showthread.php?t=967147&page=17 The same thread (Loic2's) that I posted the usb .fdi on.

Any time the kernel or kernel headers or both is updated it breaks the wacom.ko that you compiled for the previous kernel. Usually you have to recompile it, so the fact you can just copy it back in place is a bonus. And I don't know why that works!

justbecos
July 6th, 2009, 01:44 AM
Hi crazybus and justbecos,

The stuff for wacomcpl and .xinitrc is in Section 3 here: http://ubuntuforums.org/showthread.php?t=1038949

See ceridwen's post #95 on this thread. To set the tablet up for left handed use see my post #76 and sanette's post #80 on this thread.

For the .fdi syntax see mzuther's post #169 here: http://ubuntuforums.org/showthread.php?t=967147&page=17 The same thread (Loic2's) that I posted the usb .fdi on.

Any time the kernel or kernel headers or both is updated it breaks the wacom.ko that you compiled for the previous kernel. Usually you have to recompile it, so the fact you can just copy it back in place is a bonus. And I don't know why that works!

Thank you Favux,

your help is always greatly appreciated. I will have a try of the first link's options when I am in front of my the tablet.

The second link seems to have a lot of info for the Bamboo and the Intuos 3.
I have an intuos 4 so am hesitant to use instructions for the other units. My tablets is calibrated perfectly for my dual screens and the pressure sensitivity works well too.

I really only want to be able to use it in the left handed configuration and the buttons would be nice but not the end of the world if they don't work.

Tony

Favux
July 6th, 2009, 02:11 AM
Hi Tony,

Well sanette's solution for lefties is pretty slick. You add it to the .fdi. I can show you where if you want.

I wasn't suggesting you use the Intuous3 or Bamboo setups, I wanted you to see the syntax for adding them. You probably want to find someone's setup somewhere. You should be able to translate from a .xinitrc or xorg.conf now to a .fdi now. You may have to experiment and they should help guide you with that.

justbecos
July 6th, 2009, 02:32 AM
Hi Favux,

I will try your suggestions for lefty's in post #76 and Sanette's in post #80 too and see what works best.
If I can't get it to work I will definately need some assistance.

I looked at the formating in post #169 by ubootfanat and honestly it is beyond my limited capabilities to re-engineer that syntax to suit an intuos 4.

I cut and paste any linux terminal commands I can't even write them myself. Let alone the complexities of the intuos4 setups.

I plan on waiting until the exact solutuion is posted that I can cut and paste my way through successfully.

all your help so far Favux has been a lifesaver

Tony

Favux
July 6th, 2009, 03:07 AM
Hi Tony,

Your welcome. Didn't someone post an .xinitrc for the Intuous4 somewhere? We can look back on this thread. I could show you how to translate that into a .fdi.

crazybus
July 6th, 2009, 03:16 AM
Hi Tony,

Your welcome. Didn't someone post an .xinitrc for the Intuous4 somewhere? We can look back on this thread. I could show you how to translate that into a .fdi.

The post #95 (http://ubuntuforums.org/showpost.php?p=7327894&postcount=95) of this thread you mentioned before contains the relevant code for the .xinitrc code for the buttons of the intuos4 if that's what you need to convert

Favux
July 6th, 2009, 03:37 AM
Hi crazybus,

Headslap. What am I talking about? Thank you. Of course it does (I didn't reread the whole post, just got it's #). So Tony just follow Ceridwen's instructions to set up wacomcpl and configure your .xinitrc the way you want it. Then we can translate it into a .fdi.

justbecos
July 6th, 2009, 03:45 AM
Hi crazybus,

Headslap. What am I talking about? Thank you. Of course it does (I didn't reread the whole post, just got it's #). So Tony just follow Ceridwen's instructions to set up wacomcpl and configure your .xinitrc the way you want it. Then we can translate it into a .fdi.

Thanks so much Favux & Crazybus,

I will give it a try in about 5 hours when I am in front my computer.
Sounds promising though.

would be awesome to get full functionality happening!

Tony

Junkyard Sam
July 7th, 2009, 08:34 AM
First off, HUGE thank yous to Animone for the Guide in post #129:
http://ubuntuforums.org/showpost.php?p=7433550&postcount=129

I'd like to report SUCCESS using Animone's guide on two Ubuntu Jaunty 9.04 machines with an Intuos4 tablet. Worked perfectly on my Dell m9040n desktop and Toshiba M55-S135 Laptop. Also, it might be of interest to note I used the .KO from linuxwacom-0.8.3-6.tar.bz2, the current dev version, with success.

HOWEVER I did encounter ONE problem with this line - a typo apparently!!!

Grab build dependencies:
sudo apt-get install build-essential libx11-dev libxi-dev x11proto-input-dev xserver-xorg-dev tk8.4dev tcl8.4-dev libncurses5-devThe CORRECT link, apparently, is:

sudo apt-get install build-essential libx11-dev libxi-dev x11proto-input-dev xserver-xorg-dev tk8.4-dev tcl8.4-dev libncurses5-devNotice the missing dash in Animone's link.

Aside from that it worked perfectly! I now have full stylus pressure & everything. (Haven't setup my keys yet.)

PS, the FDI that worked for me on both machines using an Intuo4 tablet was:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">
<device>
<match key="input.originating_device" contains="if0">
<match key="info.product" contains="Wacom">
<merge key="input.x11_driver" type="string">wacom</merge>
<merge key="input.x11_options.Type" type="string">stylus</merge>
<merge key="info.product" type="string">stylus</merge>
<append key="info.callouts.add" type="strlist">hal-setup-wacom</append>
<append key="wacom.types" type="strlist">eraser</append>
<append key="wacom.types" type="strlist">cursor</append>
<append key="wacom.types" type="strlist">pad</append>
</match>
</match>
</device>
<device>
<match key="input.x11_options.Type" contains="eraser">
<merge key="info.product" type="string">eraser</merge>
</match>
</device>
<device>
<match key="input.x11_options.Type" contains="cursor">
<merge key="info.product" type="string">cursor</merge>
</match>
</device>
<device>
<match key="input.x11_options.Type" contains="pad">
<merge key="info.product" type="string">pad</merge>
</match>
</device>
</deviceinfo>PS. And for anyone having problems with dual monitors... If you are having problems getting your Wacom mapped to a single monitor and it's going to the wrong one - I found a problem in the Nvidia driver if you set monitor 0 to the right side (moving it to the right of monitor 1 and setting it to be your main monitor.) I tried every possible setting including horizontal, leftof, rightof, etc --- I ended up having to move monitor 0 to the LEFT in the Nvidia driver.

PS#2. Another way to get your wacom commands to load at startup is to make a script. For example:


#!/bin/sh
xsetwacom set stylus rotate half(plus all your other custom settings like PressCurve if you need it, etc.)

I just called it wacomCustomSettings.sh and put it in my home directory. Then I ran chmod 744 on it to make it executable and the added it in System > Preferences > Startup Applications. (This might not be the preferred way to do it but those other .* files weren't running for me on startup for some reason.)

Thanks SOOOOOOOOOOOOOOOO much to everyone who posted here and figured this out. Huge enormous gratitude to you all!

animone
July 11th, 2009, 08:19 AM
Thanks for the heads up on my typo *fixes*. I see there have been some kernel updates pushed out, which probably broke a lot of peoples tablets.

So I'm back to well.. go through my own howto. Added a bit more detail in my seperate notes post.

Anyway, this should be all that's needed to update the kernel driver with the new one.



make

sudo cp ./src/2.6.28/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/wacom.ko


The howto: http://ubuntuforums.org/showpost.php?p=7433550&postcount=129
The follow-up notes: http://ubuntuforums.org/showpost.php?p=7441379&postcount=131

s.iovene
July 29th, 2009, 09:51 AM
Hi all, I'm joining the thread to ask a question. Thanks to the numerous helpful messages in this thread, I have successfully configured my Intuos4 Medium on Ubuntu 9.04, and now I'm wondering:

can the button in the center of the TouchRing be used to change what the TouchRing does? I can imagine easily that it can be associated to a script that changes the keystrokes associated with the TouchRing, but since there will be no visual reference on the leds, this is gonna be pretty impractical. I can imagine 3 uses I'd like to have for the TouchRing:



Change brush size (currently my only use, I associated [ and ] to the scrolling.
Zoom in and out (currently I have set two buttons to keystrokes + and -)
Scrolling up and down (say in Firefox)

Also another question:
I have associated my button9 to do CTRL-z because I undo often, when drawing. But the ctrl-z seems to be emitted only when the button is released. When the button is pressed, instead, I can see the color picker selected, in The Gimp. Also other buttons have similar behaviours. What's wrong?

Thanks a lot!

Favux
August 1st, 2009, 10:47 PM
Hi everyone,

The new linuxwacom 0.8-4 has just been released (7-30-09). It claims support for the Intuos4, support for Xorg up to 1.6.0, and updated TwinView and Xinerama mapping. I'm wondering if it is in time to be considered for inclusion into Kharmic.

evilkillerfiggin
September 5th, 2009, 01:17 PM
Me again.

Trying the tutorial from post #129 on a fresh install of 8.10 on a laptop.

Couldn't find linuxwacom-8.3.5 on the site; tried 8.3.6 and 8.4.1 - neither produce a wacom.ko file where the tut says they do.

I really need this tablet working urgently (ideally before the end of the day.) What do I do?

Favux
September 5th, 2009, 06:20 PM
Hi evilkillerfiggin,

You could try going back to the source. Gali98's verified building and installing the 0.8.4 wacom.ko on his HOW TO. Section 1: http://ubuntuforums.org/showthread.php?t=1038949&page=11

Good luck.

evilkillerfiggin
September 5th, 2009, 10:24 PM
I'd tried that; the wget command doesn't get 8.4.0, it saves a page from the linuxwacom site as 'index.html'. This page offers me the chance to download 8.4.1.

Having looked at the linuxwacom downloads page, I can find neither 8.3.5 or 8.4.0 - just the two that came immediately after. And neither of those two produces a wacom.ko after './configure --enable-wacom' and 'make'.

Favux
September 5th, 2009, 10:36 PM
Hi evilkillerfiggin,

Yes, that's new. Usually he saved the old versions. I guess that's due to going to the new sourceforge site. But either 0.8.3-6 or 0.8.4-1 should work for you.

I just checked the unpacked source code from my compile of 0.8.4-1 and the wacom.ko is in /src/2.6.27/. It's not in your /src/2.6.28/wacom.ko? Did you change kernels? Could they have changed the location in the recent configure for kernels > 2.6.27? You may then have to hunt around in the unpacked source code to find it. But if they did make changes in 0.8.4-1 that shouldn't affect 0.8.3-6.

evilkillerfiggin
September 5th, 2009, 11:31 PM
It was in src/2.6.27/. There was nothing in 2.6.28 because I'm using kernel 2.6.27-14, I think.

Copied wacom.ko, added "wacom" to modules. Wacom works, but it's totally unusable. I can move the pen around, but the moment I touch it to the tablet it freezes for about five seconds.

This happens with the wacom.ko from both linuxwacom-0.8.3-6 and 0.8.4-1.

What can I do? Do I need kernel 2.6.28? How do I get it? What else will get f*cked up if I install it?

I can't upgrade to Jaunty because of the Intel graphics driver bug. I cannot use the laptop as it is, and I need this tablet functional by tomorrow...

Favux
September 5th, 2009, 11:54 PM
Hi evilkillerfiggin,

Well if you are in Intrepid the best thing to do would be to compile and install linuxwacom 0.8.4-1 (which supports the Intuos4) and use the xorg.conf as of old. Xorg.conf works fine in Intrepid. See my HOW TO here: http://ubuntuforums.org/showthread.php?t=1038949 and if you don't have an old Wacom xorg.conf around see: https://help.ubuntu.com/community/Wacom and https://help.ubuntu.com/community/WacomTroubleshooting If you need the Wacom symlinks see Appendix 3 on the HOW TO.

Good luck!

evilkillerfiggin
September 6th, 2009, 01:09 AM
Success.

And not a moment too soon - I was getting ready to reinstall Windows XP. Now I'm just disabling all updates so nothing can come in and mess me around.

Thanks, Favux, for the prompt replies.

Favux
September 6th, 2009, 02:52 AM
Hi evilkillerfiggin,

Good, glad you're set up. You're welcome.

ramnarayan
September 14th, 2009, 07:46 PM
Good, glad you're set up. You're welcome.

Hi Favux,

Seems like you are one of the folks to turn too

I have an Intuos4 model PTK 640, am running Ubuntu 9.04 updated till recently, and have no idea how to go ahead -

The problem , apart from me not being able to figure out what to do is that on ubuntu forums there are quite a few threads on this topic and each one of them have quite a few replies.

Would you be able to direct me to the latest "how to"

I have the following with me
Favux_Jaunty ext graphics_test 2_10-wacom.fdi.txt

and have seen this
http://ubuntuforums.org/showpost.php?p=7093065&postcount=104

and this
http://ubuntuforums.org/showpost.php?p=6546012&postcount=1

-
so would much appreciate your help in figuring out what is missing.

thanks
ram

Favux
September 14th, 2009, 09:31 PM
Hi ramnarayan,

There's no set HOW TO. Since you have the modified wacom.fdi you've seen the instructions to go to gali98's HOW TO in post #104. What you want to do is follow section 1 and compile 0.8.4-1 (I don't know if 0.8.4 is still available) but not install it. All you want is the wacom.ko from 0.8.4-1 copied into place which his HOW to does for you. Between that and the new wacom.fdi after a reboot things should be working.

Then set up wacomcpl like instructed back where you got the new wacom.fdi. Then follow the link to ceridwen's post #95 for setting up the pad.

That should do it. Hope this helps.

dcsundr
September 25th, 2009, 11:24 PM
Back again. The pen more-or-less works the way I'd like it to, but the Intuos 4 mouse doesn't work so good. By setting the &quot;CursorProx&quot; parameter to 45 (with xsetwacom) I can get the mouse to act something like a mouse, the problem is that the mouse's internal thingy that the tablet &quot;sees&quot; remains active when I lift the mouse off the tablet. What I think is needed is a way to have the proximity of the &quot;hot&quot; component of the mouse only drive tablet behavior when it's in a very narrow range of proximity, corresponding to where it is while the mouse is sliding across the surface of the tablet.

Anybody figured out how to do this?

Hi pointym5,

I had the same problem with the mouse on the intuos4, specifically I could only use the mouse while I held it above the tablet, but once I set it down on top of it the mouse became unusable. Try the following:

Access wacomcpl from a terminal.

Select cursor from the select device menu.

Then click on the "Tool Buttons" button.

In the following menu change positioning mode to absolute, then click ok.

After I did this I was able to use the mouse, however I found that it was not mapped to the screen very well. So, under the tracking menu, I changed TopX to 2800 and TopY to 5000.

This took care of things perfectly, but I feel that I should mention that I have a wide-screen so these values may not be ideal for everyone. Also, if you changed settings through xsetwacom, this may not work exactly. If that's the case the only thing I can suggest is backing up the changes, undoing them, and then trying the wacomcpl method above.

JanMalte
September 27th, 2009, 12:41 AM
3.2) I insert manually in a terminal

xsetwacom set pad AbsWDn "+ "
xsetwacom set pad AbsWUp "- "3.3) The touchring should insert '+' or '-' in the terminal
I tried this line:

janmalte@desktop:~/Programme/Wacom$ xsetwacom set pad AbsWDn "+ "
xf86WcmDecode pad: invalid AbsWDn value: button (0) "+ ". Ignore it (assign to 0)
janmalte@desktop:~/Programme/Wacom$ xsetwacom set pad Button1 "core key A "

If did everything mentioned in the threads:


Compiling wacom.ko
edited 10-wacom.fdi with the one given here http://ubuntuforums.org/showthread.php?t=967147&page=18
running wacomcpl
edited .xinitrc like the one here http://ubuntuforums.org/showthread.php?p=7327894

But i can't write anything. Even when i set up the keys with wacomcpl. Are there any ideas? I use the Wacom Intuos4

L-hibou
October 9th, 2009, 06:50 PM
I've gone through everything and I'm up to the point where I could edit this:
xsetwacom set pad Button1 "core key A " #button inside touchring
xsetwacom set pad Button2 "core key B " #top button
xsetwacom set pad Button3 "core key C "
xsetwacom set pad Button4 "core key D "
xsetwacom set pad Button5 "core key E "
xsetwacom set pad Button6 "core key F "
xsetwacom set pad Button7 "core key G "
xsetwacom set pad Button8 "core key H "
xsetwacom set pad Button9 "core key I " #bottom button

in xinitrc, however, I'm unable to change it to anything but the letters.

I'ver tried things like xsetwacom set pad Button2 "core key F5 ", and xsetwacom set pad Button3 "core key ctrl Z " Among other buttons I want to enable on my tablet. However, upon restarting, while the changes are in fact saved, the buttons do not perform those actions. I was wondering what could cause the tablet to not perform those more complex actions?

I can only get it to type ABCDEFGHI with the buttons, but trying anything more complex fails to do a thing.

Can anyone help me with this?

Favux
October 16th, 2009, 04:02 AM
Hi everyone,

Some new developments.

On linuxwacom=discuss is a thread for OLED/Express key support. This post: http://sourceforge.net/mailarchive/forum.php?thread_name=3304b430910132208x79d3ed09nb badc33cd0e7d59%40mail.gmail.com&forum_name=linuxwacom-discuss links to the patches here: http://sourceforge.net/tracker/?func=detail&aid=2878608&group_id=69596&atid=525126 The patches are to 0.8.4-3.

Also some other info. here: http://www.nabble.com/Express-Keys-LED-OLED-Support-on-Intuos4--td25498409.html There's a script for xbindkeys to set up the pad buttons/express keys. This is actually about a month earlier in the thread that the first post is in.

jarlethorsen
October 21st, 2009, 02:42 PM
I have followed the hints found in this thread and successfully got my Intuos4 working. There is however one problem getting it to work 100% i gimp. I have a setup with two screens side by side in a nvidia Twinview setup. I have used wacomcpl to limit the intuos4 to screen 0, and that works as expected. If I do not enable any of the input devices in the gimp settings it also works just fine. However I need to enable it in gimp to have pressure-senitivity working. So I enable the stylus by setting it to "Screen": Now I have the actual xorg pointer way to the left of the point that gimp uses to paint.

It seems that gimp uses the combined width for both my screens as the width for my tablet, instead of just the width of just screen 0, as xorg uses.

How do I solve this?

PS. In wacomcpl->stylus->tracking BottomX is set to 44904. What does this number reflect, the width for screen 0 is only 1920...

jarlethorsen
October 22nd, 2009, 05:37 PM
It turned out that as I had made adjustments to the wacom settings while gimp was running, I had to restart gimp to have the new settings work 100%.

keaweb
October 22nd, 2009, 09:25 PM
Hello there !

First I'd like to thank you all (an awful lot) for your time and efforts. I just got myself an intuos 4, and I have been able to make it work decently, following your instructions on the "linux wacom project", and this forum. (usually the french ubuntu forums are good enough, but it seems I had to go international this time.)
I wish I could help, unfortunately, I'm quite a casual linux user, and not familiar enough (yet) with my intuos to be a real help here, I'm afraid.

So I'll just say what I have now "out of the box", so to say...
ubuntu 9.4 (64 bits) and an intuos 4 L.
I read "I got it working as a mouse", and indeed, that's what I got. No sensitivity, no eraser (works just like the other end of the pen), and buttons sometimes working, and sometimes not. The touch-ring doesn't work at all in the gimp, and works a a "scroll" in inkscape. Well, I'll have to read some more, but right now, my eyes need to rest.

BTW, I guess I'll have to translate some of your explanations for the french ubuntu forum, as this issue is not really covered yet. Will make me feel less of a useless lurker. Can I upload your modified .fdi file there, with proper credits ? One has to be registered here before he can DL it.

Thanks again.

Favux
October 22nd, 2009, 10:06 PM
Hi keaweb,

Welcome to Ubuntu Forums!

Sure. It looks like the modified .fdi works in Karmic too. If you haven't already (sounds like you have) see: http://ubuntuforums.org/showthread.php?t=967147&page=18 A French HOW TO sounds good.

Ubuntu Terrier
October 23rd, 2009, 11:29 AM
Does any Intuos4 owner have an annoying pointer wobbling problem on the corners of the screen like me (in both Jaunty and Karmic RC)?

http://ubuntuforums.org/showpost.php?p=8150687&postcount=353

sanette
October 28th, 2009, 05:08 PM
Hi

I've tried the OLED/Express key support that Favux mentioned. It works !

this is sooooooooooo cool !

Now I have small penguins everywhere on my Intuos 4 ;)

sanette
October 30th, 2009, 10:49 AM
Ubuntu Terrier : I don't have this problem. I'm using my intuos 4M with ubuntu 9.04 with wacom 8.4-3. For older versions as well I did not have this problem.

maybe you could try calibrating in such a way that you don't need to reach the end of the tablet in order to reach the corners of the screen.

Ubuntu Terrier
October 30th, 2009, 11:27 AM
Ubuntu Terrier : I don't have this problem. I'm using my intuos 4M with ubuntu 9.04 with wacom 8.4-3. For older versions as well I did not have this problem.

By the way, I'm using a 64 bit version of Ubuntu. What about you?


maybe you could try calibrating in such a way that you don't need to reach the end of the tablet in order to reach the corners of the screen.

No sorry, what you are proposing isn't a viable solution for me but rather a very ugly workaround. I need the whole tablet surface. On Windows the tablet works perfectly.

jarlethorsen
November 5th, 2009, 03:01 PM
Has anybody been able to configure the shortcut keys (both on the tablet and on the stylus) to work in gimp? Could you please tell me how you did it?

diana.artemis
November 22nd, 2009, 10:49 AM
Has anybody been able to configure the shortcut keys (both on the tablet and on the stylus) to work in gimp? Could you please tell me how you did it?

I, too, would like help with this - particularly, setting up the tablet buttons to provide shortcuts in GIMP. I was very pleased to find the the Intuos4 works 'out of the box' with Karmic, and that the stylus (including its buttons) works fine in GIMP, when I configured Extended Input Devices.

But I can't configure the buttons. I've tried these settings via a terminal:

#button 9 is top button
xsetwacom set 'Wacom Intuos4 6x9 pad' Button9 "core key CTRL z"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button8 "core key CTRL y"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button7 "core key x"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button6 "core key p"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button5 "core key z"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button4 "core key SHIFT"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button3 "core key ALT"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button2 "core key CTRL"
#button 2 is bottom button

but GIMP doesn't like this at all, and generates a 'faulty file' error when I try to use the buttons in this way.

Also, I can't see anything in wacomcpl when I try running that. (Anyone got any ideas why not?)

I must say I have noticed some odd behaviour from the Intuos4 in GIMP. One particular irritation is that the stylus will not pull guides off the rulers, though the Wacom mouse will. I think there may be some differences between how GIMP and how the OS handle the Intuos4. But in general the Intuos4 works really well with Karmic/GIMP, so the devs involved deserve our warmest thanks!

[edit: just came across this:
http://ubuntu-virginia.ubuntuforums.org/showpost.php?p=8235216&postcount=13
so may just have to wait till Lucid.]

jarlethorsen
November 22nd, 2009, 01:26 PM
But I can't configure the buttons. I've tried these settings via a terminal:

#button 9 is top button
xsetwacom set 'Wacom Intuos4 6x9 pad' Button9 "core key CTRL z"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button8 "core key CTRL y"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button7 "core key x"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button6 "core key p"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button5 "core key z"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button4 "core key SHIFT"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button3 "core key ALT"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button2 "core key CTRL"
#button 2 is bottom button

You are aware that these settings are for left handed use? In right-handed use, button 2 is the top button and button 9 i bottom button.

I use the following settings with success:
#touchdial + middle button
xsetwacom set 'Wacom Intuos4 6x9 pad' AbsWDn "CORE KEY +" #clockwise
xsetwacom set 'Wacom Intuos4 6x9 pad' AbsWUp "CORE KEY -" #counterclockwise
xsetwacom set 'Wacom Intuos4 6x9 pad' Button1 "core key 1" #button of touchdial

#button 9 is bottom button
xsetwacom set 'Wacom Intuos4 6x9 pad' Button2 "core key CTRL z"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button3 "core key CTRL y"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button4 "core key 4"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button5 "core key 5"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button6 "core key 6"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button7 "core key SHIFT"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button8 "core key ALT"
xsetwacom set 'Wacom Intuos4 6x9 pad' Button9 "core key CTRL"
#button 2 is top button

#Stylus
xsetwacom set 'Wacom Intuos4 6x9' Button3 "core key ALT up"
xsetwacom set 'Wacom Intuos4 6x9' Button2 "core key ALT down"

diana.artemis
November 22nd, 2009, 02:24 PM
You are aware that these settings are for left handed use?

Doh! Now you come to mention it, I think I copied them from a post about using the wacom left-handed - thanks for the correction!


I use the following settings with success:

Me, too! Thanks for troubling to reply so helpfully.

BTW, my experiments with the settings suggest that the buttons only affect the wacom, so that button2 can be used to do a 'CTRL+click' with the stylus (e.g. to set a source for the clone tool), but NOT act as the CTRL key in combination with a keyboard letter, as in CTRL+T. Is that right?

jarlethorsen
November 22nd, 2009, 02:45 PM
BTW, my experiments with the settings suggest that the buttons only affect the wacom, so that button2 can be used to do a 'CTRL+click' with the stylus (e.g. to set a source for the clone tool), but NOT act as the CTRL key in combination with a keyboard letter, as in CTRL+T. Is that right?

When you say CTRL+click do you mean pressing the button on the side of the stylus? (I have those two buttons set to increasing and decreasing the brush size. Using the clone tool, pressing the CTRL key on the pad, and putting the tip of the stylus on the pad, does not set the source point for cloning, it seems to cancel the point as soon as I de-press the ctrl-key....

And I am (as you) unable to use the Ctrl key on the tablet together with keyboard buttons..

If you figure out something smart please let me know....

diana.artemis
November 22nd, 2009, 04:18 PM
When you say CTRL+click do you mean pressing the button on the side of the stylus?... Using the clone tool, pressing the CTRL key on the pad, and putting the tip of the stylus on the pad, does not set the source point for cloning, it seems to cancel the point as soon as I de-press the ctrl-key.Yes, you're quite right, that's the behaviour I see, too: I have to use the keyboard CTRL key to set a source for Clone.

But the CTRL and SHIFT buttons on the pad do work properly with the Selection tool, to switch modes (additive, subtractive, intersection)


do you mean pressing the button on the side of the stylus... I have those two buttons set to increasing and decreasing the brush size.No, I meant just tapping with the stylus, as you said. But your settings for the stylus buttons are a very sensible idea - I've been using the keyboard '[' and ']' keys to do that, but your way would be handier.

Looks like I'll need to investigate how the Intuos4 buttons for CTRL, SHIFT, ALT work with GIMP. On the evidence so far, CTRL only emulates the keyboard CTRL imperfectly, so that doesn't bode well. I bet someone here has a good idea about the cause of these issues...

diana.artemis
November 22nd, 2009, 05:06 PM
When you say CTRL+click do you mean pressing the button on the side of the stylus? (I have those two buttons set to increasing and decreasing the brush size...
Mmm... I tried your settings:

xsetwacom set 'Wacom Intuos4 6x9' Button3 "core key ALT up"
xsetwacom set 'Wacom Intuos4 6x9' Button2 "core key ALT down"
but for me they increase or decrease the brush opacity.

To change brush size, I have to use

xsetwacom set 'Wacom Intuos4 6x9' Button3 "core key ]"
xsetwacom set 'Wacom Intuos4 6x9' Button2 "core key ["

But as the stylus buttons don't autorepeat, this is very slow compared with just holding the ']' or '[' key down.

BTW, I'm using GIMP 2.6.7

jarlethorsen
November 22nd, 2009, 05:32 PM
Mmm... I tried your settings:

xsetwacom set 'Wacom Intuos4 6x9' Button3 "core key ALT up"
xsetwacom set 'Wacom Intuos4 6x9' Button2 "core key ALT down"
but for me they increase or decrease the brush opacity.

Yeah, I have changed the settings in gimp to make ALT up/down change the size of the brush...


To change brush size, I have to use

xsetwacom set 'Wacom Intuos4 6x9' Button3 "core key ]"
xsetwacom set 'Wacom Intuos4 6x9' Button2 "core key ["

But as the stylus buttons don't autorepeat, this is very slow compared with just holding the ']' or '[' key down.


I have contacted the wacom-dev-guys regarding missing autorepeat, and they just suggested me writing a patch for it... Using [] for this is a bit cumbersome as I have to press Alt-Gr + 8 and Alt-Gr + 9 for these on my keyboard...

BTW, I'm using GIMP 2.6.7
Me too.

Spritus
January 18th, 2010, 01:04 PM
Version: Ubuntu 9.04 x64
Kernel: 2.6.28-17-generic
Tablet: Wacom Intuos 4 PTK-440

EN: Thanks to Sanette, it works. I listed my commands

FR: Grâce à Sanette, ça marche. Voici les commandes

> sudo -s
> cd /home/$USER
> apt-get install xorg-dev
> wget http://prdownloads.sourceforge.net/linuxwacom/linuxwacom-0.8.3-6.tar.bz2
> tar -xvf linuxwacom-0.8.3-6.tar.bz2
> cd linuxwacom-0.8.3-6
> ./configure --enable-wacom
> make
> make install
> cp src/2.6.28/wacom.ko /lib/modules/2.6.28-17-generic/kernel/drivers/input/tablet/
> init 6 (reboot)

When your session is opened:
> modprobe wacom

Useless to edit xorg.conf
Inutile d'éditer le xorg.conf

Good luck ;)
Bonne chance ;)

Spritus
January 21st, 2010, 10:09 PM
I advice Intuos 4 small user to see my answer
http://ubuntuforums.org/showthread.php?p=8683749#post8683749

For buttons, I customized mine here
http://forum.ubuntu-fr.org/viewtopic.php?pid=3225375

;)

amicable
January 27th, 2010, 11:14 AM
I'm trying to get OLEDs working on my Intuos4. I'm running kernel 2.6.31-17-generic and looked at the Wacom oled patch at sourceforge (http://sourceforge.net/tracker/?func=detail&aid=2878608&group_id=69596&atid=525126). However, the patch doesn't go past 2.6.28. Has anyone made the patch work on later kernels?

Favux
February 5th, 2010, 09:11 AM
Hi everyone,

We're doing some work on the OLED's on this thread: http://ubuntuforums.org/showpost.php?p=8777159&postcount=18


Hi sanette,

If you could join us and help out that would be great!

Jack Knights
May 7th, 2010, 02:19 AM
Hi there, I'm a new guy to Ubuntu, (Windows7 killed my computer and I had to replace the messed up roll-back to Vista with Ubuntu), and I have a Wacom Intuos4 Professional Pen Tablet. I had absolutely no problems with it at all in both Vista and 7, but I can't get it to work properly in Ubuntu. It has these hot-keys on the side, along with a track-wheel, (I hope I said that right), and none of these work. The tablet itself works fine, I can even "erase" with the opposite side of the pen like I did in Windows, but it's the hotkeys on the side panel that bug me. It's a real bother because it makes using Photoshop 7, (yes, I like the old, simple one), impossible with the talbet. I can't find anything specifically pertaining to this problem and I'm sorry if someone else already asked and resolved this question--11 pages is a lot to go through--but I need someone to point me in the right direction, with simple, easy to understand, step-by-step instructions on how to fix the hotkeys. Many thanks if you can help me out.

sanette
May 14th, 2010, 11:56 AM
Intuos on Lucid: wheel problem

Ok, I've upgraded to lucid (10.04), and I must admit that intuos support
is not as good as in 9.10.

Well it's not so bad, since the tablet is recognized out of the box, but
there is no wacomcpl, and the expresskeys just don't work.
(even using xsetwacom). I followed favux HOWTO to compile the new version of xf86-input-wacom. See

http://ubuntuforums.org/showpost.php?p=6546012&postcount=1

Now it's almost perfect: I can set keys using xsetwacom, but
the "wheel" doesn't seem to work at all.
Any hint for this ??

Favux
May 14th, 2010, 03:56 PM
Hi sanette,

In one of their last commits they reverted the fix for the wheel: http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=shortlog Apparently it wasn't done right: https://sourceforge.net/mailarchive/forum.php?thread_name=20100510223619.GB8186%40barr a.bne.redhat.com&forum_name=linuxwacom-devel

I think the fix has now been submitted: https://sourceforge.net/mailarchive/forum.php?thread_name=AANLkTinfwBcWrwAyYyux5SpztwW 7L7X1y70oqcltuq2t%40mail.gmail.com&forum_name=linuxwacom-devel But not committed. If so it will probably be committed very soon.

sanette
May 14th, 2010, 05:47 PM
Hi Favux

thanks a lot for this information.
I'll wait a bit, then !

brubaker
May 29th, 2010, 10:39 PM
Hi,

could someone give me an update if a new thread exists regarding the status of the Intuos4 support for Ubuntu 10.04?

fillchiam
May 30th, 2010, 07:37 PM
I would also love to see a solution to this. I haven't been able to fix the expresskeys or wheel on my Intuos4 M in Lucid. :(

Favux
May 30th, 2010, 07:48 PM
Hi fillchiam,

Welcome to Ubuntu forums!

I think the fix may have been committed to the git repository for the wheel anyway. You could clone it and see if it has been fixed.


Hi brubaker,

Welcome to Ubunut forums!

You might want to install Karmic (9.10) until things with Lucid get ironed out. It'll probably give you better support and it has wacomcpl.


Hi sanette,

I'm not for sure but like I told fillchiam I think the wheel might be fixed.

kotakotakota
July 17th, 2010, 06:18 PM
Sorry to revive an old thread but... Has there been any update to the status of Wacom Intuos4 tablets under Ubuntu 10.04 (Xorg in general, as I use openSUSE)?

Thanks!

Favux
July 17th, 2010, 10:38 PM
Hi kotakotakota,

My guess is the Intous4 will work now. I think there have been enough additions and fixes to xsetwacom.

So what you need to do is install at least xf86-input-wacom 0.10.7 (.8 is almost out). Best way is to clone the git. The default wacom.ko in Lucid works for your tablet but you should probably update it too, to make sure it's in synch with xf86-input-wacom.

See I. and II. at the Bamboo HOW TO (http://ubuntuforums.org/showthread.php?t=1515562). That should get it working. Then if you want we can work on a xsetwacom script for the Intuos4.

The bad news is the OLED's won't work because Ubuntu dropped support for the usbfs because it conflicts with the new udev. The LWP knows this so we'll have to see if they come up with something new.

diana.artemis
August 6th, 2010, 08:01 PM
My guess is the Intous4 will work now... what you need to do is install at least xf86-input-wacom 0.10.7 (.8 is almost out)... The default wacom.ko in Lucid works for your tablet but you should probably update it too

I've done all that (including the latest xf86-input-wacom 0.10.8 ), and the tablet basically works OK. But I can't set some buttons to work properly with GIMP (my only reason for using the Wacom). I attach my xsetwacom script.

Specifically

# The touch ring does not work (should send + and - to zoom in and out)
# The buttons don't seem to be able to send a TAB key
# I cannot get a 'CTRL + click' using a button set to CTRL with a simultaneous tap of the stylus.

In other words, it looks like some modifiers are no longer available.

If you've got your Intuos4 working with GIMP, and sending the standard GIMP key combinations, I'd be very grateful to hear how. Indeed, I'd be very grateful for any advice/suggestions!

Favux
August 6th, 2010, 08:33 PM
Hi diana.artemis,

Peter Hutterer just finished a series of patches to add functionality for wheel and touch strips. This turned out to be surprisingly complicated. Ping just ack'ed them so they should be in xf86-input-wacom shortly. Once they're in the git repository you can clone the git. Hopefully that will give you most of the function support you're looking for.

I'll have to check if tab is in special keys. If not we may be able to add it.


# I cannot get a 'CTRL + click' using a button set to CTRL with a simultaneous tap of the stylus.
Not sure what you're asking for/describing here.

And you're right, some functions still aren't available because xsetwacom is being rebuilt for xf86-input-wacom.

Attached is a preliminary .xsetwacom.sh for the Intuos4. You may have already seen it.

diana.artemis
August 6th, 2010, 08:55 PM
Favux >>> Thanks for the super-fast reply!

Peter Hutterer just finished a series of patches to add functionality for wheel and touch strips... Once they're in the git repository you can clone the git
Great! Forgive me, but how will I know when they're in the git?


I'll have to check if tab is in special keys. If not we may be able to add it.
Thanks, that'd be really helpful.



# I cannot get a 'CTRL + click' using a button set to CTRL with a simultaneous tap of the stylus.
Not sure what you're asking for/describing here.
For instance, in GIMP you select a region to clone from by holding the CTRL key and clicking the cursor on the bit you want to use as the source; then you draw with the cursor on the destination area to copy from the source. If you were using a mouse, you'd left-click; but with the stylus you just tap. In Intrepid, I hold the button defined as 'CTRL' key while tapping with the stylus. This does not work in Lucid.


Attached is a preliminary .xsetwacom.sh for the Intuos4. You may have already seen it.
Yes, I had a look at it, and tried the form you use for some of the modifiers, but they appear not to work.

Thanks for your tireless efforts!

Favux
August 6th, 2010, 09:33 PM
I can let you know. Here's the git repostiory: http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=shortlog

The control key is in special keys so try:

"key ctrl"
or
"key Control_L"
or
"key Control_R"
The capitalized CTRL isn't in there.

Tab isn't in special keys but it looks like I may be able to add it given what dumpkeys is saying. Give me a while to play with it. If I get it working I'll show you how and can submit a patch for its inclusion.

By the way which version of xf86-input-wacom are you using?

Favux
August 6th, 2010, 10:49 PM
OK, I think I have it.

The next time you clone xf86-input-wacom after you've got it downloaded onto your desktop go to xf86-input-wacom/tools and open xsetwacom.c in gedit. Then add at about line #919:


{"tab", "Tab"},
so you've changed it from:

{"left", "Left"}, {"right", "Right"},

{"backspace", "BackSpace"}, {"Backspace", "BackSpace"},

{ NULL, NULL }
};
to

{"left", "Left"}, {"right", "Right"},

{"backspace", "BackSpace"}, {"Backspace", "BackSpace"},

{"tab", "Tab"},

{ NULL, NULL }
};
Save it and proceed on to compiling xf86-input-wacom. That should give you tab. I'll try to remember to make a patch and submit it in the next few days.

diana.artemis
August 7th, 2010, 07:03 AM
I can let you know [when git is updated]

Thanks, that would be very helpful, as I'm not very confident about all this. (Installation for me is a combination of cut-and-paste, hoping I've understood the increasingly intricate 'HowTo', and "Here goes nothin'" pressings of 'Enter' with my eyes tightly shut!) :confused:


By the way which version of xf86-input-wacom are you using?

0.10.8

I'll try the different modifiers you suggest for CTRL, and report back.

diana.artemis
August 7th, 2010, 01:10 PM
OK, so now I've got xsetwacom setting the following:
Button2 "key ctrl z"
Button3 "key ctrl y"
Button4 "key TAB"
Button5 "key x"
Button6 "key shift ctrl e"
Button7 "key alt"
Button8 "key shift"
Button9 "key ctrl"

TAB doesn't work yet, as we know. But everything else seems to be working as it should. Buttons 2,3 and 6 are specific actions in GIMP, and work OK. The buttons for ctrl, shift and alt seem in most circumstances to behave correctly.

Except with the GIMP clone tool and heal tool. For example, if you're using a mouse and keyboard, you select the source area to clone from by holding CTRL while left-clicking with the mouse. This locks the source area. You can then release the CTRL key, hold down the left mouse button and 'paint' to copy from the source area onto another part of the image. The Wacom worked exactly like this in Intrepid, using Button9 and the stylus for selecting source areas and then painting with the stylus alone to clone or heal.

But in Lucid, the source area doesn't lock: when you release Button9, the source area deselects - UNLESS you hold Button7 ('alt') at the same time as Button9, and then keep on holding Button7 after you let go of Button9 while you 'paint' with the stylus. This (a) is not the normal behaviour of the clone or heal tool, and (b) is extremely uncomfortable to do for any length of time!

I also notice that pressing and releasing Button9 (ctrl) causes GIMP to switch to the Move tool, regardless of what tool you're currently using.

So it looks like GIMP is no longer properly interpreting the codes being sent by Button9; or the codes are no longer the same as they were in Intrepid, where all this worked properly. (I've no way of knowing which is right.)

I'd be extremely grateful for help with this, as it's a pretty basic and essential aspect of using a graphics tablet with GIMP. Of course, I've no idea whether it's a Wacom issue or a GIMP issue; but given that it wasn't a problem in Intrepid, I strongly suspect it's a Wacom issue.

Any ideas, anyone?

sudopinion
August 9th, 2010, 06:22 AM
My mouse cursor keeps dropping.* This problem plauged my old system with an intuos3 as well. Is there something conflicting with my tablet that would cause this? *during a drag operation the mouse suddenly drops (lets go) of whatever's being dragged. Please help. This is REALLY annoying and renders my tablet nearly useless in linux. Any help is appreciated. sudopinion@yahoo.com

Favux
August 9th, 2010, 08:21 PM
Hi diana.artemis,

The tab key has now been added to xf86-input-wacom.

The strip and scroll wheel patches are still pending. Peter had to come up with another patch to reload actions so current xsetwacom command would be updated. And Ping is requesting a tested by on the Patch series. So hopefully still soon.


Hi sudopinion,

Have you tried adjusting SpeedLevel for the cursor?

SpeedLevel integer (1 - 11) sets relative cursor movement speed

You could also try RawSample.

diana.artemis
August 10th, 2010, 06:42 AM
The tab key has now been added to xf86-input-wacom. The strip and scroll wheel patches are still pending... So hopefully still soon.

Thanks for the update. Hope you'll soon be able to let us know that the patches are done.

Favux
August 16th, 2010, 01:57 AM
Hi diana.artemis,

The wheel and strip keys patches just landed in xf86-input-wacom. Hopefully that will get you what you want.

diana.artemis
August 16th, 2010, 06:08 AM
Hi diana.artemis,
The wheel and strip keys patches just landed in xf86-input-wacom. Hopefully that will get you what you want.


Thanks very much for letting me know, and for all your continuing work on Wacom kit.

amicable
August 18th, 2010, 11:54 AM
bump - am back where I started with the pad; only the basic features and none of the fireworks :rolleyes:

Favux
August 23rd, 2010, 12:19 AM
Hi everyone,

Good news!

Christoph Karg has written a new OLED applet in C using libusb to communicate with the tablet and Magick++ to deal with the images/icons. It's for the Intuos4 M, Product ID 0x00b9. But if you have another Intuous4 with a different product number it looks like all you need to do is add it to the defines in WacomIntuous4LED.cpp under line 19, basically copying it. And substitute the Product ID for yours at line 16 in intous4-led-check.cpp.

See his post at linuxwacom-devel: https://sourceforge.net/mailarchive/forum.php?thread_name=201008211203.59754.wacom%40k argulus.de&forum_name=linuxwacom-devel The applet is in the attachment. Icons are included.

teetee
August 31st, 2010, 02:22 PM
Hi!

So I downloaded Favux_Intuous4_wacom.conf-.xsetwacom.sh and copied it my home folder (/home/tt/) as .xsetwacom.sh

But when I try
sh /home/tt/.xsetwacom.sh at terminal it gives me:


Cannot find device 'Wacom Intuos4 6x9'.
Cannot find device 'Wacom Intuos4 6x9'.
Cannot find device 'Wacom Intuos4 6x9'.
Cannot find device 'Wacom Intuos4 6x9'.
Cannot find device 'Wacom Intuos4 6x9'.
Cannot find device 'Wacom Intuos4 6x9'.
Cannot find device 'Wacom Intuos4 6x9'.
Cannot find device 'Wacom Intuos4 6x9'.
Cannot find device 'Wacom Intuos4 6x9'.
Unknown parameter name 'SpeedLevel'.
Note: The "core" keyword is not supported anymore and will be ignored.

I have Intuos 4 M (and Ubuntu Studio 10.04 ).

I have done steps I and II at Bamboo HOW TO (http://ubuntuforums.org/showthread.php?t=1515562)

What is my problem? On this case...

Edit:
Now my pen isn't working and eraser acts like pen. Buttons have now some functions, so I managed to run that script, but it didn't work perfectly.

Favux
August 31st, 2010, 03:32 PM
Hi teetee,

Obviously something isn't right.

Let's do a little troubleshooting. What's the output in a terminal of:

lsmod | grep wacom
and

xinput --list

teetee
August 31st, 2010, 07:38 PM
Hi!


lsmod | grep wacom

wacom 33194 0



xinput --list

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Wacom Intuos4 6x9 eraser id=8 [slave pointer (2)]
⎜ ↳ Wacom Intuos4 6x9 cursor id=9 [slave pointer (2)]
⎜ ↳ Wacom Intuos4 6x9 pad id=10 [slave pointer (2)]
⎜ ↳ Wacom Intuos4 6x9 stylus id=11 [slave pointer (2)]
⎜ ↳ PIXART USB OPTICAL MOUSE id=12 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]

Favux
August 31st, 2010, 07:40 PM
That's looking good. What do you see with?:

xsetwacom list

teetee
August 31st, 2010, 07:44 PM
xsetwacom list

Wacom Intuos4 6x9 eraser ERASER
Wacom Intuos4 6x9 cursor CURSOR
Wacom Intuos4 6x9 pad PAD
Wacom Intuos4 6x9 stylus STYLUS

Favux
August 31st, 2010, 07:54 PM
Good. OK, for you:

stylus = "Wacom Intuos4 6x9 stylus" instead of "Wacom Intuos4 6x9"

That's due to a change in the naming convention that occured in the wacom drivers. So in the script change the Device name for stylus from:

"Wacom Intuos4 6x9"

to:

"Wacom Intuos4 6x9 stylus"

and now xsetwacom should see your stylus.

teetee
August 31st, 2010, 08:06 PM
Edit:
Never mind. It seems that Gimp have changed stylus to not-working state (maybe because it was before Wacom Intuos4 6x9 and it is Wacom Intuos4 6x9 stylus.)

Tomorrow I guess I'll try to find out how to make oled to work.

Thank you very much.

teetee
September 6th, 2010, 02:14 PM
Ok. I tried this (Intuos4 OLED) http://sourceforge.net/mailarchive/forum.php?thread_name=201008211203.59754.wacom%40k argulus.de&forum_name=linuxwacom-devel (intuos4 oled)
And did it also. Now I can change symbols for OLEDs.

Now I should:

- the wacom driver must be reloaded after usage of the software

What this means? How I should reload Wacom driver?

Favux
September 6th, 2010, 03:35 PM
Hi teetee,

As I get it it goes like this. He says in the READ ME "the wacom driver must be reloaded after usage of the software". So that means 'the wacom usb driver (wacom.ko) must be unloaded before usage of the software and then reloaded'.

To unload the wacom.ko module:

sudo modprobe -r wacom
Then use the software:

sudo intuos4-led-config --button 2 --icon WacomLogo
for example. When you are finished to get the tablet working again reload the wacom.ko module:

sudo modprobe wacom

Edit: Christoph Karg updated the WacomIntuos4LED.cpp to detect 3 more Intuos4 tablets. Attached below. Just substitute this one with the one in the folder, after renaming it 'WacomIntuos4LED.cpp'. And here are all the Product ID's I'm aware of:

ATTRS{idVendor}=="056a", ATTRS{idProduct}=="00b8", SYMLINK+="input/tablet-intuos4-4x6"
ATTRS{idVendor}=="056a", ATTRS{idProduct}=="00b9", SYMLINK+="input/tablet-intuos4-6x9"
ATTRS{idVendor}=="056a", ATTRS{idProduct}=="00ba", SYMLINK+="input/tablet-intuos4-8x13"
ATTRS{idVendor}=="056a", ATTRS{idProduct}=="00bb", SYMLINK+="input/tablet-intuos4-12x19"
ATTRS{idVendor}=="056a", ATTRS{idProduct}=="00bc", SYMLINK+="input/tablet-intuos4-wl-usb"
ATTRS{idVendor}=="056a", ATTRS{idProduct}=="00bd", SYMLINK+="input/tablet-intuos4-wl"

teetee
September 6th, 2010, 03:54 PM
Hi Favux,

and thanks (again)!

It seems that you got it right. Now I got it working again.

teetee

kotakotakota
September 6th, 2010, 09:32 PM
I tend to get an issue where the cursor jumps to the top left corner of the screen whenever i use any of the buttons or the scroll wheel on my Intuos4 Medium tablet. Any ideas? I last updated my Wacom driver about a month ago.
Thanks!

Favux
September 6th, 2010, 09:36 PM
Hi kotakotakota,

What release of Ubuntu are you in? What wacom driver did you update? And to what version?

kotakotakota
September 6th, 2010, 09:42 PM
Favux,

Sorry, I usually post this information: I am under Ubuntu 10.04 64 bit, using the linuxwacom-0.8.8-8 (the production stable) driver. Thanks!

Favux
September 6th, 2010, 09:47 PM
Did you also update xf86-input-wacom?

kotakotakota
September 6th, 2010, 09:50 PM
I didn't since I installed the driver because I'm assuming that would overwrite it.

Favux
September 6th, 2010, 09:55 PM
Hi kotakotakota,

No, in Lucid you use linuxwacom to get the usb kernel driver wacom.ko. For the X driver wacom_drv.so you need xf86-input-wacom. See I. & II. on the Bamboo HOW TO (http://ubuntuforums.org/showpost.php?p=9496609&postcount=1) or Sections 1 & 2 in the linuxwacom HOW TO (http://ubuntuforums.org/showpost.php?p=6546012&postcount=1).

kotakotakota
September 6th, 2010, 10:03 PM
Oh, wait, is the linuxwacom.ko kernel module from the Linux Wacom Project's website (once compiled) the thing that you are referring to? If so, the version I am using for that is the production stable one. I am pretty sure I used your guide for installing it, but I suppose I will try with a fresh install in the next few days.

I know I've done this several times before, but its ridiculous how quickly the method of installing it changes... I have to admit, I miss the days of HAL. Things seemed to just work back then.

By the way, thank you very much for your excellent guide on installing the Wacom drivers. I always use it when installing the drivers under Ubuntu, openSUSE, Fedora, and I think I even used it for Gentoo.. Very easy to follow and has always been a fabulous resource.

Favux
September 6th, 2010, 10:21 PM
Thank you for the kind words. I had no idea it worked for so many distro.s.

marcoshamas
September 10th, 2010, 02:40 PM
Hi,

I'm on Lucid and I have an Intuos4 with the touch ring that works as a scrollbar while I would like to use it for zooming in and out using the + and - signs.

So I've cloned the xf86-input-wacom git repository.

When I give sh ./autogen.sh I receive this:

~/wacom/xf86-input-wacom $ sh ./autogen.sh
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal
configure.ac:44: error: xorg-macros version 1.8 or higher is required but 1.5.0 found
/usr/share/aclocal/xorg-macros.m4:39: XORG_MACROS_VERSION is expanded from...
configure.ac:44: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: /usr/bin/autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1

Now I'm a little lost. How do I upgrade to 1.8? Is there around a HOWTO to fix the touch ring on Lucid? Because I'm not sure about what I'm doing.

Favux
September 10th, 2010, 04:03 PM
Hi marcoshamas,

Welcome to Ubuntu forums!

See either the linuxwacom HOW TO (http://ubuntuforums.org/showpost.php?p=6546012&postcount=1) Section 2 or the Bamboo P&T HOW TO (http://ubuntuforums.org/showpost.php?p=9496609&postcount=1) II. Both have a mini-HOW TO on updating Lucid to xorg-macros version 1.8.

Hope this helps.

marcoshamas
September 11th, 2010, 01:16 PM
Hi marcoshamas,

Welcome to Ubuntu forums!

Thanks!



See either the linuxwacom HOW TO (http://ubuntuforums.org/showpost.php?p=6546012&postcount=1) Section 2 or the Bamboo P&T HOW TO (http://ubuntuforums.org/showpost.php?p=9496609&postcount=1) II. Both have a mini-HOW TO on updating Lucid to xorg-macros version 1.8.

Hope this helps.

I followed the steps in the HOWTO but when I write Make I see this message:

~/Desktop/util-macros-1.8.0 $ make
make: Nothing to be done for `all'.

Favux
September 11th, 2010, 04:37 PM
Do you have 64-bit Lucid?

marcoshamas
September 11th, 2010, 07:17 PM
Do you have 64-bit Lucid?

yes it's the 64bit version

Favux
September 11th, 2010, 07:36 PM
On a 64-bit install you may need to add another flag. To check see where evdev_drv.so is located. If it is in /usr/lib/xorg/modules/input, then '--prefix=/usr' is correct. If in /usr/lib64/xorg/modules/input, then you need to add '--libdir=/usr/lib64'. From Troubleshooting in the Bamboo P&T HOW TO. Maybe it applies to macros also?

marcoshamas
September 11th, 2010, 11:45 PM
On a 64-bit install you may need to add another flag. To check see where evdev_drv.so is located. If it is in /usr/lib/xorg/modules/input, then '--prefix=/usr' is correct. If in /usr/lib64/xorg/modules/input, then you need to add '--libdir=/usr/lib64'. From Troubleshooting in the Bamboo P&T HOW TO. Maybe it applies to macros also?

evdev_drv.so is located in /usr/lib/xorg/modules/input and /usr/lib64/xorg/modules/input
I tried again adding the the --libdir=/usr/lib6 but the result is still the same:


/util-macros-1.8.0$ ./configure --prefix=/usr --libdir=/usr/lib64
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for a BSD-compatible install... /usr/bin/install -c
configure: creating ./config.status
config.status: creating xorg-macros.pc
config.status: creating Makefile
config.status: creating xorg-macros.m4


/util-macros-1.8.0$ make
make: Nothing to be done for `all'.

Favux
September 11th, 2010, 11:48 PM
What happens if you just skip the xorg macros and go on to try to compile xf86-input-wacom?

marcoshamas
September 12th, 2010, 12:19 AM
What happens if you just skip the xorg macros and go on to try to compile xf86-input-wacom?

./autogen.sh --prefix=/usr
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal
configure.ac:44: error: xorg-macros version 1.8 or higher is required but 1.5.0 found
/usr/share/aclocal/xorg-macros.m4:39: XORG_MACROS_VERSION is expanded from...
configure.ac:44: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: /usr/bin/autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1

Favux
September 12th, 2010, 12:40 AM
OK, an OpenSuse user had a similar error and was able to just skip it. We never figured out the problem or why it worked without macro 1.8.

To have a chance of figuring it out you'd have to show me the entire output of configure and make, not just selections, including the command you used.

I assume there's some error in the Makefile because config:

config.status: creating xorg-macros.m4

seems to be happy and configuring the 1.8 macros.

marcoshamas
September 12th, 2010, 12:56 AM
OK, an OpenSuse user had a similar error and was able to just skip it. We never figured out the problem or why it worked without macro 1.8.

To have a chance of figuring it out you'd have to show me the entire output of configure and make, not just selections, including the command you used.

I assume there's some error in the Makefile because config:

config.status: creating xorg-macros.m4

seems to be happy and configuring the 1.8 macros.

Ok now is working. After the "make: Nothing to be done for `all'." my stupid assumption was that it was an error and so I didn't try the make install.

I've compiled everything and now the touch ring works correctly.

Thank you very much

Favux
September 28th, 2010, 06:07 PM
Hi everyone,

Sanette has modified Christoph Karg's OLED applet so that it now supports profiles. You can use one for Inskscape and a different one for Gimp for e.g., with the OLED's being relabled with each different profile.

See the OLED thread: http://ubuntuforums.org/showpost.php?p=9888901&postcount=107

Typhon
September 29th, 2010, 03:43 PM
Today I read through all kinds of "Wacom on Ubuntu" threads and tutorials and frankly, it made my head spin.

I have Intuos4 tablet running on Lucid and I wonder what is wrong with the official Ubuntu package ("xserver-xorg-input-wacom") in the repositories?

I don't know why distros don't make Wacom setup easier, because now you have to be a pretty serious geek to make it work. After all, these tablets are becoming more and more popular; they're not some obscure piece of hardware. I can't imagine an ordinary non-technical user trying to set up his tablet. Luckily, I have been able to set up mine.

sanette
October 11th, 2010, 06:52 AM
Typhon:

I have tested the latest Kubuntu live CD (10.10 RC)
and the intuos4 works out of the box, without installing any extra package.
(stylus, eraser, buttons, wheel).

Of course, you still need command line for assigning personal keys to buttons (through xsetwacom)
and also, OLEDS still need a special patch, but this one is not essential.

cordoval
November 3rd, 2010, 02:32 AM
sanette you are right, I am in ubuntu 10.10 and it works out of the box, however! my ring only lit up 1 light out of the four and I don't know how to configure it. When on a browser that works as a scroll bar but cannot do much more like I would want for instance zooming in and out.

Can someone help with a tutorial on ubuntu on how to setup this one?

Thanks,

Luis

Favux
November 3rd, 2010, 02:49 AM
Hi Luis,

Welcome to Ubuntu forums!

There's a preliminary xsetwacom script earlier in the thread: http://ubuntuforums.org/showpost.php?p=9686812&postcount=194

Use the "Device names" that:

xinput --list
returns for you Wacom devices.

cordoval
November 3rd, 2010, 04:17 AM
thanks a lot!

I modified the script under my home directory, chmod +x script.sh and run it ./script.sh and I get:


Unknown parameter name 'SpeedLevel'.
Note: The "core" keyword is not supported anymore and will be ignored.

I also tried to comment those lines however perhaps I shouldn't.
Is the reason that is not working the fact that I don't have the proper libraries installed? I just got my ubuntu 10.10 out of the box so I have not done any installing on special git repos or etc.

The intuos4 small works ok, but there is only one led lit up around the wheel (touch ring) and it will not change if I click on the button 1.

What could be wrong?

Favux
November 3rd, 2010, 05:06 AM
Well the SpeedLevel is for the Wacom tablet mouse. If you don't have one you don't need the cursor section. The xsetwacom commands were rewritten for xf86-input-wacom. To see what's available there's a new manual, 'man xsetwacom'.

Core is deprecated. That happened on the way to 0.10.8 xf86-input-wacom from 0.10.5. So just remove core.

Is the reason that is not working the fact that I don't have the proper libraries installed? I just got my ubuntu 10.10 out of the box so I have not done any installing on special git repos or etc.
The default in Maverick is 0.10.8, which has a lot of fixes and additions, so xsetwacom works pretty well in it. There were some commits for wheels and strips after 0.10.8 was released. So maybe cloning the git would help.

What's your Intous4 model number? It's not a super new one is it? I don't think any new Intuous4 has been added to the wacom.ko in a while. So I don't think it will gain you to compile a newer one.

cordoval
November 3rd, 2010, 05:29 AM
Intuos4 PTK-440

how do I install the git repo or whatever I need to get the "wheels and strips" working?

Or perhaps am I misguided as I need to configure it further in the GIMP extended devices? I did configure extended devices under Preferences >> Extended Devices >> and set the pad, cursor, eraser, stylus by default set to screen and 1,2,3,4,5,6 for all, and nothing on keys' tab. Wonder what the keys tabs are for exactly...
But that seems like another problem.

I just want to configure the zooming option at least on the wheel which I think it is button 1.

cordoval
November 3rd, 2010, 05:34 AM
something that confuses me is the fact that there are several drivers one I assume that comes within ubuntu 10.10 maverick and another from the linux wacom project https://help.ubuntu.com/community/Wacom/LatestDriver
and I guess another more talking about a special repo?

I wonder which one should I work with?

Favux
November 3rd, 2010, 05:55 AM
Hi Luis,

The wacom.ko is the usb kernel driver and you get that from linuxwacom.

Starting with Lucid and Xserver 1.7 Xorg took over the X driver (wacom_drv.so) for Wacom from linuxwacom. That's called xf86-input-wacom (the xserver-xorg-input-wacom package in Synaptic). The linuxwacom X driver only works on X servers less than 1.7.

To clone the git repository for 0.10.8+ see step II. in the Bamboo P&T HOW TO (http://ubuntuforums.org/showthread.php?t=1515562). Remember in Maverick you don't need to update the macros to v. 1.8, it's already that.

cordoval
November 3rd, 2010, 07:18 AM
Hi there,

I guess I needed to make sense of the script.sh wacom set commands there. I mean they did not turn out to be very self explanatory to me.

Now I just pressed one of the keys Button 2 which was set to key Ctrl and at the same time I was holding it and round my finger about the touch ring and it did the zooming effect I wanted.
So I guess a combination of keys would do that I wanted to do.

What I thought at first was that the four LEDs next to the touch ring to configure the different setups was going to work. I guess I will never get to use those LEDs??? Is this correct?

Can someone confirm me that those LEDs are only for Windows and stuff?

So it was working already out of the box, however, I did wanted to just press the button 1 and have the led switch to the second led and therefore second setting of the touch ring. I guess there is not such capability on ubuntu setup right?

Thanks

Favux
November 3rd, 2010, 07:44 AM
Can someone confirm me that those LEDs are only for Windows and stuff?
No, they can work. You can use sanette's modification of Christoph Karg's userland OLED applet: http://ubuntuforums.org/showpost.php?p=9888901&postcount=107 or Christoph's original. I link it on this thread and the one you're linked to above.

cordoval
November 3rd, 2010, 12:42 PM
The problem with them is that they don't consider the Intuos4 small version which does not have LEDs for the buttons but only 4 LEDs around the touch ring.

The buttons gets reduced to 7 I believe

Button2 - no display
Button3 - no display
Button4 - no display

Button1 (Touch Ring)

Button5 - no display
Button6 - no display
Button7 - no display

Favux
November 3rd, 2010, 04:32 PM
Ahh. I didn't know there was an Intuos4 model like that. So are those just LED's? They don't display anything like the models with OLED's do?

Let's find out the product ID for it:

cat /proc/bus/input/devices

cordoval
November 3rd, 2010, 05:11 PM
The OLEDs display the setup of the buttons for other models, but for the intuos4 small, there is not such OLEDs. Only 4 LEDs surrounding the touch ring
http://www.craftitonline.com/pub/wacom_intuos4_small_2.jpg



I: Bus=0003 Vendor=056a Product=00b8 Version=0104
N: Name="Wacom Intuos4 4x6"
P: Phys=
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/input/input16
U: Uniq=
H: Handlers=mouse1 event11
B: EV=1f
B: KEY=1cff 0 1f007f 0 0 0 0 0 0 0 0
B: REL=100
B: ABS=100 f000167
B: MSC=1


Also it came with 2 USB cables which seem identical, the only reason for that I assume it is for the lefty and righty options, but that is a curious redundancy as either can use any of the cables.

PS> sorry for my lack of consistency it is "are" rather than "is" in the graphic