PDA

View Full Version : [ubuntu] Xorg crashes after kernel upgrade



freund
April 8th, 2009, 07:54 PM
The system is a lenovo x60 tablet running 8.10.

After kernel version 2.6.27-7 Xorg keeps crashing and its because as soon as I have a line in the xorg.conf file the line
InputDevice "stylus" "SendCoreEvents"

in

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "TrackPoint"
# InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
# InputDevice "Synaptics Touchpad"
EndSection

it doesnt work.

Thus I can't use the pen.

It worked for kernel version 2.6.27-7 and previous but not after. I tried the new wacom driver on the wiki and it didn't help.

Help with this problem would be appreciated.

Favux
April 8th, 2009, 08:24 PM
Hi freund,

So you have Intrepid 8.10 and kernel 2.6.27-11? You installed linuxwacom and wacom-tools 0.8.1-6 from the deb.s on Loic2's Wacom wiki?

Doesn't your stylus have an eraser and some buttons?

I think we need to see the whole xorg.conf.

The first thing to know is that you have to have the same version of linuxwacom driver and wacom-tools. If you just installed the driver and still had the 0.8.1-4 wacom-tools that could be a problem.

freund
April 8th, 2009, 08:43 PM
If you https://help.ubuntu.com/community/Wacom yes. Yes I have Intrepid 8.10 and kernel 2.6.27-11 and xorg doesn't work with the

wacom-tools_0.8.1.6-1ubuntu2_i386.deb
xserver-xorg-input-wacom_0.8.1.6-1ubuntu2_i386.deb.

My stylus has a button and I use it. I commented out those sections just to see if it would work to no effect.

My xorg.conf is shown below


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
Load "wacom"
# Load "dbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
# Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "TrackPoint"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "HorizScrollDelta" "0"
Option "Emulate3Buttons" "true"
Option "EmulateWheel" "true"
Option "EmulateWheelButton" "2"
EndSection


#Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizScrollDelta" "0"
#EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/ttyS0"
# Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "PressCurve" "60,0,100,40" # Custom preference
# Option "Threshold" "50" # Custom preference
Option "Suppress" "3"
Option "Button1" "1"
Option "Button2" "3"
# Option "Button3" "3"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/ttyS0"
# Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/ttyS0"
# Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "Suppress" "5"
# Option "Button1" "1"
# Option "Button2" "2"
# Option "Button3" "3"
# Option "Mode" "Absolute"
EndSection

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
Driver "intel"
# Driver "i810"
BusID "PCI:0:2:0"
# ADD THIS IF YOUR LAPTOP DOES NOT HAVE A TV CONNECTOR or DOCKING STATION
Option "monitor-TV" "TV"
EndSection

# ADD THIS IF YOUR LAPTOP DOES NOT HAVE A TV CONNECTOR or DOCKING STATION
Section "Monitor"
Identifier "TV"
Option "Ignore" "True"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
# ADD A VIRTUAL LINE TO PROVIDE FOR THE LARGEST SCREENS YOU WILL HOTPLUG
Virtual 2048 2048
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "TrackPoint"
# InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
# InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Favux
April 8th, 2009, 09:06 PM
Hi freund,

My guess is it is something they have messed up with the update. They will probably fix it shortly. Because there is no reason 0.8.1-6 shouldn't work with kernel 2.6.27-11. I think the update said the new kernel headers were part of a security update? Could it be blocking "SendCoreEvents"?

One thing you could do is loose the "cursor" section and "cursor" in "ServerLayout". That is for a Wacom mouse which you don't have. Then you could check to see if your Wacom symlinks are in place. Comment out "Option "Device" "/dev/ttyS0"" and remove the comments from "Option "Device" "/dev/input/wacom"" and restart. See if that makes a difference.

freund
April 8th, 2009, 09:38 PM
Thanks Favux, I will let you know how it goes.

freund
April 8th, 2009, 10:02 PM
I tried the two things you suggested: 1) Deleted the "cursor" section and "cursor" in "ServerLayout". 2) Comment out "Option "Device" "/dev/ttyS0"" and remove the comments from "Option "Device" "/dev/input/wacom"" and restart.

I have the same problem it xorg won't boot with this configuration with wacom version 0.8.1-6 and kernel 2.6.27-11.

freund
April 8th, 2009, 10:12 PM
I just confirmed that xorg.conf still works for wacom version 0.8.1-6 and kernel 2.6.27-7 but not 2.6.27-11.

Favux
April 8th, 2009, 10:18 PM
Hi freund,

Ok then revert to the ttyS0 inputs again.

I was already running on the 2.6.27-11 kernel when the updates came through. There were several and I don't remember all of them. One was a new 2.6.27-11 kernel header which I think was part of a security update. The other I remember was an nVidia upgrade from 177 to 180.

The xorg.conf only crashes with Wacom? I guess you could try reinstalling the 0.8.1-6 deb.s and seeing if that makes a difference. From what you are saying you were using the default 0.8.1-4 linuxwacom for Intrepid, correct?

I compile my linuxwacom stuff so with the new kernel headers my module was disabled but xorg.conf wasn't broken. I actually compiled a new linuxwacom driver, not the one I had been using. And everything works fine. Another possibility is something has changed with how Ubuntu handles serial input because my tablet pc is usb.

freund
April 9th, 2009, 02:03 PM
Before this thread I tried both 0.8.1-6 and 0.8.1-4 deb.s wacom drivers after the kernel upgrade from 2.6.27-7 to 2.6.27-11 since it got broken with the kernel upgrade. It all works on 2.6.27-7. And everytime there was update to to the kernel I would retry Intrepid. My notebook is a quad boot machine and it works fine in Hardy with the same xorg.conf as it started on Intrepid (2.6.27-7).

I have an Intel graphics card so the Nvidia upgrade doesn't affect me. I will try the compile wacom driver route just to see whether that is the issue. Or I will just wait for Ubuntu 9.04.

Favux
April 9th, 2009, 07:01 PM
Hi freund,

With the X60 you shouldn't need to compile any of the newer drivers. The 0.8.1-6 should give you everything. Do you know if there was an update to your Xorg Intel driver?

freund
April 9th, 2009, 09:19 PM
There was but I can't remember when though. The upgrade didn't resolve the issue.

Favux
April 9th, 2009, 09:29 PM
Hi freund,

I'm sorry, which upgrade are you referring to?

What I'm going to do is work on your xorg.conf and make sure it's an Intrepid style the best I can. Then I'll compare it to some other X60t xorg's and see if I can spot a problem. This will take some time. But since you can boot into Hardy you should be OK, right?

Edit: Do you have a Synaptics Touchpad and does it work?

freund
April 9th, 2009, 10:03 PM
The intel driver was upgraded with no effect. I also tried to strip down the xorg.config to its minimum with no success. It always hangs when I introduce
InputDevice "stylus" "SendCoreEvents"
or equivalent for the eraser.

I don not have a Synaptics Touchpad and removed it from the xorg.conf file its legacy thing from my Dell notebook. Its commented out in the Section "ServerLayout"
.

Thanks for your effort its much appreciated.

Favux
April 9th, 2009, 10:42 PM
Hi freund,

I have been remiss in not providing some background. Basically they started deprecating xorg.conf in Intrepid. I can see you've spent a lot of time customizing your xorg.conf so that's probably hard to hear. They are introducing HAL (hardware abstraction layer) with dBUS input. HAL replaces a lot of xorg.conf configuration through configuration with its .fdi files.

Before I get into the test xorg.conf (sounds like you've already tried a lot of what I'll propose) did you have to put a line like:

/dev/ttyS0 port 0x220 irq 4 autoconfig
in /etc/serial.conf? And do you have setserial installed? If so try:

sudo /etc/init.d/setserial reload
And rebooting and restarting X a few times.

This would be test 1 of your xorg.conf:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

#Section "Files"
#FontPath "/usr/share/fonts/X11/misc"
#FontPath "/usr/share/fonts/X11/cyrillic"
#FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
#FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
#FontPath "/usr/share/fonts/X11/Type1"
#FontPath "/usr/share/fonts/X11/100dpi"
#FontPath "/usr/share/fonts/X11/75dpi"
## path to defoma fonts
#FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
#EndSection

#Section "Module"
#Load "i2c"
#Load "bitmap"
#Load "ddc"
## Load "dri"
#Load "extmod"
#Load "freetype"
#Load "glx"
#Load "int10"
#Load "vbe"
#Load "wacom"
## Load "dbe"
#EndSection

#Section "InputDevice"
#Identifier "Generic Keyboard"
#Driver "kbd"
#Option "CoreKeyboard"
#Option "XkbRules" "xorg"
#Option "XkbModel" "pc104"
## Option "XkbModel" "pc105"
#Option "XkbLayout" "us"
#Option "XkbOptions" "lv3:ralt_switch"
#EndSection

#Section "InputDevice"
#Identifier "Configured Mouse"
#Driver "mouse"
#Option "CorePointer"
#Option "Device" "/dev/input/mice"
#Option "Protocol" "ImPS/2"
#Option "ZAxisMapping" "4 5"
#Option "Emulate3Buttons" "true"
#EndSection

#Section "InputDevice"
#Identifier "TrackPoint"
#Driver "mouse"
#Option "CorePointer"
#Option "Device" "/dev/input/mice"
#Option "Protocol" "ExplorerPS/2"
#Option "ZAxisMapping" "4 5"
#Option "HorizScrollDelta" "0"
#Option "Emulate3Buttons" "true"
#Option "EmulateWheel" "true"
#Option "EmulateWheelButton" "2"
#EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/ttyS0"
# May use "/dev/input/wacom" if Wacom symlinks in place
# Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "PressCurve" "60,0,100,40" # Custom preference
# Option "Threshold" "50" # Custom preference
#Option "Suppress" "3"
#Option "Button1" "1"
Option "Button2" "3"
# Option "Button3" "3"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/ttyS0"
# May use "/dev/input/wacom" if Wacom symlinks in place
# Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
Driver "intel"
# Driver "i810"
BusID "PCI:0:2:0"
# ADD THIS IF YOUR LAPTOP DOES NOT HAVE A TV CONNECTOR or DOCKING STATION
Option "monitor-TV" "TV"
EndSection

# ADD THIS IF YOUR LAPTOP DOES NOT HAVE A TV CONNECTOR or DOCKING STATION
Section "Monitor"
Identifier "TV"
Option "Ignore" "True"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
# ADD A VIRTUAL LINE TO PROVIDE FOR THE LARGEST SCREENS YOU WILL HOTPLUG
Virtual 2048 2048
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
#InputDevice "Generic Keyboard"
## InputDevice "Configured Mouse"
#InputDevice "TrackPoint"
InputDevice "stylus" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
If it boots, with or without the "SendCoreEvents" then maybe try simplifying video to something like:

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
or maybe

Section "Device"
Identifier "Configured Video Device"
Driver "intel"
EndSection
while also commenting out the "DRI" section.

Obviously once you get things working you could start introducing things back. By the way the xorg.conf in Jaunty is apparently even more simplified and I don't have a good handle on it at all.

Edit: Some links. http://math.dartmouth.edu/~sarunas/x60_intrepid.html
http://www.thinkwiki.org/wiki/Installing_Ubuntu_8.10_(Intrepid_Ibex)_on_a_ThinkP ad_X61 (I don't know how much difference there is between the X60 and X61)

freund
April 17th, 2009, 05:48 PM
I tried the xorg.conf and it crashes all kernels.

I am just going to wait for 9.04 since I am superbusy right now.
sorry.
thanks for all your effort.