View Full Version : [ubuntu] X11 issues with SheepShaver

April 2nd, 2009, 11:47 PM
I am trying to compile SheepShaver to use on Ubuntu, but stuck with this last problem:

checking for mon... no
configure: WARNING: Could not find mon, ignoring --with-mon.
checking for sem_init in -lposix4... no
checking for cos in -lm... yes
checking for X... no
configure: error: You need X11 to run SheepShaver.

X11 is installed, I don't get it. Unless it has something to do with perl? Also, am supposed to "Make" the resulting file, but can't figure out how to use make, at least when I do, its says: no makefile

April 3rd, 2009, 05:46 AM
I'm currently using the dreaded Winblows and hating every second (blame the iPhone), so I can't check what the lib names are. But you need to install X11's development packages.

You can probably find the right ones with something like:

apt-cache search x11 dev

and install them like so:

sudo apt-get install PACKAGE_NAME

The procedure for compilation is normally something along the lines of:

make install

depending on the package. You may not need the last stage. It may need to be run with sudo. You should get a README or INSTALL file along with it that gives you a better indication.

April 4th, 2009, 12:08 AM
You need pthreads to run SheepShaver.

and locate:

locate pthread

glibc is installed.

Is this a specific pthread needed to run SheepShaver or SheepShaver compiler can't find the pthreads installed?

am downloading Kaffe Pthreads to check if this is what is missing.

April 4th, 2009, 12:19 AM
I've checked Posix Threads on Wiki (https://computing.llnl.gov/tutorials/pthreads/#Compiling)https://computing.llnl.gov/tutorials/pthreads/#Compiling

and I have gcc and g++ installed. What gives. This should compile?

April 4th, 2009, 12:21 AM
configure: error: You need pthreads to run SheepShaver.

I have g++ and gcc installed. What gives, this should compile?

April 4th, 2009, 12:27 AM
Install the build-essential package.

April 4th, 2009, 12:38 AM
SOLVED: using this excellent How To (http://ubuntuforums.org/showthread.php?t=670336), wish I had found it to begin with.

Use this page to get the CVS (http://gwenole.beauchesne.info/en/projects/sheepshaver#getting_help)

April 4th, 2009, 12:45 AM
Threads merged.

April 4th, 2009, 01:18 PM
Threads merged.

Thanks bodhi.zazen for this piece of zen. Do you know where I can get an older Apple Rom? Mac is Very scarce in the third world. Have tried all the torrents but no luck. I actually own two Powerbooks, but they not working.