PDA

View Full Version : Call of Duty 4 and wine 1.1.17



Diblic
March 28th, 2009, 12:27 PM
Hey everyone

So my problem is that when I try and run Call of Duty 4 on Wine 1.1.17 (Using Ubuntu 8.10) it does not run full screen, instead it leaves my Avant window manager on the bottom and my task bar at the top visible. (For example I cannot click "apply" when changing settings in CoD because the Avant in on the way) Here is a picture for reference http://tinypic.com/view.php?pic=24d0weu&s=5 .

My question is, that what can I do to run it fullscreen?

I am completely new to Linux, been using Ubuntu for like a week now, so please consider that in your answer :D

Best regards and thanks in advance!

-Diblic-

asda__
March 29th, 2009, 01:05 PM
Just go to Wine settings (Terminal > winecfg) and there, in the "Graphics" tab, uncheck "Allow the window manager to decorate windows".

Diblic
March 30th, 2009, 04:05 PM
That did not work, the menus are still there :(

Stunts
March 30th, 2009, 04:11 PM
Hello!
Try to turn of compiz and replace it with metacity.
just press "Alt+F2" and type:


metacity --replace


Wine doesn't play well with compiz.
After you are done playing you can turn the desktop effects back on by doing the opposite in "Alt+F2":


compiz --replace


This should at least make the menu bar go away. as for AWN, well, Maybe try an auto hide function?
Good luck!

Diblic
March 30th, 2009, 04:14 PM
Found a solution, I unchecked both, "allow window manager to decorate windows" and "allow window manager to control windows" and now its running all good and full screen. ;D

Stunts
March 30th, 2009, 04:15 PM
Glad to hear that!
Have fun!

Diblic
March 30th, 2009, 04:40 PM
Hmm,

now I have to get Garena running but thats completely another story...

:D

Stunts
March 30th, 2009, 10:05 PM
Try the winehq appdb.
It's a great resource for that sort of thing.
Good luck once again.

x3|rAGE
April 1st, 2009, 09:30 AM
Diblic, I ran into the same problem but I found a solution for keeping "allow window manager to decorate windows" and "allow window manager to control windows" enabled. Deactivate them and then go into your game. Adjust your game resolution to match your desktop's resolution. Go back into wine settings and enable "allow window manager to decorate windows" and "allow window manager to control windows" and you should be able to use desktop effects, most notably the cube, while the game is running. :)

Dale Lewis
July 24th, 2009, 03:20 AM
Hi folks...Hope I am in the right place and not hijacking this thread. I have COD 4 running under the git version of wine `1.1.26 on Juanty 64 bit. The games runs great while loading but when you enter game play from the menu and you select your mission it will load and the graphics will turn white to the point it's not playable. My graphics card is an Nvidia 9400 with a gig of ram...any ideas on why that could be happening? Thanks!!!!!!

Stunts
July 24th, 2009, 08:51 AM
Something similar happens when playing warcraft3 and switching application/desktop.
On war3 activating the option "emulate a virtual desktop" solves that issue. Maybe you can try something similar?
try running it like this:


wine explorer /desktop=0,1280x1024 "path_to_call_of_duty4.exe"
Where you replace 1280x1024 for your full screen resolution. (and of course enter the correct path between the quotes).

Good luck.

Dale Lewis
July 24th, 2009, 11:23 PM
Tried to no avail...I can't find any additional info on this issue either. Thanks!!

Dale Lewis
July 25th, 2009, 08:07 AM
Needed to match screen depth...that corrected it!

Stunts
July 25th, 2009, 09:20 PM
Glad you got it to work. =-)