PDA

View Full Version : alacarte in 9.04



mrm48
March 23rd, 2009, 03:15 PM
Hi all,

I cannot access alacarte in 9.04. If I run it from the terminal, this is what I get:

# alacarte
Traceback (most recent call last):
File "/usr/bin/alacarte", line 22, in <module>
from Alacarte.MainWindow import MainWindow
ImportError: No module named Alacarte.MainWindow

has anyone found a fix for this or is there another way to edit the menu?

Thanks,
Matt

dBuster
March 23rd, 2009, 04:26 PM
Do you not have an option in SYSTEM -> Preferences for MAIN MENU? That is where I make all my changes.

I believe it is preferences, might be system though... I am at work using unfortunately a windows box...

binbash
March 23rd, 2009, 04:39 PM
alacarte command works fine here

Aenima99x
March 23rd, 2009, 06:26 PM
Same problem here, can't edit the Main Menu at all.
Running Alacarte from a terminal gives same error as OP.
Right-clicking Main-menu icon and choosing "Edit Menus" does nothing.
Running Main Menu from System\Preferences does nothing.

Any ideas? :(

Aenima99x
March 23rd, 2009, 07:09 PM
Fixed it by reinstalling Alacarte.
The deb file is here if needed (https://launchpad.net/ubuntu/jaunty/hppa/alacarte/0.11.10-0ubuntu1)

taavikko
March 23rd, 2009, 07:16 PM
Fixed it by reinstalling Alacarte.
The deb file is here if needed (https://launchpad.net/ubuntu/jaunty/hppa/alacarte/0.11.10-0ubuntu1)

There's no need to distribute deb files that way,
since it's available in repositories. And part of an default install
If there's no network connection available, that might be the last resort.



sudo apt-get --reinstall install alacarte
would have sufficed.

Aenima99x
March 23rd, 2009, 07:26 PM
Ummm yeah, hence the phrase IF NEEDED. :roll:

mrm48
March 24th, 2009, 12:52 AM
Thanks,

Got it working by reinstalling alacarte like was suggested.