PDA

View Full Version : [ubuntu] Can't install qutim!



hello_from_russia!
March 17th, 2009, 02:38 AM
Hello!
Sorry, but I just start to use Linux and may be I do something wrong. I use ubuntu 8.10 but I can't install qutim. I added the url to /etc/apt/sources.list than I updated by "sudo apt-get update" and try to install qutim by "sudo apt-get install qutim". So my terminal displayed me that my package can't be installed because there are some problems with dependences.
qutim depends from libqt4-core (>= 4.3.4) and libqt4-gui (>= 4.3.4) but they will be not installed... Packages are broken. Please, help me... :(

Partyboi2
March 17th, 2009, 02:57 AM
What 'url' did you add to your sources.list?

hello_from_russia!
March 17th, 2009, 03:05 AM
What 'url' did you add to your sources.list?

I tryed to add these repositories:
deb http://ppa.launchpad.net/smakc/ubuntu hardy main
deb http://qutim.org/debian/ unstable main
May be I mistake?

taurus
March 17th, 2009, 03:08 AM
If you are running intrepid, how come you added a repo from hardy?

Partyboi2
March 17th, 2009, 03:09 AM
Remove those from your sources.list. Then make sure you have "multiverse" enabled in your sources.list. (System>Admin>Software Sources>1st tab) then either search synaptic for 'qutim' and install or you can install it from the terminal (Applications>Accessories>Terminal)

sudo apt-get install qutim

hello_from_russia!
March 17th, 2009, 03:36 AM
Remove those from your sources.list. Then make sure you have "multiverse" enabled in your sources.list. (System>Admin>Software Sources>1st tab) then either search synaptic for 'qutim' and install or you can install it from the terminal (Applications>Accessories>Terminal)

sudo apt-get install qutim

I have "multiverse" enabled in my sources.list. I searched synaptic for 'qutim' and tryed to install but message window appeared, there written that:
'Could not mark all packages for installation or upgrade
The following packages have unresolvable dependencies.
Make sure that all required repositories are added and enabled in the preferences.
qutim:
depend: libqt4-core but it is not going to be installed
depend: libqt4-gui but it is not going to be installed
Рекомендует: qutim-emoticons but it is not going to be installed'

taurus
March 17th, 2009, 03:50 AM
Did you remember to run sudo apt-get update first?


sudo apt-get update
sudo apt-get install qutim

hello_from_russia!
March 17th, 2009, 03:54 AM
Did you remember to run sudo apt-get update first?


sudo apt-get update
sudo apt-get install qutim

yes, I always update when I change my sources.list

taurus
March 17th, 2009, 03:57 AM
Post your /etc/apt/sources.list.


cat /etc/apt/sources.list

hello_from_russia!
March 17th, 2009, 07:47 AM
# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://ru.archive.ubuntu.com/ubuntu/ intrepid main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid main restricted
## Major bug fix updates produced after the final release of the
## distribution.
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid universe
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates universe
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
deb http://rusxmms.sourceforge.net/ubuntu/rusxmms dapper main
## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu intrepid partner
deb-src http://archive.canonical.com/ubuntu intrepid partner
deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb http://security.ubuntu.com/ubuntu intrepid-security universe
deb-src http://security.ubuntu.com/ubuntu intrepid-security universe
deb http://security.ubuntu.com/ubuntu intrepid-security multiverse
deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse
deb http://ppa.launchpad.net/tualatrix/ubuntu hardy main
deb-src http://ppa.launchpad.net/tualatrix/ubuntu hardy main
deb http://rusxmms.sourceforge.net/ubuntu/rusxmms dapper main
deb http://wine.budgetdedicated.com/apt intrepid main

deb http://ppa.launchpad.net/qgis/ubuntu hardy main
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-backports restricted main multiverse universe
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-proposed restricted main multiverse universe

Partyboi2
March 17th, 2009, 10:13 AM
Try disabling all the non intrepid repos in your sources.list. Open a terminal and

gksu gedit /etc/apt/sources.listthen add a # infront of all the non intrepid repos.

# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://ru.archive.ubuntu.com/ubuntu/ intrepid main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid main restricted
## Major bug fix updates produced after the final release of the
## distribution.
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid universe
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates universe
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
#deb http://rusxmms.sourceforge.net/ubuntu/rusxmms dapper main
## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu intrepid partner
deb-src http://archive.canonical.com/ubuntu intrepid partner
deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb http://security.ubuntu.com/ubuntu intrepid-security universe
deb-src http://security.ubuntu.com/ubuntu intrepid-security universe
deb http://security.ubuntu.com/ubuntu intrepid-security multiverse
deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse
#deb http://ppa.launchpad.net/tualatrix/ubuntu hardy main
#deb-src http://ppa.launchpad.net/tualatrix/ubuntu hardy main
#deb http://rusxmms.sourceforge.net/ubuntu/rusxmms dapper main
deb http://wine.budgetdedicated.com/apt intrepid main
#deb http://ppa.launchpad.net/qgis/ubuntu hardy main
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-backports restricted main multiverse universe
deb http://ru.archive.ubuntu.com/ubuntu/ intrepid-proposed restricted main multiverse universeThen save close gedit, then

sudo apt-get update && sudo apt-get install qutim

hello_from_russia!
March 17th, 2009, 12:31 PM
Thanks for your advice, I've done it but situation doesn't change :(

taurus
March 17th, 2009, 01:34 PM
What is the whole output of command?


sudo apt-get update

hello_from_russia!
March 17th, 2009, 02:28 PM
The whole output is:

В кеше http://ru.archive.ubuntu.com intrepid Release.gpg
В кеше http://ru.archive.ubuntu.com intrepid/main Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid/restricted Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid/universe Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid/multiverse Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid-updates Release.gpg
В кеше http://ru.archive.ubuntu.com intrepid-updates/main Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid-updates/restricted Translation-ru
В кеше http://archive.canonical.com intrepid Release.gpg
Игн http://archive.canonical.com intrepid/partner Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid-updates/universe Translation-ru
Игн http://ppa.launchpad.net hardy Release.gpg
Игн http://ppa.launchpad.net hardy/main Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid-updates/multiverse Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid-backports Release.gpg
Игн http://ru.archive.ubuntu.com intrepid-backports/restricted Translation-ru
Игн http://ru.archive.ubuntu.com intrepid-backports/main Translation-ru
Игн http://ru.archive.ubuntu.com intrepid-backports/multiverse Translation-ru
Игн http://ru.archive.ubuntu.com intrepid-backports/universe Translation-ru
В кеше http://archive.canonical.com intrepid Release
В кеше http://ru.archive.ubuntu.com intrepid-proposed Release.gpg
В кеше http://ru.archive.ubuntu.com intrepid-proposed/restricted Translation-ru
Получено:1 http://ppa.launchpad.net hardy Release [27,6kB]
В кеше http://ru.archive.ubuntu.com intrepid-proposed/main Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid-proposed/multiverse Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid-proposed/universe Translation-ru
В кеше http://ru.archive.ubuntu.com intrepid Release
Игн http://ppa.launchpad.net hardy/main Packages
В кеше http://archive.canonical.com intrepid/partner Packages
В кеше http://ru.archive.ubuntu.com intrepid-updates Release
В кеше http://ru.archive.ubuntu.com intrepid-backports Release
В кеше http://ru.archive.ubuntu.com intrepid-proposed Release
В кеше http://ppa.launchpad.net hardy/main Packages
В кеше http://ru.archive.ubuntu.com intrepid/main Packages
В кеше http://archive.canonical.com intrepid/partner Sources
В кеше http://ru.archive.ubuntu.com intrepid/restricted Packages
В кеше http://ru.archive.ubuntu.com intrepid/main Sources
В кеше http://ru.archive.ubuntu.com intrepid/restricted Sources
В кеше http://ru.archive.ubuntu.com intrepid/universe Packages
В кеше http://ru.archive.ubuntu.com intrepid/universe Sources
В кеше http://ru.archive.ubuntu.com intrepid/multiverse Packages
В кеше http://ru.archive.ubuntu.com intrepid/multiverse Sources
В кеше http://ru.archive.ubuntu.com intrepid-updates/main Packages
В кеше http://ru.archive.ubuntu.com intrepid-updates/restricted Packages
В кеше http://ru.archive.ubuntu.com intrepid-updates/main Sources
В кеше http://ru.archive.ubuntu.com intrepid-updates/restricted Sources
В кеше http://ru.archive.ubuntu.com intrepid-updates/universe Packages
В кеше http://ru.archive.ubuntu.com intrepid-updates/universe Sources
В кеше http://ru.archive.ubuntu.com intrepid-updates/multiverse Packages
В кеше http://ru.archive.ubuntu.com intrepid-updates/multiverse Sources
В кеше http://ru.archive.ubuntu.com intrepid-backports/restricted Packages
В кеше http://ru.archive.ubuntu.com intrepid-backports/main Packages
В кеше http://ru.archive.ubuntu.com intrepid-backports/multiverse Packages
В кеше http://ru.archive.ubuntu.com intrepid-backports/universe Packages
В кеше http://ru.archive.ubuntu.com intrepid-proposed/restricted Packages
В кеше http://ru.archive.ubuntu.com intrepid-proposed/main Packages
В кеше http://ru.archive.ubuntu.com intrepid-proposed/multiverse Packages
В кеше http://ru.archive.ubuntu.com intrepid-proposed/universe Packages
В кеше http://security.ubuntu.com intrepid-security Release.gpg
Игн http://security.ubuntu.com intrepid-security/main Translation-ru
Игн http://security.ubuntu.com intrepid-security/restricted Translation-ru
Игн http://security.ubuntu.com intrepid-security/universe Translation-ru
Игн http://security.ubuntu.com intrepid-security/multiverse Translation-ru
В кеше http://security.ubuntu.com intrepid-security Release
В кеше http://security.ubuntu.com intrepid-security/main Packages
В кеше http://security.ubuntu.com intrepid-security/restricted Packages
В кеше http://security.ubuntu.com intrepid-security/main Sources
В кеше http://wine.budgetdedicated.com intrepid Release.gpg
Игн http://wine.budgetdedicated.com intrepid/main Translation-ru
В кеше http://wine.budgetdedicated.com intrepid Release
Игн http://wine.budgetdedicated.com intrepid/main Packages
В кеше http://wine.budgetdedicated.com intrepid/main Packages
В кеше http://security.ubuntu.com intrepid-security/restricted Sources
В кеше http://security.ubuntu.com intrepid-security/universe Packages
В кеше http://security.ubuntu.com intrepid-security/universe Sources
В кеше http://security.ubuntu.com intrepid-security/multiverse Packages
В кеше http://security.ubuntu.com intrepid-security/multiverse Sources
Получено 1Б за 15s (0Б/c)
Чтение списков пакетов... Готово