View Full Version : [ubuntu] ubuntu 8.1 not detecting RAM

March 16th, 2009, 05:20 PM
I'm new to ubuntu, just installed it. I have 1.25 GB RAM on my laptop, but ubuntu is recognizing only 256MB. I had problems while installing too, so I googled, someone mentioned that if we remove the extra RAM added, then the installation will go through. I tried it and it worked (my laptop came with 256MB, I added 1GB later).

Now, its detecting only 256MB RAM, ignoring rest 1GB. Can someone tell me how to fix this?

Thank you

March 16th, 2009, 05:26 PM
Is it possible you have the wrong RAM for your machine?
Did you just install it?

Does MEMTEST86 see it? (ram check option when booting from ubuntu install CD)

March 16th, 2009, 05:31 PM
Have you looked in the BIOS to see if it detects all your RAM?

March 16th, 2009, 05:43 PM
Nope, RAM has been there for years...I don't think anything would be wrong with it. Since ubuntu didn't install, I removed it, installed ubuntu and put it back.

Nope, I haven't run MEMTEST. Will try today evening and report back.

March 16th, 2009, 05:46 PM
Also, should I always remove any extra RAM added, before installing Ubuntu?

March 16th, 2009, 05:56 PM
Since you removed it, installed Ubuntu, then reinstalled the RAM, have you checked to see whether the RAM is physically seated correctly? Not loose, etc., something to take a look at if you've not already done so.

March 16th, 2009, 06:54 PM
Yes, I checked it, its seated correctly. I'll check again when I go home in the evening.