PDA

View Full Version : [ubuntu] intrepid gnome-ppp dialer permission problem



jeff35
March 15th, 2009, 01:50 PM
I am trying to connect my ubuntu system online.
I have the modem found, ran pppdconfig(as I remember) i need to write this down better. setup wvdialer.conf, and changed the permisions. when i dial out i get:


OK
--> Modem initialized.
--> Sending: ATM1L3DT3018226
--> Waiting for carrier.
ATM1L3DT3018226
CONNECT 460800
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sat Mar 14 12:20:48 2009
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 8107
--> Disconnecting at Sat Mar 14 12:20:49 2009
--> The PPP daemon has died: pppd options error (exit code = 2)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 2)

where is the /ect/ppp/pap-secrets: and chap-secrets file located?
what file do I modify now?

jeff35
March 15th, 2009, 08:01 PM
update
next i made pap-secrets, and chap-secrets with 777 permission:

# Secrets for authentication using PAP
# client ....server....... secret ......IP addresses
you@copper.net * password

and now i get modem results of:

OK
--> Modem initialized.
--> Sending: ATM1L3DT3018226
--> Waiting for carrier.
ATM1L3DT3018226
CONNECT 460800
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sun Mar 15 02:26:15 2009
--> Pid of pppd: 10499
--> Disconnecting at Sun Mar 15 02:26:16 2009
--> The PPP daemon has died: pppd options error (exit code = 2)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 2)


I think its closer, still working on it tho any suggestion?

lee292
March 17th, 2009, 01:04 AM
If it's any comfort, you're not alone! I'm getting errors very similar to yours. The "secrets" files are in /etc/ppp, if you haven't already found them. I modified them but the ppp daemon still dies!

jeff35
March 19th, 2009, 02:35 AM
on my system i had to create 3 file as root located in the /etc/ppp diectory,
pap-secrets
chap-secrets
options

gave them all 777 permision
sudo -i

as root chmod 777 /etc/ppp/file

where file was pap-secrets, chap-secrets, options

now i gwt online, but cant do anything, i have java installed in firefox.

results;
OK
--> Modem initialized.
--> Sending: ATDT301 8226
--> Waiting for carrier.
ATDT301 8226
CONNECT 460800
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Wed Mar 18 14:57:06 2009
--> Pid of pppd: 10497
--> Using interface ppp0
--> pppd: �[10]�[08]([08]�[08]
--> pppd: �[10]�[08]([08]�[08]
--> pppd: �[10]�[08]([08]�[08]
--> pppd: �[10]�[08]([08]�[08]
--> pppd: �[10]�[08]([08]�[08]
--> local IP address 24.155.175.84
--> pppd: �[10]�[08]([08]�[08]
--> remote IP address 66.90.132.234
--> pppd: �[10]�[08]([08]�[08]
--> primary DNS address 67.211.172.29
--> pppd: �[10]�[08]([08]�[08]
--> secondary DNS address 67.211.172.30
--> pppd: �[10]�[08]([08]�[08]
defaultroute
restore default path
restoredefaultroute
--> pppd: �[10]�[08]([08]�[08]
--> Connect time 1.5 minutes.
--> pppd: �[10]�[08]([08]�[08]
--> pppd: �[10]�[08]([08]�[08]
--> pppd: �[10]�[08]([08]�[08]
--> Disconnecting at Wed Mar 18 14:58:39 2009
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds

what now i am still stuck?

robin0800
March 22nd, 2009, 12:59 PM
What I did was to force gnome ppp to start with root permissions.
This should be the default, it is for kppp but not for gnome.
I did this in KDE, added kdesudo to the icon executable.
Not sure how you do this in gnome.

fredbird67
May 12th, 2009, 02:25 AM
In GNOME or Xfce, it would be "gksudo gnome-ppp"