PDA

View Full Version : [ubuntu] Can't connect to internet...local network OK



64mgb
March 12th, 2009, 02:20 AM
I've seen several similar posts, but so far have not found a solution to my problem. I'm running Ubuntu 8.10 on my MythTV box and something has gone wrong with the networking on it...I had made no changes other than to replace what I believe is a bad video card.

But when the networking didn't work I decided to try some things. On this box, I have a static IP address because I don't want to have to reconfigure MythTV every time the box gets a new IP address from DCHP. I don't remember all the steps I took and why, but along the way I removed network-manager. Now I can connect to my local network ok, but can't connect to the internet.

If anyone thinks they can help me with this problem, please let me know what to post and I'll get it posted as soon as possible.

Thanks,
Rich

punx45
March 12th, 2009, 02:37 AM
show us the contents of /etc/network/interfaces and /etc/resolv.conf

probably just need to correct a gateway or nameserver setting

64mgb
March 12th, 2009, 02:43 AM
Here is interfaces:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.199
netmask 255.255.255.0
gateway 192.168.1.1

auto eth1
#iface eth1 inet dhcp

auto eth2
#iface eth2 inet dhcp

auto ath0
#iface ath0 inet dhcp

auto wlan0
#iface wlan0 inet dhcp


And here is resolv.conf:

# Generated by NetworkManager


Thanks,
Rich

punx45
March 12th, 2009, 02:48 AM
add


nameserver 192.168.1.1

to /etc/resolv.conf (back it up first)
then reset networking


/etc/init.d/networking restart
and that should take care of it.

that will use your routers settings for DNS servers, which are likely passed down from your ISP. if you wish, you can also look up the IPs for the OpenDNS servers and substitute that in the file.

64mgb
March 12th, 2009, 02:55 AM
add


nameserver 192.168.1.1

to /etc/resolv.conf (back it up first)
then reset networking


/etc/init.d/networking restart
and that should take care of it.

that will use your routers settings for DNS servers, which are likely passed down from your ISP. if you wish, you can also look up the IPs for the OpenDNS servers and substitute that in the file.

Outstanding! Thanks punx45!

Rich