PDA

View Full Version : No puc actualitzar 3 paquets!



tanreb20
March 10th, 2009, 04:41 PM
Bon dia! Fa uns dies que estic tenint problemes per actualitzar el sistema(linux mint - ubuntu 8.19)

Quan em recomaana alguna actualització em surten 3 paquets que no puc seleccionar. Com es veu a la imatge.

He intentat fer uns updates i upgrades, treure els paquets trencats etc...

Fa uns dies vaig toquetejar el kernel i en vaig instalar un que no em va funcionar, el vaig desinstalar i esborrar els arxius del kernel. Pt tenir alguna cosa a veure?

http://img142.imageshack.us/img142/1130/capturaj.th.png (http://img142.imageshack.us/my.php?image=capturaj.png)

http://img142.imageshack.us/img142/967/screenshot01.png

oriolsbd
March 10th, 2009, 08:00 PM
Prova de mirar les dependències que tenen. Potser és dels paquets que has borrat.

Per a fer-ho, obre el Synaptic. Busca algun dels tres paquets i, fent clic amb el botó dret, mira'n les propietats. A la pestanya "Dependències" les podràs trobar.

Salut!

tanreb20
March 11th, 2009, 12:19 AM
Ho he fet i he instalat el que me sugeria pero no va.

Em surt aixo a synaptic:

http://img12.imageshack.us/img12/4050/capturat.th.png (http://img12.imageshack.us/my.php?image=capturat.png)

I si intento marcar-la per actualitzar


g++:
Depén: cpp (>=4:4.3.2-2ubuntu1) però s'instal·larà 4:4.3.1-1ubuntu2
Depén: gcc (>=4:4.3.2-2ubuntu1) però s'instal·larà 4:4.3.1-1ubuntu2

torracastanyes
March 11th, 2009, 01:09 PM
Em penso que aquests paquets són del compilador que vas utilitzar per instalar el kernel aquell. Jo els eliminaría.
Mira també si per baixar-te el kernel vas activar algún repositori especial que et doni problemes amb les versions.