PDA

View Full Version : [ubuntu] Nvidia Geforce 9500 GT Driver



Opt-Crysys
March 8th, 2009, 05:31 AM
Hello, I'm new to Ubuntu, and I can't seem to find a driver for my Graphics card, I have been searching for a long time now, and I can't find one. I was looking for one as per the instructions on playing World of Warcraft. It told me to use Envy, but before that I put in:


glxinfo | grep rendering

It should come up with a yes but for me it said no, I was wondering if there is a driver for my particular Card. Thanks in advance, for helping a new person out, sorry if didn't provide information on something.

ivanvajar
March 8th, 2009, 05:54 AM
Open System/Administration/Hardware Drivers. Do you see any proprietary drivers in use? If don't have Hardvare Drivers application installed, say so. We'll install it together.

ivanvajar
March 8th, 2009, 05:59 AM
Generally, you can go to Applications/Add/Remove Applications, search for NVIDIA binary X.Org 'new' driver and install it. nVidia is well supported in Linux.

Opt-Crysys
March 8th, 2009, 06:06 AM
Ok when I go to System/Administration/Hardware Drivers I don't see anything, but I did search it up on the add/remove apps, and I found it and installed, now I don't know if you know but when you do that, before when I tried to start the app World of warcraft, the rendering would be awful, and I'd have to quit out now it says failed to find a suitable display device

shinobitux
March 8th, 2009, 06:41 AM
I commonly encounter this issue with World of Warcraft when running the open source version of the nvidia driver: "nv" (Envy?) which doesn't have hardware acceleration.

First things first, please post your /etc/X11/xorg.conf file. This file is where you setup your appropriate video driver. For example mine looks like this:


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder57) Mon Oct 27 14:38:08 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "BenQ FP71G"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
#Driver "nv"
VendorName "NVIDIA Corporation"
BoardName "GeForce4 Ti 4200 with AGP8X"

BusID "PCI:1:0:0"

Option "RenderAccel" "True"
#Option "UseEvents" "False"
#Option "TripleBuffer" "1"
#Option "DamageEvents" "1"
#Option "PixmapCacheSize" "70000"
#Option "OnDemandVBlankInterrupts" "True"

Option "AddARGBGLXVisuals" "True"
#Option "NoRenderExtension" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"

#Virtual 1280 1024
EndSubSection
EndSection

#Section "Extensions"
# Option "Composite" "Enable"
#EndSection

If you look at my 'Section "Device"' you can see I have 'Driver "nvidia"' set up. Find out what yours is...that'll give us a starting point.

I don't recommend you copying my config file as I've tampered with it to get it this way. In most cases, if you don't have an appropriately configured config file your want to do this:


sudo nvidia-settings

A graphical interface for your nvidia card will show up. If you select "X Server Display Configuration" from the left-side menu you'll get a screen with the option to "Save to X Configuration File" on the bottom right, then restart your machine or Ctrl-Alt-BSPC to restart your X server. That's usually where I start with my nvidia cards. I have two computer with nvidia graphics cards (one ubuntu, one fedora) and I have WoW up and running on both of them.

Hope this helps.

PS - It's a good idea to back up your /etc/X11/xorg.conf file every time you make a major change. I think nvidia-settings automatically makes a backup though.

shinobitux
March 8th, 2009, 06:48 AM
Oh! I almost forgot!

You'll get horrible rendering in WoW unless you edit your Config.wtf file for in World of Warcrafts WTF/ directory. Mine's in /home/isaac/.wine/drive_c/Program\ Files/World\ of\ Warcraft/WTF/Config.wtf

I forgot exactly where I learned to configure that file but this line is mandatory in all my nvidia machines:


SET gxAPI "OpenGL"

See: http://www.wowwiki.com/Wine

There's also like a hundred other tweaks you can do to that config file.

Here's mine:


SET locale "enUS"
SET hwDetect "0"
SET gxColorBits "24"
SET gxDepthBits "24"
SET gxResolution "1280x1024"
SET gxRefresh "50"
SET gxMultisampleQuality "0.000000"
SET fullAlpha "1"
SET doodadAnim "0"
SET SmallCull "0.040000"
SET DistCull "500.000000"
SET trilinear "1"
SET frillDensity "24"
SET farclip "450.000000"
SET specular "1"
SET pixelShaders "1"
SET particleDensity "1.000000"
SET unitDrawDist "300.000000"
SET movie "0"
SET readTOS "1"
SET readEULA "1"
SET realmList "us.logon.worldofwarcraft.com"
SET patchlist "us.version.worldofwarcraft.com"
SET gxApi "opengl"
SET readScanning "-1"
SET readContest "-1"
SET readTerminationWithoutNotice "-1"
SET coresDetected "1"
SET videoOptionsVersion "1"
SET showToolsUI "1"
SET Sound_OutputDriverName "System Default"
SET realmName "Twisting Nether"
SET ChatMusicVolume "0.29999998211861"
SET ChatSoundVolume "0.39999997615814"
SET ChatAmbienceVolume "0.29999998211861"
SET Sound_MasterVolume "1"
SET Sound_SFXVolume "1"
SET Sound_MusicVolume "0.40000000596046"
SET Sound_AmbienceVolume "0.60000002384186"
SET Sound_ZoneMusicNoDelay "1"
SET gameTip "95"
SET OutboundChatVolume "1"
SET InboundChatVolume "1"
SET VoiceActivationSensitivity "0.39999997615814"
SET Sound_VoiceChatInputDriverName "System Default"
SET Sound_VoiceChatOutputDriverName "System Default"
SET autoLootCorpse "1"
SET installType "Retail"
SET portal "us"
SET Gamma "1.000000"
SET mouseSpeed "1.2999999523163"
SET accountName "isaacmack"
SET lastCharacterIndex "9"

Make sure you change


SET gxResolution "1280x1024"

to whatever resolution you're running. It's not necessary but in my experience it helps.

Opt-Crysys
March 8th, 2009, 06:49 AM
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

Ok so there it is, I tried


gksudo nvidia-settings

and it said it wasn't a command(sorry if I seem stupid in this), but yea I see at the same my "section" as me having kdb? I'm not sure

Opt-Crysys
March 8th, 2009, 06:51 AM
Ah yes, I have added the line in my configure, no worries on that...

shinobitux
March 8th, 2009, 06:52 AM
Don't worry about it, you don't sound stupid. We all had to start somewhere and I've spent hours on projects like this in the past. Let me check on the nvidia-settings issue. I've found ubuntuguide.org helpfull for setting up nvidia cards...

...give me a minute.

Opt-Crysys
March 8th, 2009, 06:55 AM
OK, thank you very much, yea I actually have been going at this for a while now haha.

shinobitux
March 8th, 2009, 06:56 AM
Ok, there's two ways you can do this.

First:


sudo apt-get install nvidia-settings

and then try the


sudo nvidia-settings

trick I showed you.

Second:

go here: http://ubuntuguide.org/wiki/Ubuntu:Intrepid#Reconfigure_xserver-xorg

and copy there xorg.conf file into yours and restart your X server.

I highly recommend installing nvidia-settings regardless as sometimes it makes configuring your settings a bit easier.

...how 'bout now?

Opt-Crysys
March 8th, 2009, 07:08 AM
OK the first way that I tried it worked, but when I open up the nvidia settings I don't see what you are telling me, its just a screen with checkboxes and it does have a left side but its not a menu, also when I open it up it tells me

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

Now for the second way, I tried to copy paste but it says I don't have permission to save this make sure its in the right location.

shinobitux
March 8th, 2009, 07:17 AM
Hmm...

Could be the graphical way isn't working because I'm using older video cards than you are and it doesn't work the same way.

As for the reason the second way isn't working, it sounds like you're trying to edit it as your regular user and not your root user. The xorg.conf file is owned by the "root" user and can normally only be changed by that user.

Do you know any command line text editors? I just


sudo vim /etc/X11/xorg.conf

but you don't want to do that if you aren't familiar with vi.

"Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

You could definitely do this. nvidia-xconfig should do exactly what I was trying to do with nvidia-settings automatically. Just make sure you


sudo nvidia-xconfig

The "sudo" means "Super User DO" ie - run the command as if you were the "root" user.

If you want to copy text from the webpage try


gksu gedit /etc/X11/xorg.conf &

This should attempt to open the config file in gnomes default text editor with root user privelages. This is a graphical editor and should be a lot simpler than learning a command-line editor on the fly :)

shinobitux
March 8th, 2009, 07:25 AM
Lol

This all reminds me of when I did tech support for a living.

I've only got another hour or two but I want to see you up and playing.

Opt-Crysys
March 8th, 2009, 07:28 AM
OK, what stumps me is that if I copy the other xorg.conf into mine, wouldn't it not work, since he is using something different? Also It worked as in I copied it, but it still says the same thing. I am not sure I even got the driver I don't know maybe I got lost in translation?

Opt-Crysys
March 8th, 2009, 07:33 AM
Also whenever I go to System>Administration>Hardware Drivers I do not see a thing, is this normal, because I have looked elsewhere and it told me to just install the envy thing, and then get the repositories from there....

shinobitux
March 8th, 2009, 07:41 AM
You know, I've done this so many times maybe I'm skipping a couple steps.

First thing, what version of Ubuntu are you running? 8.04? 8.10?

According to ubuntuguide.org (which I've used for my nvidia cards) ...

http://ubuntuguide.org/wiki/Ubuntu:Intrepid#Install_Latest_Nvidia.2FATI_driver s

...you need to go and download the latest drivers manually. The Envy drivers probably don't have hardware acceleration and wont work with games like WoW.

Try the ubuntuguide link: http://www.nvidia.com/Download/index.aspx?lang=en-us to install the drivers

Installation of ATI and nVidia Graphics drivers

NVidia Driver

If you have problems with Nvidia drivers after upgrading, check This guide for common solutions to problems with nvidia.

* Please make a backup of xorg.conf before following this method.

Install the nvidia-settings package:


sudo apt-get install nvidia-settings

Download Nvidia driver at http://www.nvidia.com/Download/index.aspx?lang=en-us and place it at your home directory. After downloading, close all open windows and press <CTRL> <ALT> F1. Log in and enter password and then just connect to the internet. Press <ALT> F2, kill gdm or kdm season by entering sudo killall <your desktop manager>, example:


sudo killall gdm

Install the nvidia driver. Make sure you are in the nvidia driver directory. If you downloaded it and placed it on the Desktop, make sure to change directories first.


cd Desktop

To install it, enter /NVIDIA-Linux-x**-***.**-pkg1.run. For example, if you downloaded Nvidia version 173.80:


sudo ./NVIDIA-Linux-x86-173.80-pkg1.run

choose yes to any verbose response. After you are finished installing the driver, reboot your computer.


sudo reboot

shinobitux
March 8th, 2009, 07:44 AM
This should be the driver for Nvidia Geforce 9500 GT

http://us.download.nvidia.com/XFree86/Linux-x86/180.29/NVIDIA-Linux-x86-180.29-pkg1.run

Opt-Crysys
March 8th, 2009, 07:26 PM
I am currently running 8.04, and I have downloaded the driver, the one in your last post, but excuse me for sounding "dumb" but your directions are confusing me a bit, are you going through step by step, also are the directions that are in intrepid the same as 8.04?

Opt-Crysys
March 8th, 2009, 07:38 PM
Also since we have done everything, Whenever I boot up to Ubuntu, it says it has to run in low graphical settings. I think that we messed something up, because it was better before.

shinobitux
March 9th, 2009, 01:15 AM
Ok, yeah I was following the instructions for 8.10 not 8.04. They're a bit different. We haven't done anything irreversible so it's not that big of a deal.

If you want to get that annoying "low graphics mode" message to go away for now, here's your original xorg.conf file:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

Could you check a couple things for me?


lsmod | grep nvidia

Does that give you anything?

And go to System > Administration > Software Sources and tell me if everything under the "Ubuntu Software" tab is checked or not.

shinobitux
March 9th, 2009, 02:05 AM
Ok, from what I understand the issue is that you can't install the non-free nvidia drivers for the 9500GT because they don't show up in System > Administration > Hardware Drivers. I thought you had 8.10 so I wasn't surprised as the instructions on ubuntuguide.org have you download the drivers manually.

This person:
http://www.linuxquestions.org/questions/ubuntu-63/how-to-install-a-nvidia-geforce-9500gt-673780/
had the exact same problem and was told to install the envyng-gtk package which automatically downloads, installs and upgrades the latest non-free nvidia driver for your card.

The envyng developer http://albertomilone.com/envyngfaq.html
has that faq on how to install the envyng package.

You'll need to enable the universe and multiverse repositories in System > Administration > Software Sources if you haven't already.

Then

sudo apt-get install envyng-gtk

Once everythings downloaded and installed, restart your computer and try:

glxinfo | grep rendering
to see if direct rendering is working.

Opt-Crysys
March 9th, 2009, 02:44 AM
Hey I have some good news, my brother went in through my comp and fixed it for me, now WoW works like a charm. Thank you for all your help, and listen I am sorry to put you through all this trouble. If I have another problem could I come to you, seeing as my brother is really busy with his job?

shinobitux
March 9th, 2009, 10:01 AM
Sure, I don't mind. I'm trying to do more of this.

If you get a chance please ask him what the issue was 'cause I'm curious.

Have fun playin' :)

jkim588
March 10th, 2009, 03:30 AM
Hey, I installed the NVIDIA package successfully but when I restart the whole screen is black. I'm not sure how to get it working. I would really appreciate someones help. Thanks!


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Thu Feb 5 00:18:17 PST 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

shinobitux
March 10th, 2009, 07:24 AM
Hey, jkim588.

Which nvidia package did you install?

Do you also have the 9500 GT? What version of Ubuntu are you running?

I don't see anything wrong with your xorg.conf file at first glance but could you try a couple things for me?

Try

lsmod | grep nvidia
this should tell us if the nvidia module is loading on startup.

If you don't know what nvidia card it is try

sudo lspci -v > ~/Desktop/pci_devices.txt
and copy the contents of the pci_devices.txt file on your desktop here so I can look at it. It usually shows up as "VGA compatible controller" or something like that.

I'm not around as much during the workweek but I'll try to help as much as I can.

okst666
March 14th, 2009, 01:03 PM
ARGH..this is driving me nuts...

I have the exact same Problem...and tried everything I know.

I have 8.04 and a 9500GT

I totally reinstalled ubuntu
I tried envy -> no luck
I tried the 180.annoying.version.numbers drivers from nvidia -> no luck
I tried with nvidia-settings...without nvidia settings

dmesg always tells me there is a version conflict between api and kernel (something with 71.28.04 or so) driver.

I also tried to rmmod nvidia and started gdm...THEN the new drivers come up (there is kind of nvidia splashscreen when they fire up) and everything works just fine....till I reboot...then its all ****ed up again :cry:


WHERE is that old kerneldriver and how do I delete it?
WHY do I have to worry about kernelstuff at all?
WHEN will there finally be a setup.exe like solution for all that problems (the forums are full of crap like this)
WHAT do I have to do now, to get this card finally run with the latest drivers.

Please give me advise...we can reinstall ubuntu 8.04 from the beginning if needed.
Please do not link to any tutorials..I tried them all...they do NOT work!

thank you in advance.

ollie:(

okst666
March 14th, 2009, 02:09 PM
I did it...I did it..I can't beliebe it was that easy!!

look at http://www.nvnews.net/vbulletin/showthread.php?t=72490

and search for "Debian GNU/Linux or [K]Ubuntu with Xorg 7.x"

all had to do was that disabled_modules entry and now it works just fine:o


thanks anyway...it is just good to cry out loud sometimes :D

shinobitux
March 15th, 2009, 12:42 AM
Hey, okst666.

I've seen the steps in your link before and I'm sorry it took you so long to find it.

Where you able to find out exactly what was wrong? i.e. - Was linux-restricted-modules not installed? Did you have nvidia-glx installed?

I'm not an expert, but I'll try to answer some of your earlier questions.


WHY do I have to worry about kernelstuff at all?

When you start up linux it loads many "modules" that expand upon the functionality of the kernel. These modules provide hardware-level functionality (among other things) not compiled into the kernel. This allows linux to evolve to meet your needs as a user without recompiling the kernel. I think the nvidia module provides an hardware-level interface for Xorg so you can achieve greater video performance.

The whole purpose of an operating system is to add layers of abstraction from the hardware. You don't want your average user to be concerned with the low-level functions required for routine work. In order to improve performance you limit the amount of layers between the application and the hardware. Linux does this by means of kernel "modules" which are "tacked-on" to the compiled kernel.

My knowledge of this subject is limited and if I've made any mistake everyone feel free to educate me as to where I'm mistaken.


WHEN will there finally be a setup.exe like solution for all that problems?

I don't see a setup.exe OR setup.sh solution to all hardware combinations in the near future. In the few years I've been working with Linux I've seen the unfortunate tendency of developers to orphan backwards compatibility or obsolete functionality in the pursuit of better and more efficient methods. It's more complicated than that but I'll try to make one point.

From your nvnews.net post you can see mentioned the removal of the rgbpath functionality from Xorg:


Unfortunately, xorg-server 1.4.99.901 removed support for the RgbPath option, so X configuration files generated by nvidia-xconfig will not work. For these servers, I recommended that you delete everything but the "Device" section and leave the rest up to the X server's autoconfiguration[...]

The Linux project, as a whole, is a group of communities coming together to build and improve upon tools. However, communication between these communities can be sporadic or even non-existent. If one community makes a change in functionality or removes certain backwards compatibilities it can have a far and wide-ranging effect on many other projects.

For a single individual, like me, it's difficult to keep up with the changing flows and moods of the Linux development community. So, I tend to do my research on the fly and learn what I need when I need it. Someone like me (odds are it would be someone more knowledgeable than me) could provide a setup script, but as I've a limited amount of hardware to work with and test on I couldn't possibly create a script that would work for everybody. Configuration is different not only between versions of Ubuntu, but different versions of Xorg, different nvidia cards, and don't forget the computer hardware itself.

Things are improving quite a bit. The introduction of non-free binary drivers for nvidia and ati graphics card is really impressive. Now users aren't required to compile their video drivers and test different configuration options. If Linux developers had only to work on a limited selection of hardware you could definitely write a setup script, but they try to develop for the widest selection they can.

...

I know this can be frustrating sometimes, but canonical really is making great strides. This can be evidenced by the rapid growth of linux usage in home and office users. And think of this: for many end-users a clean Ubuntu installation offers them everything they'll need without installing drivers or additional software.

I look forward to the point where I've taught myself enough to help people like you find easily-implemented solutions to issues like this. But I'm not quite there yet :)

I'm very glad you got your nvidia drivers to work and I hope you have fun with the rest of your linux experience.

geraldgrogan
March 27th, 2010, 08:28 AM
Sorry to post to this old thread, but after searching all day for an answer the very same issue with this same video card, I was guessing that others might be interested in what worked for me.

After a kernal update my video stopped working. I had my PC connected to my flat screen monitor via a vga cable, which apperently was causing the problem, The log file mentioned that it could not determine the monitor model number. Appearently, this card needs to be connected via a dvi cable in order to operate properly (or at all).

Once I connected this video card to the monitor using a dvi cable, and then rebooted, the high resolution started working perfectly. Just in case I am not the last person on Earth to upgrade to DVI, I urge everyone to upgrade to DVI cables ASAP.

I hope this helps.