PDA

View Full Version : [mythbuntu] 802.11n only runs at 54 Mb/s



madman100
March 6th, 2009, 02:26 PM
Hi all can any one help me i have a EDimax 802.11n wireless card and have the rt2860 drivers install but the network speed is only 54 Mb/s can not get it to change to 300 Mb/s can any one tell me if this is supported in ubuntu 8.10

Thanks
madman100

Reiger
March 6th, 2009, 03:02 PM
Short answer: 300Mb/s is a theoretical figure which in practice is not attainable. You are seeing a bandwidth figure considered exceptional/above-typical for wireless A & G networks already...

Long answer, bandwidth depends on
(a) Bandwidth of established channel (equal to the lowest bandwidth available on either end of the connection)
(b) Interference (other radio's using the channel, and in the 2.4Ghz spectrum there are a lot of those for instance wireless mice, other b/g devices etc.) & 'obstacles': armoured concrete for instance is a real signal killer.
(c) Number of clients of the modem/router (which kind of overlaps with a, but bandwidth now needs to be shared).

At any rate: a true 300Mb/s bandwidth between 'you & Internet' will, even if your wireless link 'has it', remain dependent on the following:
(a) Number of devices connected to the 'bottleneck' simultaneously
(b) Bandwidth of the connection between the 'bottleneck' and the Internet (do you have a Gigabit+ connection, actually).

Now consider that in order for your device to get its full 300Mb/s potential you must have at least a total bandwidth B of N * 300 Mb/s with N the number of devices sharing this bandwidth simultaneously. Bottom line: don't worry yet. Use the wireless N device for what is actually good for: its longer range.

madman100
March 6th, 2009, 07:07 PM
Hi Reiger thanks for the quick reply the router what i have is a EDimax 802.11n Gigabit router and my wireless setting are mode AP band 2.4 GHz B+G+N
Fragment Threshold:
(256-2346)
RTS Threshold:
(0-2347)
Beacon Interval:
(20- 1024 ms)
DTIM Period:
(1-10)
Data Rate:= AUTO

N Data Rate:= AUTO

Transmit Rate:

Channel Width=20 MHZ
Auto 20/40 MHZ 20 MHZ
Preamble Type:= SHORT
Short Preamble Long Preamble
Broadcast Essid:
Enable Disable
WMM:
Enable Disable
CTS Protect:
Auto Always None
Tx Power: 100%

Thanks
madman100