PDA

View Full Version : [kubuntu] KNetworkManager does not auto-start connection after Resume



Firestem4
March 4th, 2009, 07:37 AM
Whenever I put my laptop into standby and I resume (8.10)KNetworkManager does not automatically resume its last internet connection (Similar to its auto-connect feature). Is this a bug/by design? Is there some workaround I can do to fix this?

Any help would be greatly appreciated. Thanks in advance!

yther
March 4th, 2009, 07:57 AM
I got the same difficulty here... for the moment I'm working around it by simply not using suspend, or doing "sudo service NetworkManager restart" when I need to. I should find out if there's a way to trigger scripts when resuming. [searches] Hm, there may be, but it's nothing I can solve in 5 minutes, so leaving it for later. :(

There's at least one bug about this behavior (https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/264683), as well. You may find some useful info, or links to it, in there.

Firestem4
March 4th, 2009, 07:59 AM
I was considering potentially creating a script..(or well copying it from someone who has...since i know very little BASH Me<----am fairly new to linux).

I wouldn't know where to begin when it comes to executing a script on resume...Ive only made one script so far which kills my Firefox process and starts Firefox (works flawlessly hehe. Firefox when exited didn't dump the process, so I couldn't open it up againn till I did)

If you have any luck with this in the future, Could you please notify me?

Firestem4
March 4th, 2009, 09:10 AM
HAH! Would you look at that...

I just installed todays updates and one of those included a Knetworkmanager update. Guess what it fixed?

Ironic lol.