PDA

View Full Version : 9.04 Jaunty, no Desktop Effect Intel X4500



starfly
February 23rd, 2009, 07:05 PM
Hello,

Ive read a lot about a very fast Jaunty in combination with my Video card, Intel G4 X4500. But after installing Jaunty my Desktop effects cant be enabled and the Framerates (for example youtube) are very slow.

Any one any suggestions how to speed it up ?! Or what i`ve done wrong so that it is slower than in intrepid...or even non working...

stchman
February 23rd, 2009, 08:21 PM
Hello,

Ive read a lot about a very fast Jaunty in combination with my Video card, Intel G4 X4500. But after installing Jaunty my Desktop effects cant be enabled and the Framerates (for example youtube) are very slow.

Any one any suggestions how to speed it up ?! Or what i`ve done wrong so that it is slower than in intrepid...or even non working...

Remeber, Jaunty is experimental Alpha software. There are going to be a lot of bugs until the OS becomes a stable release.

Joeb454
February 23rd, 2009, 08:22 PM
Moved to Jaunty Testing :)

Stetzen
February 24th, 2009, 12:16 AM
Try to run compiz --replace from the terminal and post the output here, I think, it will help us to solve a problem. /var/log/Xorg.0.log will also be very useful. It looks like your 3d acceleration is disabled for some reason.

starfly
February 25th, 2009, 02:44 AM
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz: 426: /usr/local/bin/compiz: not found


I Know that its a beta only, but instead of that point it works absolutly great for me :-)

But my new Graphic board has absolutly no acceleration, or no memory is given to it..i dont know, thanks for ur Help !

Its so slow that the smalest videos in the web are to slow to watch, the framerate...

My Xorg.conf is Ubuntulike and hasnt been modified by me...

starfly
February 25th, 2009, 03:02 AM
Attachment of the Xorg Log in doc Format ( Realy Long data stream ) ;)

klange
February 25th, 2009, 04:42 AM
Try to run compiz --replace from the terminal and post the output here, I think, it will help us to solve a problem. /var/log/Xorg.0.log will also be very useful. It looks like your 3d acceleration is disabled for some reason.
I'd really like to see this sort of thing stop here. Ubuntu has shipped with compiz-manager replacing `compiz` since the beginning, and it automatically executes compiz with the `--replace` option. (The actual compiz binary executable is /usr/bin/compiz.real, compiz-manager is /usr/bin/compiz).

So, in conclusion, in Ubuntu, compiz --replace is redundant.

Anyway, on to the point: You have some old "config" files (not really config files, more like trash from a custom install or another repo) from some form of previous Compiz installation. Ask on #compiz-fusion@irc.freenode.net, as I don't have the exact file paths with me at the moment. Basically, one of these files is redirecting the script in /usr/bin/compiz from /usr/bin/compiz.real to /usr/local/bin/compiz (which happens to not exist).

You lack acceleration due to some major issues in EXA on the current drivers. A noted workaround is to disable vertical sync blank (search for it), but you can also help test UXA (again, search for it), which is unstable but faster and has a number of other advantages (which you'd notice once you get Compiz back up).

starfly
February 25th, 2009, 10:30 AM
Okay translating it to simple ;-)

-Try setting acceleration to uxa

-Compiz settingsfiles are out of date... ?! Clean installation with formated disks, all repros original Jaunty..

starfly
February 25th, 2009, 11:09 AM
cant find anything to :disable vertical sync blank

Set my Xorg.conf so :

Section "Device"
Identifier "intel"
Driver "intel"
Option "AccelMethod" "UXA"
Option "Tiling" "No"

Cant imagine that this is the way to activate Uxa...

starfly
February 25th, 2009, 12:10 PM
Nothing... Heres the output of compiz-manager

Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz-manager: 426: /usr/local/bin/compiz: not found

klange
February 25th, 2009, 12:16 PM
You still have an extraneous XDG config file pointing to the wrong Compiz binary. Someone else on #compiz-fusion@irce.freenode.net should be able to point you to it.

starfly
February 25th, 2009, 12:49 PM
YSEESESESEESS!
GOT IT !

change gedit /usr/bin/compiz-manager

change lines 30 and 31 to:
COMPIZ_BIN_PATH="/usr/bin/" # For window decorators and compiz
PLUGIN_PATH="/usr/lib/compiz/"

and then a few lines down, change to:
COMPIZ_NAME="compiz.real" # Final name for compiz (compiz.real)

--------------------------

In the xorg.conf section the Device must be :

Section "Device"
Identifier "intel"
Driver "intel"
Option "AccelMethod" "UXA"



Thanks a lot and hope someone will need this someday ;-)

starfly
February 25th, 2009, 02:05 PM
But ive got to mention the Power of the acceleration is so SLOW that the Flashplayer doesnt play any Webvideo very good...bad bad framerates

mortski
February 25th, 2009, 06:21 PM
Your fix will be overwritten on the next upgrade of compiz-wrapper. The proper fix is outlined in LP: #290085.

Jancis
February 25th, 2009, 06:47 PM
It did help me, thanks a lot, because I wanted to try out jaunty and it returned me frozen mouse (touchpad) and no composite rendering. Thanks to guys like you I got back on track really soon ;)

thanks!

Triggerhapp
February 25th, 2009, 10:07 PM
Just updated my intel machine and seem to have gotten this too... Just to mention

starfly
February 25th, 2009, 11:15 PM
and now lets find a solution to watch videos with fullscreen without break lines,,,

Triggerhapp
February 26th, 2009, 12:44 AM
That ones fine for me.

starfly
February 26th, 2009, 01:46 AM
What Kind of acceleration do u use ?

My videos are unwatchable at fullscreen.

bribera
February 26th, 2009, 06:03 PM
I'm seeing the same initial problem, but when I edit /usr/bin/compiz-manager and attempt to start compiz, I get an infinite loop of this spew:



brendan@pequod:~/Desktop$ compiz-manager
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.

... and so on, ad infinitum

bribera
February 26th, 2009, 06:07 PM
Oh blah, ignore me -- I missed this line.

YSEESESESEESS!
and then a few lines down, change to:
COMPIZ_NAME="compiz.real" # Final name for compiz (compiz.real)

starfly
February 27th, 2009, 05:17 PM
exact the same thing happened to me too ;-)
I`ve forgotten this line, and the console wasnt able to stop returning the same messages ;-)