PDA

View Full Version : [ubuntu] Ubuntu 8.10 freezes after install



ragnathor
February 22nd, 2009, 09:23 PM
Hello,

I installed Ubuntu on my old Dell desktop (completely erasing my Windows partition). The installation process went fine, and on reboot the login screen comes up for Ubuntu - I login but then it freezes - the screen is the yellowish one and I can move the mouse around, but nothing shows up. The keyboard becomes unresponsive. I tried the other boot options - failsafe with GNOME and failsafe with terminal. Failsafe with GNOME freezes like before, but the terminal comes up fine (no clue what to do though, never used linux/ubuntu).

Here are my system specs of an old dell optiplex 2400:

Memory:
512MB DDR RAM PC2700

processor:
SL6VT Intel 2.20GHz Celeron CPU for Dell Inspiron, Dimension, and OptiPlex Systems, 2.20GHZ/128/400, Socket 478, FC-PGA2, Northwood-128, Dell D1846.

Harddrive:
Hard Drive, 40G, I, Half Height 7.2K, 40G/P, SEAGATE SNOWMASS

The ethernet port and graphics are integrated onto the motherboard.

I apologize if this question has already been asked - I searched as best I could through the threads and couldn't find one with this specific problem. Thanks for any help.

cwsnyder
February 22nd, 2009, 09:31 PM
It sounds like you are having a problem with X Server.

Can you boot with the Live CD (prior to install version)?

To completely fix your X Server, you will probably have to make a custom xorg.conf file, similar to the one I have, but modified with the information to match your monitor/graphics card combo.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "NVIDIA GeForce 6 Series"
Busid "PCI:1:0:0"
Driver "nv"
Screen 0
Vendorname "NVIDIA"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1280x1024"
Horizsync 31.5-64.0
Vertrefresh 56.0 - 65.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1280 1024
Modes "1280x1024@60" "1024x768@60" "1280x960@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce 6 Series"
Busid "PCI:1:0:0"
Driver "nv"
Screen 1
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

Virtualboxbuntu
February 22nd, 2009, 10:02 PM
Yes, it sounds like a problem with X server. My other computer had this problem as well.

Start your computer, but don't login. Push CTRL+ALT+F2. Type your username, then your password, to login. Type
sudo dpkg-reconfigure -phigh xserver-xorg, enter your password (it will not appear) and then wait for it to finish. Then push CTRL+ALT+Backspace.

ragnathor
February 23rd, 2009, 07:12 AM
Thanks for the replies. I tried the live CD but the same problem occured as you probably expected. I also entered the code above and got the following message:

xserver-xorg postinst warning: overwriting possibly-customised configuration file; backup in /etc/X11/xorg.conf.20...

However, on logging in again the same problem appears (freezes). Should my next step be to modify the xorg.conf file? I found out how to open it from this thread:

http://ubuntuforums.org/showthread.php?t=307716

and it shows the following (without the comments):



Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection



So basically there is nothing there. I haven't used linux before or know what X server is, so I've really got no clue how I'd configure this for my computer. Are there other options I might try? Thanks again for the help.

Adam

cwsnyder
March 5th, 2009, 01:09 PM
I would try replacing the sections Monitor and Screen with the following:
Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Horizsync 31.5-64.0
Vertrefresh 56.0 - 65.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Virtual 1024 768
Modes "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection
and see if you can at least get a display. This would limit you to 1024x768 screen resolution, but if your display is being detected improperly (which this sounds like) and your display is capable of 1024x768, this should fix it.

The Intel graphics built-in to your motherboard is completely supported by Linux, but if the display is not detected properly, the display could be sent into modes which are blank screen.

I had this problem when I first installed Ubuntu 7.10, Ubuntu 8.04, and Ubuntu 8.10. To solve the first time, I had to create a custom xorg.conf defining my display, after I connected up a CRT multi-sync monitor to discover what the problem was. I have subsequently updated it to include particulars for my graphics card (which uses the nVidia drivers, not built-in to Ubuntu). Since Ubuntu 7.10 Gutsy Gibbon, I have backed up my xorg.conf file and copied it across upgrades.

I finally reported a bug report to see if I could get a better fix in November.

abn91c
March 5th, 2009, 01:33 PM
If your Dell has an i845/9xx integrated video, you will need to disable desktop effects or remove compiz to log-in
sudo apt-get remove compiz
sudo apt-get remove compiz-core

ragnathor
March 15th, 2009, 10:34 PM
If your Dell has an i845/9xx integrated video, you will need to disable desktop effects or remove compiz to log-in
sudo apt-get remove compiz
sudo apt-get remove compiz-core


This has fixed the problem - thank you!

WhiteShepherd
March 18th, 2009, 05:36 PM
I found another workaround. I could not install 8.10 for the life of me even with the alternate CD.

So I installed Ubuntu 8.04 Live CD (which worked just fine). Then went to software sources and changed "Long Term Release to Normal Release". I then went to update manager and upgraded to 8.10 just fine.