PDA

View Full Version : [ubuntu] If I apply this code - can I play DVD's?



listerdl
February 21st, 2009, 08:12 PM
Hi All

If I enter this code into terminal:


sudo apt-get install ubuntu-restricted-extras

Will/should I be able to play DVD's?

sandyd
February 21st, 2009, 08:16 PM
no



sudo apt-get install libdvdcss



add that in and ill play dvds

binbash
February 21st, 2009, 08:17 PM
you need libdvdcss2 (add medibuntu to your repos then sudo apt-get update && sudo apt-get install libdvdcss2)

theozzlives
February 21st, 2009, 08:19 PM
Not encrypted ones after the restricted extras, you want to enter:

sudo apt-get install libdvdread3 libxine1-ffmpeg totem-xine build-essential debhelper fakeroot
then:

sudo /usr/share/doc/libdvdread3/install-css.sh
Select Movie Player (xine) when you play them.

theozzlives
February 21st, 2009, 08:21 PM
you need libdvdcss2 (add medibuntu to your repos then sudo apt-get update && sudo apt-get install libdvdcss2)

libdvdread3 has libdvdcss2 with it.

listerdl
March 9th, 2009, 10:16 PM
I did all the above and I can play DVD's - so thanks!

But....something very strange happened...half way through watching a movie it asked me to confirm that I have installed libdvdcss?

Did I not install the software correctly?

gandaran
March 9th, 2009, 10:22 PM
I did all the above and I can play DVD's - so thanks!

But....something very strange happened...half way through watching a movie it asked me to confirm that I have installed libdvdcss?

Did I not install the software correctly?
open synaptic and check if it's installed!
if you did run this code

sudo /usr/share/doc/libdvdread3/install-css.sh
then you have an older version of libdvdcss installed, install the one from the medibuntu repository.

theozzlives
March 9th, 2009, 10:28 PM
open synaptic and check if it's installed!
if you did run this code

sudo /usr/share/doc/libdvdread3/install-css.sh
then you have an older version of libdvdcss installed, install the one from the medibuntu repository.

The code I gave works on my 8.10 machines. I watch Girls Gone Wild all the time hehe.

gandaran
March 9th, 2009, 10:32 PM
The code I gave works on my 8.10 machines. I watch Girls Gone Wild all the time hehe.
yes it works, but libdvdcss2 from the medibuntu is more recent/update

mc4man
March 10th, 2009, 02:35 AM
the "/usr/share/doc/libdvdread3/install-css.sh" in 8.10 and probably also 9.04 has been rewritten to retrieve from medibuntu and is current.