PDA

View Full Version : [ubuntu] sound volume too low



paker
February 21st, 2009, 05:36 PM
My new build is working well except for sound. It is extremely low, not cracking or anything.

1) I tried different players. Same result.
2) Set volume at max from Speaker icon > open volume control. no change.
3) Changed Auto to ALSA in System > Preferences > Sound. No change.
4) switched to different headphones. no change.

My system:

Intel Q9330
Gigabyte GA-EP45-UD3R
onboard sound
ubuntu 8.10 32 bit

Thanks.

mc4100
February 21st, 2009, 05:38 PM
Have you tried raising the PCM?

alsamixer -Dhw

paker
February 21st, 2009, 07:29 PM
PCM is already at max from:

Speaker icon > PCM > Raise bar.

paker
February 21st, 2009, 11:34 PM
Problem solved.

Problem: Intel ICH10-based HD Audio (my onboard audio) is not supported by the ALSA in the repository. Volume is way too low.

Solution: Upgrade to the current version of ALSA.

How to: http://ubuntuforums.org/showthread.php?t=1046137&highlight=alsa+upgrade. Get the upgrade script "AlsaUpgrade-1.0.x-rev-1.16.tar" from the thread and install.

tar xvf AlsaUpgrade-1.0.x-rev-1.16.tar
sudo ./AlsaUpgrade-1.0.x-rev-1.16.sh -di

Note: -di is for downloading and installing. Reboot.

auntiestacey
February 22nd, 2009, 01:51 AM
Thanks paker for the post. I've had the same problem since installing this week. Will try this when I get home from work.

paker
February 22nd, 2009, 04:30 AM
Thanks paker for the post. I've had the same problem since installing this week. Will try this when I get home from work.In case you are as unskilled as me,

tar xvf AlsaUpgrade-1.0.x-rev-1.16.tar

This converts "xxx.tar" to "xxx.sh" and stores it in the home folder.

sudo ./AlsaUpgrade-1.0.x-rev-1.16.sh -di

This downloads and installs newer ALSA per "xxx.sh."

auntiestacey
February 22nd, 2009, 03:59 PM
Unfortunately sound didn't change with the update. I have Realtek ALC888 integrated sound on my nvidia 8200 mobo.

I found this post on Linux forums and will try this next. Posting here for others in the same boat with me.

http://www.linuxforums.org/forum/ubuntu-help/100864-realtek-hd-audio-alc888.html

-as