PDA

View Full Version : [ubuntu] Screen display bug - equivalent to a crash



jtsc
February 21st, 2009, 09:50 AM
Hello,

I've had a strange new bug happen twice today. I have a lenovo z61t laptop with the most recent stable version of Intrepid Ibex (I think I installed it a month ago, now).

The nature of the bug is that suddenly the screen will go funny colors. It will start alternating between all-black and and black with columns of blue periods, some of them bolded. After spazzing out like that for a while, the screen will go all black; the cursor will be visible as the "X", except it will disappear on the lower 2/3s of the screen, and there is one pixel on the far right of the screen (right at the boundary between where the cursor is visible and disappears) which, when the cursor rest there, turns the whole screen white instead of black.

During this bizarre screen malfunctioning, there are no changes in response to clicking or pressing buttons or anything like that (although caps lock seems to work, or at least it affects the signal light), but I believe Ubuntu is still running happily, because when I tap the power button Ubuntu will do a "soft" shutdown - and in fact, you can actually sort of see the Ubuntu logo and the little progress bar come on the screen, but in a very distorted fashion (like, each line of pixels was distorted in to perhaps 1/3 the original width, so there were about five lines of orange status bar per line, and then five more would start on the next line at a slight offset). So I assume it's not a kernel panic.

I don't know what caused it. The second time it happened just after I clicked to open a pdf (which I have successfully opened before, and which is open right now). The first time I also had pdfs open, but can't recall what might have caused it.

Is this a known problem? How can I fix it? Is there anyway to start the desktop environment back up while the screen isn't working?

ashwinhgtx
February 21st, 2009, 10:59 AM
Something similar happens to me also if my uptime goes for more than 3 or 4 days. I'm on a Thinkpad R60 running Kubuntu Intrepid.

jtsc
February 22nd, 2009, 08:44 AM
Please help!