PDA

View Full Version : [ubuntu] can't partition HDD's



snowman12
February 13th, 2009, 10:31 PM
lappy just came back from repairs and the first thing I did was try to install ubuntu via WUBI.
The windows side works fine, but but once it reboots into ubuntu I get stuck at step 4 (prepare partitions). It doesnt show any hdd's in the list and all the buttons except for "forward" "back" and "quit" are greyed out.
Am I going mad?!?! :confused:

HermanAB
February 13th, 2009, 11:51 PM
Run chkdsk in Windows and then try again.

Cheers,

Herman

TohBee
February 14th, 2009, 12:25 AM
maybe this helps:

http://forum.ubuntuusers.de/topic/dell-inspiron-530n-ubuntu-pc-:-wirklich-linux/

snowman12
February 14th, 2009, 02:17 AM
Herman,

ran "chkdsk /F"
nothing happened.

Tohbee,

umm, what part exactly? it makes for a difficult read even with google translate ;)

caljohnsmith
February 14th, 2009, 02:58 AM
Hi snowman12, how about posting a screen shot of what you are seeing, and also please post:

sudo fdisk -lu
And if you have more than one HDD, let us know which one you want to install Ubuntu to.

snowman12
February 14th, 2009, 05:51 AM
caljohnsmith,

attached are screenshots of what i see @ startup and the terminal output

hope this helps

caljohnsmith
February 14th, 2009, 07:05 AM
So just to clarify, are you trying to install Ubuntu via Wubi again inside Windows? And are you doing it from the Live CD?

snowman12
February 14th, 2009, 09:00 AM
I started out from WUBI, got to the part where you shut down and reboot into ubuntu to finish the intstallaton, no problems. But when it asks to partition the HDD (There is only one BTW), it doesnt show up. I click on quit and it starts a live session, with or without the liveCD.
I only ran WUBI once (should I try reinstalling?) and if I run the install app/script on the desktop in a live session i get the same problem.

Funny though, the installer detects my flashdrive when I boot with it plugged in.

If you need any more info, just ask
thanks!

snowman12
February 15th, 2009, 08:59 AM
I uninstalled WUBI, then started a proper live session and ran the installer from there and. . . .


SUCCESS!!!!!!


it detected my HDD!!!


new problem though,

It only shows two partitions and I need three. (windows, ubuntu, and a windows recovery partition).

Isn't there supposed to be a slider where you set how much breathing room windows gets?

anyway this is what I'm seeing

caljohnsmith
February 15th, 2009, 02:01 PM
Glad to hear the installer at least sees your HDD now. I would recommend using gparted (Ubuntu's partition editor under System > Admin > Partition Editor) to first shrink whichever partition you want to make room for Ubuntu, and then you can manually set up your Ubuntu partitions with gparted. Or you could choose the "manual" partition option in the installer, and I think you can do basically the same thing. Here are a few guides that you might find helpful:

http://mywebsite.bigpond.net.au/dfelderh/linuxmaniac/p23.html (manual partition setup)
http://mywebsite.bigpond.net.au/dfelderh/linuxmaniac/p22.html (using gparted first)

Good luck and let me know how it goes.

snowman12
February 16th, 2009, 03:47 AM
:P:P:P:P:P:P:P:P
it's working fine now

thank you all soooo much!!