PDA

View Full Version : [kubuntu] intrepid - open nvidia drivers and resolution problems



tehk
February 4th, 2009, 05:25 PM
I've had 8.10 running for a few months and have been using the nvidia v177 drivers for quite a while. However lately, I've gotten into doing 2d animation work using javascript and html and have found that the nvidia drivers are rather poor in this area. So, I switched back to using the open source nvidia drivers and found that they greatly solved the 2d animation problems and were much faster. The 3d animations were slower and lacked antialiasing, but I don't miss that stuff at all.

The Problem:

When using the open source drivers, my display resolution is limited to 1280x1024, whereas with the proprietary nvidia drivers I was able to achieve 1920x1200. I hacked around for a few hours yesterday messing with my xorg.conf file in attempt to configure the open drivers to allow be the higher screen resolution, but alas to no avail.

Just as an example of the 2d performance issues I've been encountering, try this page: http://blog.miernicki.com/?p=82 which uses an animated <canvas> element. In the open source drivers, nice and smooth and using the closed drivers, the animation is jagged and stops periodically.

Back to the issue:

I thought it may help to put up my xorg.conf files up in advance of others asking, so here they are:

Open source drivers version:


Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

And next the nvidia closed basic xorg.conf:


Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

And finally the xorg.conf as configured using the nvidia-settings applet:


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Mon Nov 3 08:46:04 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL2407WFPHC"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6800 XT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1920x1200_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


I thought the solution honestly would be to snag some of the info from the closed nvidia-settings version and import the monitor, device, and screen sections to the open driver version. But nothing I tried would allow me to go any higher than 1280x1024.

Argggg. Please help!

t

tehk
February 4th, 2009, 11:02 PM
:popcorn:

ridetheteapot
February 4th, 2009, 11:22 PM
hey your open source driver xorg is showing you using vesa. have you tried the open source nvidia driver? change vesa to nv (make sure that xserver-xorg-video-nv is installed first)
maybe make the screen section look more like this

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "some other res" "some other res"
EndSubSection
EndSection

tehk
February 5th, 2009, 03:42 AM
wo0p! nv driver kick ***!

much better speed but the occassion artifact on the screen.... missing pixels here and there....

there's probably a setting to control this...

here's my newest xorg.conf:


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Mon Nov 3 08:46:04 UTC 2008
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL2407WFPHC"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 76.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1920x1200_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Module"
Load "dri"
Load "GLcore"
EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "RenderAccel" "0"
Option "UseFBDev" "true"
EndSection

Section "Device"
Identifier "Device0"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6800 XT"
Driver "nv"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

tehk
February 5th, 2009, 03:43 AM
the screen artifacts only appear when typing is going on... otherwise I cannot see any screen artifacts.... thought id add that ;)

ridetheteapot
February 5th, 2009, 06:25 PM
the artifacts are happening in all apps? or is it specific to firefox (and maybe just a couple others). try to see if like gedit will do the same thing, if you its a problem with the oss driver.

you could try the nouveau driver, its a fork of 'nv', and they are trying to improve 2d and 3d preformance. i never have used it before but if you want to experiment...
http://nouveau.freedesktop.org/wiki/InstallNouveau

tehk
February 6th, 2009, 12:02 AM
the artifacts are app independant and screen wide. so, whenever I begin typing you can begin to notice a small horizontal lines that did not finish rendering completely on the screen, there is about one per keystroke.

i think im gonna stick with what I have for now as the artifacts are tolerable at least until i get a second machine purely for graphics at my desktop (hopefully next month!) and the nouveau looks a little too unstable for my level of reliability.

redroad55
February 6th, 2009, 02:06 AM
Is your keyboard PS/2 or USB .. Just curious

tehk
February 27th, 2009, 06:58 PM
usb

Name change
February 27th, 2009, 07:03 PM
I don't know how deep into "free software" you are, but I recommend to use the nVidia binary blob driver. I use their newest driver and problems are minimal. I only get some problems with full-screen videos.
Here's a useful link to Kubuntu forums to get more about how to install the driver: link (http://kubuntuforums.net/forums/index.php?topic=3100807.0)