PDA

View Full Version : [ubuntu] Banshee won't play music files



blazemore
February 3rd, 2009, 10:02 PM
Normally I know what I'm doing, so I'm a bit stumped with this one.
I imported a small music library into Banshee on my new netbook.
However, when I double-click a file to play, a small X appears next to it, and it moves to the next one. It does this a few times and then stops.

The music files play fine in VLC, and I have ubuntu-restricted-extras installed.

I've tried deleting and re-importing the files, and I'm using the latest stable Banshee from their PPA.

blazemore
February 3rd, 2009, 11:36 PM
Edit: I tried uninstalling and re-installing Banshee, and I also tried an older version. Still the same.

blazemore
February 4th, 2009, 02:19 PM
Has anyone else had this problem, or knows how to fix it?

blazemore
February 5th, 2009, 11:36 AM
*bump*

blazemore
February 13th, 2009, 12:33 AM
*week ago bump*

mc4man
February 13th, 2009, 12:38 AM
what is the format of the audio files your trying to play? (are you using 8.04 or 8.10?

shouldn't be a problem to figure this out

blazemore
February 13th, 2009, 02:05 PM
They are mp3.
I have ubuntu-restricted-extras installed, and VLC will play it.

But VLC doesn't use gstreamer, so I think it's a gstreamer problem.

mc4man
February 13th, 2009, 03:47 PM
Well I don't use gstreamer apps (audacious and amarok) so I've never used/installed ubuntu-restricted-extras but..
mp3 playback for gstreamer apps is enabled thru the gstreamer0-10-ffmpeg plugin

Search gstreamer in synaptic and see if it's (the plug in) installed. If not, install it and then restart x (Ctrl+backspace

If it is, then reinstall and restart x

tylerannosaurus
October 30th, 2009, 06:25 AM
I just fixed this problem on my computer. You just need to get the plugins gstreamer0.10-ffmpeg and gstreamer0.10-plugins-ugly. You can either go to the synaptic package manager (located in System>Administration>Synaptic Package Manager) and search for those, or I think the code to do that is just


sudo apt-get install gstreamer0.10-ffmpeg

sudo apt-get install gstreamer0.10-plugins-ugly

I think that's all you need to do...let me know if that works!

Slothcake
October 31st, 2009, 08:13 AM
sudo apt-get install gstreamer0.10-ffmpeg


Installed this and it worked fine

matthatesspam
September 1st, 2010, 05:52 PM
I just fixed this problem on my computer. You just need to get the plugins gstreamer0.10-ffmpeg and gstreamer0.10-plugins-ugly. You can either go to the synaptic package manager (located in System>Administration>Synaptic Package Manager) and search for those, or I think the code to do that is just


sudo apt-get install gstreamer0.10-ffmpeg
sudo apt-get install gstreamer0.10-plugins-uglyI think that's all you need to do...let me know if that works!
This solved the issue for me as well. :)

blazemore
September 4th, 2010, 09:33 AM
If you're running Maverick, open Banshee's page in the Software Centre, and tick all the "add-ons" to install.