PDA

View Full Version : [ubuntu] DVD and AVI not working in fullscreen



wikwanderlust
February 3rd, 2009, 02:31 PM
Alright, here's my (latest) problem. It's actually an old one, but I'd like to fix it. The problem is I can watch a protected DVD or watch an AVI movie just fine in any player I want, but when I try to go fullscreen, the program shuts down abruptly with no warning or explanation given. This happens in VLC, and Totem. I dual-boot Windows, so that's where I've been watching DVDs, but I'd still like to get this fixed, or at least find out what the problem is.

I run Ubuntu 8.10. My video card is a GeForce 6100, and I use the NVIDIA accelerated graphics driver (Version 96). If you need anything else, just ask, you're the ones helping me after all. Any help would be appreciated. Thanks.

binbash
February 3rd, 2009, 02:42 PM
Post your xorg.conf and video player's video output (x11,xv etc)

wikwanderlust
February 3rd, 2009, 02:46 PM
I kinda fell stupid now, and I appreciate the help...But I have no clue what you just said. :( Could you please tell me where to find this xorg.conf file? I'm even more confused by the video output. Considering how long I've been using Linux, I think I should know how to do this by now...Sorry.

binbash
February 3rd, 2009, 02:48 PM
sudo cat /etc/X11/xorg.conf

paste it here AND did you try changing video player's video output?go to vlc settings and video tab.there is an output option there and something is selected.tell me what is selected(X11 etc).AND try to select X11 as video output and try again.

wikwanderlust
February 3rd, 2009, 02:51 PM
Thanks for the help: Here's the xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

wikwanderlust
February 3rd, 2009, 02:52 PM
Output says default...trying x11

wikwanderlust
February 3rd, 2009, 02:54 PM
IT WORKS! Thanks binbash. That was surprisingly simple.

binbash
February 3rd, 2009, 02:54 PM
open the vlc at terminal, and open a dvd, avi etc.Paste the terminal output after the crash please.Also for protected dvds did you install libdvdcss2?

EDIT :nevermind i am glad you fixed it