PDA

View Full Version : [ubuntu] having trouble with aptitud



Vicfred
January 28th, 2009, 06:05 AM
I have 2 broken packages, tried to fix them by selecting the broken packages in aptitud... well actually everytime I install something it fails and fix the previously broken package, first vlc broke, then evolution and evolution-common, now bzr. What's happening?

fugaki
January 28th, 2009, 06:27 AM
try this in synaptic:
Edit>Fix Broken Packages

Vicfred
January 28th, 2009, 06:30 AM
that's not working

E: /var/cache/apt/archives/bzr_1.6.1-1_i386.deb: failed in buffer_write(fd) (10, ret=-1)

Vicfred
January 28th, 2009, 09:37 PM
bump

Vicfred
January 29th, 2009, 05:39 AM
bump

kshtjsnghl
January 29th, 2009, 06:07 AM
you should try the command -

sudo dpkg --configure -a

kshtjsnghl
January 29th, 2009, 06:09 AM
you may also want to remove the packages that are broken if the above command doesnt work by using

sudo apt-get --purge remove <package name>