PDA

View Full Version : [ubuntu] Disabling cups?



S0m3th1ngw13rd
January 28th, 2009, 12:54 AM
Is there a way I can disable cups? I don't think I need it(not 1 printer in the house). I might be wrong ,not sure. Can someone please advise?

Thanks ahead of time.

tdayal
January 28th, 2009, 01:12 AM
If you go to Preferences > Sessions, you can uncheck services you don't want at startup, so you probably want to uncheck the printing services.

Next time you reboot, no more printing services.

yeats
January 28th, 2009, 01:13 AM
I would think that unless there's a specific reason you don't need CUPS, you would want to leave it alone. With no active printers, it can't be using much in the way of resources. . .

But, since you're asking :-) . . . have you considered a complete removal? Reinstalling later is no sweat, especially if you don't have it configured already.

UPDATE: tdayal posted at the same time - that suggestion might be better :-)

bwang
January 28th, 2009, 01:14 AM
Why would you want to disable it? Is CUPS causing you any trouble?

I think that

sudo apt-get remove cups-pdf cupsys cupsys-bsd cupsys-client cupsys-common cupsys-driver-gutenprint libcupsys2
will remove CUPS, however, I don't recommend removing it.

S0m3th1ngw13rd
January 28th, 2009, 01:17 AM
Don't have a printer at all and don't plan on buying one so don't need cups. Unless it is used for something else also?

cariboo907
January 28th, 2009, 01:18 AM
One other way to accomplish what you want is to stop cups from starting at boot up, open a Applications-->Accessories-Terminal and type:


sudo update-rc.d -f cups remove

That way if you ever need to connect a printer, you don't have to reinstall cups, you can just start the service as needed.

Jim

S0m3th1ngw13rd
January 28th, 2009, 01:20 AM
One other way to accomplish what you want is to stop cups from starting at boot up, open a Applications-->Accessories-Terminal and type:


sudo update-rc.d -f cups remove

That way if you ever need to connect a printer, you don't have to reinstall cups, you can just start the service as needed.

Jim

Thanks Jim, this disabled it from starting at boot.