PDA

View Full Version : [ubuntu] Help With Alsamixer, Headphones and Speakers



Lunx
January 27th, 2009, 06:59 PM
Got my first ever taste of Linux and Ubuntu a couple of weeks ago and it's been nothing short of a brillant experience. Managing to stumble around in my OS and get things working with practically no problems whatsoever, and for things I've needed help with I've found all the answers in previous threads here on the forums so I've not had to post a question until now.

My problem is with alsa and sound coming from both my headphones and computer speakers simultaneously. If I start playing music through PC speakers, then plug in my 'phones, the sound continues to come from main speakers as well. I've searched threads on this and thought I'd found the solution by opening Alsamixer and muting front, but that didn't do the trick either, causes me to lose sound from both headphones and pc speakers. Everything else I find on this is about one lot of speakers not working, nothing about both speakers and earphones working at same time.

Not sure what info others will need to help me with this, but for starters I'm running 8.10 Intrepid and my other details are

**** List of PLAYBACK Hardware Devices ****

card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

And the audio controller

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)


I'm guessing it's something simple, just I can't figure it out.

Another thing I'm curious about is Alsamixer interface. I have all the boxes checked as to what is shown, but still can't see a slider control for headphones and checking/unchecking the headphones box doesn't seem to do anything at all.

Thanks in advance for any help

Lunx
January 29th, 2009, 08:52 AM
*bump*