PDA

View Full Version : [ubuntu] Can't adjust screen resolution Error message



martuschka
January 26th, 2009, 09:51 PM
Hi,

i have been having some problems with my graphics card lately, and now it is a bit better; i can atleast watch films. But i cant change the screen resolution. I tried to change it from the menu, but get this error message

The X Server does not support the XRandR extension. Runtime resolution changes to the display size are not available.


And my screens are: HP nx8220 screen 15.4 1280x800
HP w 2408h 24 monitor 1920x1200

please help ;) Ps, i know how to include information about my graphics card if u like, or i can include xorg file if that helps.

Thanks

Coreigh
January 26th, 2009, 10:39 PM
I am sorry I did not find anything comprehensive for a solution. All I can offer is to suggest tweaking the xorg.conf. The XRandR if I understand is an option to allow you to rotate the display output, like you would on a tablet. Given you don't need this you could comment that option in the conf. Also make sure you are using the ATI video driver and not a generic one. I am not sure about ATI but nVidia requires to enable the unvierse repo's and use non-free software.


Hopefully someone else with your model will have a more specific solution for you.

Best of luck.

martuschka
January 27th, 2009, 06:39 AM
Thanks for the advice, anyone else got a clue?
This is the second time i post the same thread, if i cannot solve this soon, im gonna cry ;)

Crafty Kisses
January 27th, 2009, 06:43 AM
I wouldn't mind seeing your X, but you could technically reconfigure your X and see if that does anything for you:

sudo dpkg-reconfigure xserver-xorg

mikewhatever
January 27th, 2009, 06:44 AM
What is your graphics card? If you don't know, please post the output of
<sudo lshw -C display> without brackets. Did you check if there is a driver to enable under System->Admin->Hardware Drivers?

Cresho
January 27th, 2009, 06:47 AM
I have an hpw2408 with an nvidia 8800gt. It works flawlessly in hardy heron. Also, the screen tilt works...though I had to tweak the xorg a bit. But if you have the hardware, it works with the installation of the restricted drivers no tweaking involved

Cresho
January 27th, 2009, 06:55 AM
ohh! I forgot to mention that my xorg has no information regarding resolution. I posted so you guys can see it. Nvidia graphics card and drivers takes care of all the work. ignore the " Option "NoLogo" "True"
Option "RandRRotation"" part since this was the only thing i added to make my monitor fully functional.



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "RandRRotation"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection

martuschka
January 27th, 2009, 02:30 PM
I wouldn't mind seeing your X, but you could technically reconfigure your X and see if that does anything for you:

sudo dpkg-reconfigure xserver-xorg

Hi thanks so much for trying to help out.

I did reconfig and not so much happend, the only thing i got to change was the keyboard, and nothing else.

martuschka
January 27th, 2009, 02:34 PM
What is your graphics card? If you don't know, please post the output of
<sudo lshw -C display> without brackets. Did you check if there is a driver to enable under System->Admin->Hardware Drivers?

Hi yes thanks for helping ;)
It says it is enabled and has a little green light.

This is my graphics card:

display
description: VGA compatible controller
product: M24 1P [Radeon Mobility X600]
vendor: ATI Technologies Inc
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list
configuration: driver=fglrx_pci latency=0 module=fglrx



Perhaps also worth mentioning, i can only have sound if i have headphones plugged in. But i dont care about that right now, because my speakers from the stereo are much better.
But i thought i might have something to do with the other..

martuschka
January 27th, 2009, 02:39 PM
I wouldn't mind seeing your X, but you could technically reconfigure your X and see if that does anything for you:

sudo dpkg-reconfigure xserver-xorg

Well just let me know and I'll send it your way ;)

philinux
January 27th, 2009, 02:44 PM
How is your monitor connected to the pc.

martuschka
January 27th, 2009, 02:56 PM
Yes of course it is, i see my desktop on both screens but they are huge resolutions, so i cant see the whole thing.

philinux
January 27th, 2009, 03:29 PM
Yes of course it is, i see my desktop on both screens but they are huge resolutions, so i cant see the whole thing.

I meant how physically. Direct vga cable or through a switch of some sort.

martuschka
January 27th, 2009, 05:42 PM
Ahh, sorry ;)

Looks like VGA cabels from both ends, one into the pc and the other to the screen.

philinux
January 27th, 2009, 06:17 PM
Try with just one monitor connected at a time. See if you can sort out the resolution.

martuschka
January 27th, 2009, 10:04 PM
Ok when i disconnect the other screen (big one) from the laptop everything looks perfect, i can see the whole window no problem. I then connected the bigger screen back in to the laptop and tried to change the settings for the screens and this is the message i get:

The current monitor is in the database but does not support DDC/CI
This often occurs when you connect the VGA/DVI cable on the wrong input of the monitors supporting DDC/CI only on one of its two inputs.

Which drives me nuts couse both the laptop and the screen only have one input each for this type of cable ;)

mikewhatever
January 28th, 2009, 12:33 AM
I really don't think you should pay much attention to generic messages as in above. Quite honestly, I didn't know what ddc/ci was and had to look it up.

DDCcontrol is a tool used to control monitor parameters, like brightness and contrast, without using the OSD (On Screen Display) and the buttons in front of the monitor.

I think it may be useful to look at your xorg.conf, glxinfo and xorg log, perhaps this way, we can all learn something new.
The following commands will create xorg.conf and glxinfo and Xorg.log files on your desktop, attach them to your next post:

cat /etc/X11/xorg.conf > ~/Desktop/xorg.conf
glxinfo > ~/Desktop/glxinfo
cat /var/log/Xorg.0.log > ~/Desktop/Xorg.log

martuschka
January 28th, 2009, 08:26 AM
Hmm, when i turned on the computer this morning the graphics started to be really slow again...

359 frames in 5.0 seconds = 71.345 FPS
360 frames in 5.2 seconds = 69.231 FPS
360 frames in 5.0 seconds = 71.713 FPS
400 frames in 5.2 seconds = 76.336 FPS
360 frames in 5.1 seconds = 71.252 FPS
420 frames in 5.2 seconds = 81.406 FPS
400 frames in 5.2 seconds = 77.659 FPS

martuschka
January 28th, 2009, 08:44 AM
I really don't think you should pay much attention to generic messages as in above. Quite honestly, I didn't know what ddc/ci was and had to look it up.


I think it may be useful to look at your xorg.conf, glxinfo and xorg log, perhaps this way, we can all learn something new.
The following commands will create xorg.conf and glxinfo and Xorg.log files on your desktop, attach them to your next post:

I'm so sorry for being such a noob or computer retard but the commands give me this:

horus@horus-laptop:~$ cat /etc/X11/xorg.conf > ~/Desktop/xorg.conf
bash: /home/horus/Desktop/xorg.conf: No such file or directory
horus@horus-laptop:~$ cat /etc/X11/xorg.conf >
bash: syntax error near unexpected token `newline'
horus@horus-laptop:~$ glxinfo > ~/Desktop/glxinfo
bash: /home/horus/Desktop/glxinfo: No such file or directory
horus@horus-laptop:~$ cat /etc/X11/xorg.conf > ~/Desktop/xorg.conf
bash: /home/horus/Desktop/xorg.conf: No such file or directory
horus@horus-laptop:~$ xorg.conf
bash: xorg.conf: command not found
horus@horus-laptop:~$

mikewhatever
January 30th, 2009, 12:21 PM
Sorry for the delay, I had no access to the forums for a few days. For some strange reason, your system doesn't want to create those files on the desktop, although it should. Perhaps a package responsible for this is missing, I don't know. To work around that problem, just copy/paste the outputs of the following (not too convenient, but doable):
cat /etc/X11/xorg.conf
glxinfo
cat /var/log/Xorg.0.log

I'd also like to suggest posting a but report at launchpad.net.