PDA

View Full Version : [ubuntu] connected to network but not internet



K.krstnsn
January 26th, 2009, 06:24 PM
ok, so i have this INSANE issue with ubuntu.

Lets say im connected to a wireless network, which is connected to the internet. Sometimes when i comeback to my computer while its been idle for a little bit. itll be connected to the network but not the internet. The only fix is to reboot the computer.....


Things ive tried.


Switch networks
Turn on/off networkcard

sarath_it
January 26th, 2009, 07:00 PM
Well I cant answer your problem, given limited avenues, but I can guide u to somethings that might help.

is this your home wireless network?
check routers's dchp clients table.. is your comp still connected?

try
ifconfig wlan0 down
ifconfig wlan0 up

/etc/init.d/networking restart

check the syslog in
gnome-system-log

K.krstnsn
January 26th, 2009, 07:13 PM
Well, i have a static ip set.

The thing i think is weird is.... if i reconnect to my network. itll reconnect to the network but theres still no internet. The same thing happens if i connect to another open network around me. It connects but there is no internet.

sarath_it
January 26th, 2009, 07:17 PM
How about dns? is that working?
check route info in gnome-nettool

next time, keep the syslog open, may be u will see something interesting :)

ussndmac
January 26th, 2009, 07:33 PM
Well, i have a static ip set.

The thing i think is weird is.... if i reconnect to my network. itll reconnect to the network but theres still no internet. The same thing happens if i connect to another open network around me. It connects but there is no internet.


Hmm...this is similar to what happens to my machine with wifi.

- the pc says it sees the wap
- the wap log says the pc connected
- the pc can't ping the wap or anything on the net the wap is wired to

the entire network is static ip so dns should be out of the picture...

Mac