PDA

View Full Version : [ubuntu] xorg.conf - Force YPbPr Over VGA Cable?



TheByrus
January 22nd, 2009, 01:55 AM
Every once in a while I get an itch to jump into Linux again to see what I can do with it compared to when I'm using Windows. I have a problem that really can't be solved on Windows but I think can be solved on Ubuntu given how flexible configurations can get.

I bought a cheap (VERY cheap) VGA to Component Video cable online. We're talking "Made in and Shipped Directly From China" kind of cheap. So obviously this isn't the best solution but I figure "Hey it's just video signals. How hard can it be to make this work?"

Well when I first got it I gave it a try and it almost made it. I could see my video but it was displaying on my TV three times in a row with strange colors, distortion, and only working at 1024 x 768 resolution. I gave up pretty fast but now I'm trying to get it working again.

So I did some research and found there was an option for xorg.conf that might help me. Of course the main problem here is that VGA doesn't typically send out the kind of signal component video uses which is YPbPr. So with some Googling this was the option I found might help:

Option "ForceCRT2Type" "YPBPR480P"

There are many different values for "ForceCRT2Type" but this seemed the most appropriate since my TV will do 480p at best. (Though strangely enough will do 1024 x 768 over composite video). Unfortunately this isn't working either and I was curious if someone here could help me. Here are some hardware specs to help you out:

Computer Model: HP DV9650us
OS: Ubuntu 8.10 x86
Video Card: Nvidia 8600M GS (Driver - Official Nvidia 177.82)
Processor: Intel Centrino Duo 1.5gz
RAM: 2 gigabytes

and blah blah. I'd say more but I don't think my CD drive specs or anything like that will help me much with this problem. I will say, however, that this is a fully installed Ubuntu 8.10 on a 4 gig thumb drive. That may be considered slightly unusual though I don't believe it affects my problem very much either.

In any case here is my current xorg.conf file:



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Mon Nov 3 08:46:46 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "LPL"
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option "DPMS"
EndSection

Section "Monitor"
# HorizSync source: builtin, VertRefresh source: builtin
Identifier "Monitor1"
VendorName "Unknown"
ModelName "CRT-0"
HorizSync 28.0 - 55.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600M GS"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600M GS"
BusID "PCI:1:0:0"
Screen 1
Option "ForceCRT2Type" "YPBPR480P"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: 1440x900_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT: 640x480_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


Just to note, I have tried putting the option under the device section and monitor section (this is the second screen so it IS suppose to be screen "1" not "0") with no change in result. Currently my TV will flicker "VIDEO 2" on and off in the upper right corner, implying that it is trying to receive something. However the screen also stays blue which is what it does when there is no video feed.

simosx
November 21st, 2009, 04:36 PM
Apparently, ForceCRT2Type works for graphics cards based on the SiS chipset,
http://www.x.org/archive/X11R6.8.0/doc/SiS2.html

It should be possible to get other graphics card drivers to perform such a conversion. For NVidia, there is the issue with the closed-source driver, so it either supports this conversion or you are out of luck.

I would suggest that you ask at the xorg-devel mailing list,
http://lists.freedesktop.org/mailman/listinfo/xorg

You have done quite some work on this, so it's good to take it to the end.