PDA

View Full Version : [ubuntu] 6th Generation Ipod Classic 120GB



dennismoore1
January 21st, 2009, 12:23 AM
i just bought one and i cant find a single program that works with it
any ideas??

Gramps
January 21st, 2009, 12:28 AM
Try this http://www.gtkpod.org I think iTunes works under wine too.

dennismoore1
January 21st, 2009, 12:40 AM
gtkpod doesnt support the 120gb ones for some reason
under classics it only says 80gb and 160gb
and ill see about iTunes=]]

dennismoore1
January 21st, 2009, 12:43 AM
nope itunes doesnt work man=/

dennismoore1
January 21st, 2009, 12:46 AM
any other ideas anyone??

Veteropinguis
January 30th, 2009, 07:32 AM
I'm in the same situation...got a 120 GB iPod for Christmas but have been getting more in to Ubuntu and don't want to have to deal with having to boot in to Windows every time I'd want to sync anything.

Bump?

steeleyuk
January 30th, 2009, 08:39 AM
My mum has got an 120GB 6th Gen iPod working with GTKPod so it is doable.

I'll let you know if I can remember how I did it. I know I compiled libgpod and gtkpod to the newest versions. You also have to get the FirewireGuid and place it in one of the files on the ipod.

nlz
January 30th, 2009, 08:55 AM
rockbox will work i think..

www.rockbox.org

please report back, i also want to buy one,but only if rockbox works on it.

steeleyuk
January 30th, 2009, 09:02 AM
I would avoid an Ipod altogether and support a company which a) supports Linux and b) doesn't try to block the devices use in applications other than iTunes.

Just my opinion.

Anyway, the 6th Gen Classic isn't on the list of the supported devices on Rockbox.

steeleyuk
January 30th, 2009, 10:20 AM
Update: On a fresh install of Intrepid the 6th Gen works perfect with Rhythmbox. You can play from the device and send music to it.

nlz
February 4th, 2009, 10:46 AM
rockbox will work i think..

www.rockbox.org

please report back, i also want to buy one,but only if rockbox works on it.

Rockbox won't work on Ipod classic due to changed firmware since Ipod video. It's shame..

Black_Monkey
February 4th, 2009, 04:15 PM
I just used GTKPod and Amarok, and told it that it was an 80GB one or something. As long as it's a 6G Classic, it doesn't really matter.

Nehilor
January 13th, 2010, 09:12 PM
Hi, i have a iPod 120gb 6th Generation and i put it the music with Rhythmbox in Ubuntu 9.10 without any problem and for the CD covers maybe with Amarok while you are connected to internet.

Extra Help:
In Rhythmbox:
- Right click over "Music" and choose Add Folder.
- When you have all the music added to the playlist just select all and drag it over your iPod.
- Put a Internal Suffering cd or Amputated Genitals cd and go f-u-c-k-i-n-g headbanging all the day! haha XD :guitar:

Cheers! :)

iluii
July 3rd, 2010, 07:54 PM
I know this thread is already outdated but Amarok (1.4.7) under xubuntu 8.10 worked great with my Classic 120gb. Maybe this link can help:

http://forum.kde.org/viewtopic.php?f=121&t=74115

the info is also a bit outdated and I havent changed the music my iPod in a year, since its almost full, and have since updated to 10.04 lts and havent tried the new libgpod nor the new Amarok. But i hope it helps