PDA

View Full Version : [ubuntu] i ruined my sound driver totally



Santooka
January 20th, 2009, 08:28 PM
Dear all,

after sending beginning this thread:http://ubuntuforums.org/showthread.php?p=6585610#post6585610 and no one answered me, i decided to do it myself, so i ruined my sound settings totally and i dunno what to do, how to get it back like it was, where to look at....

so can anybody drive me out of this?

I NEED MY SOUND BACK PLEASE!!!!

cariboo
January 20th, 2009, 08:48 PM
It would help if you could tell us what you have done to get you to the point where you are, so that we get an idea of where to start.

Jim

Santooka
January 20th, 2009, 09:42 PM
cool now i reinstalled the linux image 2.6.24-11 ad it works again


but still no surround

i have 4.1 speakers

i am trying everything written on the internet to do it and nothing yet

ask for whatever files outputs and i will deliver it here but i really need a solution for this

best regards

Santooka
January 20th, 2009, 09:51 PM
ok i tried this :http://www.automaticable.com/2008-05-28/how-to-enable-surround-sound-on-ubuntu-hardy/

and tried to install this: http://paste.ubuntuusers.de/raw/393727/ after downloading the package, this is where i totally ruined my sound....

and after fixing it i tried other diofferent things buty alot of threads are talking about the 5.1 and 7.1 speakers and channels, and i guess they differ from the 4.1, right? i dunno

so do u have any ideas what to do ?

cariboo
January 21st, 2009, 05:27 AM
You do realize that the drivrs you installed are available in the rpeositories. Open System-->Administration-->Synaptic package Manager and search for alsa-base, this includes the needed drivers.

In a Applications-->Accessories-->Terminal type:


sudo lshw -C multimedia

and paste the output in your next post. The above information will help us solve your problem.

Jim

Santooka
January 21st, 2009, 04:23 PM
here's what i got:


*-multimedia
description: Audio device
product: 82801G (ICH7 Family) High Definition Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=HDA Intel latency=0 module=snd_hda_intel

cariboo
January 22nd, 2009, 12:32 AM
Double-click the speaker icon in the top panel and make sure all the controls are turned right up. Also go to System-->Preference-->Sound, and make sure all the outputs are set to autodetect.

Jim

Santooka
January 22nd, 2009, 12:47 AM
done, but what mixer do i choose?

i chose HDA Intel (Alsa mixer), right?

anyways it didn't do anything

Santooka
January 22nd, 2009, 12:50 AM
yeah i guess it's the right one

cariboo
January 22nd, 2009, 07:03 PM
So are you saying your sound now works?

JIm

Santooka
January 23rd, 2009, 03:30 AM
NOOOOOOOOOOO

the sound works fine from the beginning but the thing is with the rear speakers, they r not working at all....

i only hear them click at the booting and shutting down the computer, except that nothing...

Santooka
January 23rd, 2009, 12:41 PM
so no better ideas yet??

i never knew this will be a a hard difficult problem like it is right now

Santooka
January 25th, 2009, 01:29 AM
so .................
nothing?

cariboo
January 28th, 2009, 01:13 AM
Can you post a screenshot of what you see when you click on System-->Preferences-->Sound?

Jim

Santooka
January 29th, 2009, 12:46 AM
here it is, but note that i tried to change the device several times and nothing changed :s

http://ubuntuforums.org/attachment.php?attachmentid=101331&d=1233186286

cariboo
January 29th, 2009, 01:35 AM
It looks like your outputs are detected properly, so it is just a matter of getting the volume turned up. Strangely I get two different result from alsamixer and gnome-aslamixer, see screenshot. I would suggest using gnome-alsmixer to see if you can turn the other outputs up.

Jim

Santooka
January 30th, 2009, 02:35 AM
here's how it looks for me

cariboo
February 3rd, 2009, 07:44 PM
I noticed you have side and lfe turned down, maybe you should turn them up.

Jim