PDA

View Full Version : [ubuntu] Agere WinModem working on ubuntu 8.10



marcosabel
January 20th, 2009, 05:43 PM
The drivers on http://linmodems.technion.ac.il/packages/ltmodem/sv92/ are for previous versions of Ubuntu. With a minor modification of the agrsm-20080203.tar.gz package it can run on ubuntu 8.10.
The modification was to change on file serial26.c the line 1007 from this:

struct tty_struct *tty = up->port.info->tty;

To This:

struct tty_struct *tty = up->port.info->port.tty;

And that is all.

Hope to help somebody. This issue give me many headaches

Regards.

macinnisrr
January 21st, 2009, 12:08 AM
Thanks alot! I've been trying to get this modem working for the last week to no avail. I'll give this a shot asap and hope for the best