PDA

View Full Version : [ubuntu] Intrepid/Gnome: Compose key not working



IainPurdie
January 20th, 2009, 05:41 PM
I just updated from Hardy to Intrepid and I had a couple of niggles afterwards. The compose key no longer functioning is one of them. I've double-checked all the settings within Keyboard and Keyboard Shortcuts to no avail.

I used to use right-CTRL which worked a treat. I quite like the CTRL-letter-then-accent method as I type in a lot of foreign languages for a travel blog.

Settings as they stand (and as far as I can recall, the same as I had under Hardy):

Keyboard model: Acer laptop
Layout: United Kingdom
Alt/Win behaviour: Meta mapped to left Win
Caps Lock: Default
CTRL key position: Default
Layout switching: none selected
Misc comp options: none selected
Numeric keypad delete: Default
Numeric keypad layout: Default
Euro sign: 4
Compose key: Right CTRL
Third Level Chooser: Press right alt to choose 3rd level. Shift+right alt is Multi_Key

Am I missing something?

LaChatonFoulle
November 10th, 2009, 08:39 PM
i found i have to visit System -> Preferences -> Keyboard -> Layouts -> Layout Options -> Compose key position and re-check my choices EVERY TIME I LOGIN to use my compose keys as i had them set in 9.04 and 8.10 and 8.04.......

hth

mpm
November 25th, 2009, 08:22 PM
I recently did a fresh install of Karmic 9.10, and when I set the compose key as left control as I have for the last 5 releases, it didn't work. What I had to do was change the compose key to the right menu button. There must have been another key binding interfering with the left control key. I only had to train myself to use a different key.
Good luck!