PDA

View Full Version : [ubuntu] XAMPP won't connect.



hoboy
January 17th, 2009, 02:03 PM
I have installed xampp it start very well I can connect to http://localhost/phpmyadmin/
I have installed Mysql Administrator and Msql querry Browser using synactic
but I can not connect to the mysql db true Administrator or querry Browser.
On the console I am getting the following error
when I use mysql
I get the following error
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
After long time googling here I am

TANGO!
January 17th, 2009, 07:55 PM
I'm having the exact same problem. After lots of googling and searching for possible solutions in this forums, and reading the Mysql manuals. Help please...

Bumpity

kranny
January 17th, 2009, 08:07 PM
Hi,

The problem here i think might be that the mysql-browser doesnt find the correct sock file it is searching for.There should be some place to change configuration for mysql-query-browser.But here is a quick fix.

Create /var/run/mysqld directory
Create soft link for mysql.sock from xampp directory


sudo ln -s /opt/lampp/var/mysql/mysql.sock /var/run/mysqld/mysqld.sock

TANGO!
January 17th, 2009, 08:27 PM
Awesome, that did it for me!!!

Thank you very very much hoboy, I didn't have to get into editing the my.cnf file.:D

I can't find the "thx" thingy here in the forum... can only the starter of the thread give thanks?

kranny
January 18th, 2009, 10:55 AM
The reply was given by me tango:P:P
Btw the mods removed thanks giving option recently.

hoboy
January 18th, 2009, 11:49 AM
Thanks you are genius, my problem is solved.

TANGO!
January 18th, 2009, 09:15 PM
Oopsies, you're right, a million thanks Kranny! I'm sure the post will help lots of other people in the future.

kaqfa
March 27th, 2011, 04:58 AM
Thank you for the solution, it works for me :)