PDA

View Full Version : [kubuntu] Configure default window manager



spinstartshere
January 16th, 2009, 11:14 PM
I recently started using KDE as my main desktop environment as I now find it better than GNOME. However, I have found that logging in causes Compiz to be used as the window manager, rather than KWin. Is there a way to change this so that KWin is loaded by default? I have looked all over the system settings but have not been able to find anythign relevant. Thanks.

mac71
January 17th, 2009, 01:01 AM
Hi, have you looked at system settings>default applications and select window manager. From there you can select default (kwin) or another window manager such as compiz or metacity. It should change the setup instantly.

As an after thought, have you tried setting up in the advanced tab of system settings>session manager to run with a empty session (don't know if that'll make a difference):)

spinstartshere
January 17th, 2009, 01:06 AM
I forgot about that... Correction: I found one thing of relevance, but changing it was only effective until I rebooted. Thanks for the suggestion, though.

mac71
January 18th, 2009, 09:44 AM
No problem. Wish I could have been more help. Oh, one thing thats just come to me- have you tried installing fusion icon? run that and switch your window manager from there.

spinstartshere
January 18th, 2009, 10:43 AM
I already have it installed, but I'm one of these people who says that I shouldn't have to do something else in order for it to work properly.

mac71
January 18th, 2009, 11:01 AM
Yep. I totally understand. It would end up driving me mad too.

benerivo
January 18th, 2009, 02:35 PM
To stop compiz loading on kde startup, i think you can go to the advanced tab in System Settings. Open the autostart section, and disable compiz. This change should be permanent.

spinstartshere
January 18th, 2009, 02:38 PM
It isn't enabled there.

benerivo
January 18th, 2009, 02:47 PM
Check in ~/.kde/autostart and ~/.config/autostart.
Also try disabling desktop effects in gnome (if this is an option).

I forget how the System Settings in kde4 looks, but i remember some option where you choose the default window manager from a drop down list.

txcrackers
January 18th, 2009, 10:27 PM
You could also uninstall Compiz - if you're not using it, why keep it?

spinstartshere
April 14th, 2009, 12:03 AM
I keep it because it's a part of the desktop. I am still having problems with Compiz loading with KDE4, even when it is disabled in GNOME. KWin is not showing in the system monitor, only Compiz, whose parent process is ksmserver. However, I cannot find any mention of Compiz anywhere in the Service Manager or Autostart.