PDA

View Full Version : [ubuntu] Cannot reach router in Intrepid



diogobaeder
January 4th, 2009, 04:45 AM
Hi, guys,

Yesterday I turned on my machine, which has Ubuntu since November 2008, and all of a sudden it cannot connect to the LAN anymore. It is simply not reaching my router, which is configured at 192.168.1.1 as the gateway.

I noticed that, when I restarted the machine on Windows, it complained that there was an IP conflict within the network, which was true (there were two machines using 192.168.1.102), even because I configured it as manual address, and the network came back when I setted to automatic IP addressing in Win, but Ubuntu didn`t work with DHCP setting my machine at .103 or even manually at .120, for example.

So, I'll put all the command outputs here, that I found usefull, hoping someone can help me out... :-(

$ sudo lshw -C network

*-network
description: Ethernet interface
product: RTL-8139/8139C/8139C+
vendor: Realtek Semiconductor Co., Ltd.
physical id: c
bus info: pci@0000:00:0c.0
logical name: eth0
version: 10
serial: 00:e0:7d:a4:df:68
size: 100MB/s
capacity: 100MB/s
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.103 latency=64 link=yes maxlatency=64 mingnt=32 module=8139too multicast=yes port=MII speed=100MB/s
*-network
description: Ethernet interface
physical id: 1
logical name: pan0
serial: 06:22:b0:bc:27:c2
capabilities: ethernet physical
configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes





$ ifconfig

eth0 Link encap:Ethernet Endereço de HW 00:e0:7d:a4:df:68
inet end.: 192.168.1.100 Bcast:192.168.1.255 Masc:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:576 Métrica:1
pacotes RX:901 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:35 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:121654 (121.6 KB) TX bytes:7392 (7.3 KB)
IRQ:16 Endereço de E/S:0xe800

lo Link encap:Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACK RUNNING MTU:16436 Métrica:1
pacotes RX:20590 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:20590 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:0
RX bytes:3233981 (3.2 MB) TX bytes:3233981 (3.2 MB)

pan0 Link encap:Ethernet Endereço de HW 06:22:b0:bc:27:c2
endereço inet6: fe80::422:b0ff:febc:27c2/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:6 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:468 (468.0 B)




$ cat /etc/resolv.conf

# Generated by NetworkManager
nameserver 201.6.0.42
nameserver 201.6.0.112




$ cat /etc/network/interfaces

auto lo
iface lo inet loopback




$ route

Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
192.168.1.0 * 255.255.255.0 U 1 0 0 eth0
link-local * 255.255.0.0 U 1000 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0




$ route -n

Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0




$ ping -c 4 www.google.com

ping: unknown host www.google.com





$ ping -c 4 74.125.43.104

PING 74.125.43.104 (74.125.43.104) 56(84) bytes of data.
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted

--- 74.125.43.104 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3013ms




$ paris-traceroute 192.168.1.1

terminate called after throwing an instance of 'TrException'
Exception : [ERROR](Server.cc, 51)Cannot create the server : Operation not permitted
Cancelado

(Note the dollars as the shell prompt)

Thank you, guys!

Diogo

Noel96
January 4th, 2009, 02:55 PM
Have you tried booting up from the liveCD to see if you can connect to your router using that?

Iowan
January 4th, 2009, 04:40 PM
Your /etc/network/interfaces file has no definition for eth0. You might try adding back these lines (via sudo nano /etc/network/interfaces or gksudo gedit /etc/network/interfaces):
auto eth0
iface eth0 inet dhcpIf you'd prefer static address, input that information instead - but pick an address outside the router's DHCP pool (but still inside the subnet).

diogobaeder
January 4th, 2009, 09:08 PM
Hi, Noel and Iowan,

I'm currently answering your posts through the LiveCD (which raises the fact that the network is OK, so the problem is in my machine).

Iowan, thanks for the hint; since Intrepid has a NetworkManager, I thought it would deal with /etc/network/interfaces correctly... I'll try it now, after reboot, and post the result here...

Thank you, guys!

Diogo

aesis05401
January 4th, 2009, 09:18 PM
... but Ubuntu didn`t work with DHCP setting my machine at .103 ...


Can you clarify this for me? I am having a similar networking issue but my dhclient eth0 operation cannot complete the negotiation with my DHCP server.

You were able to acquire the .103 address from your DHCP server(?) or are our problems possibly related?

diogobaeder
January 4th, 2009, 09:33 PM
Aesis: yes, I could get the IP defined by DHCP as much as by static addressing. I could ping myself, but not the gateway (192.168.1.1).

Iowan: your solution worked, but it stops the Intrepid's NetworkManager. Considering this to be the only solution, it's not that bad, the important thing here is to get Internet and LAN to work (I'm sending the current message by the troubled machine)... but since it is such an easy tool, it would be nice to have it working back again... despite, I'm planning to reinstall everything when Jaunty launches in april, so I think I can live with it till then...

Thanks a lot, again!

Diogo

Noel96
January 5th, 2009, 02:40 AM
Something that worked for me once was

uninstall Network Manager using Administration / Synaptic Package Manager
reboot
re-install Network Manager using the above Synaptic Package Manager (make sure you have a live, wired internet connection when you re-install so that NM can find it)

Since Network Manager is part of the LiveCD install, you don't need a network connection to actually install it. It re-installs from the CD. (You might need to make sure that you put a checkmark against "CD Rom" in the repository sources. I don't remember doing that, though.)

Regards,
Noel

diogobaeder
January 5th, 2009, 11:06 AM
Thanks, Noel! I'm at work, now, but as soon as I get home I'll check it out!

Diogo

theozzlives
January 5th, 2009, 11:22 AM
set your network settings as automatic. Then go to your router config go to your LAN settings, tell it to use the router as DHCP and assign your IPs there. You'll need to know the hostname, IP address, and MAC address of each computer. You can get the MAC in Ubuntu by typing:

ifconfig
you can get it in windows by typing:

ipconfig /all

diogobaeder
January 6th, 2009, 12:58 AM
Noel, I tried the "uninstall, reboot, uninstall" procedure but it didn't work. Still "sendmsg: Operation not permitted" when pinging my router.

I'll stick to /etc/network/interfaces, while nothing better happens...

Ozzie, I couldn't quite understand you when you meant configuring my router to DHCP mode and manually setting the machines' IPs at the same time...

Thanks,

Diogo

Iowan
January 6th, 2009, 03:10 AM
Check the options in this workaround (http://ubuntuforums.org/showthread.php?t=974382). Some of the posts list options other than un-installing NM.

diogobaeder
January 8th, 2009, 02:57 AM
Hi, Iowan an people,

I tested the various possibilities posted in this thread, including following the static IP (maintaining the NetworkManager) one from the other refered thread.

Only editing /etc/network/interfaces worked, all the other ones got the IP and DNS server from the router (and static config was OK, too), but threw me the "operation not permitted" message on "sendmsg" (on ping) and "send_packet" (on networking restart).

Do you guys think it's the case to open a bug for the Ubuntu team?

Thanks!

Diogo