PDA

View Full Version : [ubuntu] loud pitched noise



hvacr
January 4th, 2009, 04:26 AM
PP4 running ubuntu 8.10 64 with the newest system76 drivers. When I close my laptop lid while the system is running I get a loud high pitched noise from the laptop. I have set all volumes to mute, set do nothing when lid is closed in the power management. I have disabled all warnings also. I have no idea what could be causing this at all.

zenmatrix
January 4th, 2009, 04:32 AM
some drives have ascoutic managment drivers in windows if you just installed ubuntu after using windows that could explain the higher pitched noise. Good news is if it is that your drive will run more efficently since the acoustic managment slows the drive to limit the noise

hvacr
January 4th, 2009, 04:34 AM
some drives have ascoutic managment drivers in windows if you just installed ubuntu after using windows that could explain the higher pitched noise. Good news is if it is that your drive will run more efficently since the acoustic managment slows the drive to limit the noise

This does not sound like it is coming from the drive, plus this is a very high pitched noise. It does not do it when I boot into Vista.

zenmatrix
January 4th, 2009, 04:41 AM
Its hard to say, the only things that can make that kinda noise is

cd
hdd
speaker
fans

if fans are all that are left it could be that running ubuntu is making it run hotter

hvacr
January 4th, 2009, 05:06 AM
Its hard to say, the only things that can make that kinda noise is

cd
hdd
speaker
fans

if fans are all that are left it could be that running ubuntu is making it run hotter

This sound only occurs when I close the lid while ubuntu is running, the cd, hdd, speaker, fans would have nothing to do with this.

Lee_Machine
January 4th, 2009, 08:06 AM
The sound is feed back coming from the internal mic. All you need to do is go double click the sound icon and turn front mic all the way down.


Then when you use it...and most people dont unless they are using Skype to audio chat just turn it back up.

I keep my down and use a logitec head set.

hvacr
January 4th, 2009, 01:38 PM
The sound is feed back coming from the internal mic. All you need to do is go double click the sound icon and turn front mic all the way down.


Thanks, that did the job. That was the only thing I did not disable in the sound section. Strange thing to happen though.

Lee_Machine
January 4th, 2009, 02:09 PM
Your welcome,

I've had the same thing happen to me on my Pangolin about 2 months ago.

Don't be to quick to blame Linux, S76, or ALSA. As Ive had this happen to me on a few laptops. Ranging from Dells with Windows XP, Vista, and even on a Macbook Pro.

Internal mics have to be turned up much for them to even record usable sound, that they are prone to feedback.

Usually with other devices, such as electric guitars, other microphone, what be it. I have found external ones to work better for me anyhow while recording me playing my guitar.

Although when I use skype on my Macbook Pro I am told by the other person on the other end can hear me loud and clear. I dont get that with the Pangolin. I have read that these new Pangolins has a much better internal mic than the old ones.