PDA

View Full Version : [ubuntu] [SOLVED] RTL8139 Ethernet not working



gletob
January 3rd, 2009, 08:49 PM
Hi I just installed ubuntu on my desktop and it has an integrated ethernet controller the Realtek RTL8139 and it's not working. The cable is connected but the lights on the back of the computer and on the router are not on. The card and cable work fine in XP. lspci shows it as

02:03.0 Ethernet Controller: Realtek Semiconductor Co., Ltd. RTL8139/8139C/8139C+ (rev10)

albinootje
January 3rd, 2009, 08:51 PM
Hi I just installed ubuntu on my desktop and it has an integrated ethernet controller the Realtek RTL8139 and it's not working. The cable is connected but the lights on the back of the computer and on the router are not on. The card and cable work fine in XP. lspci shows it as

02:03.0 Ethernet Controller: Realtek Semiconductor Co., Ltd. RTL8139/8139C/8139C+ (rev10)

Please try this :
http://wiki.archlinux.org/index.php/Configuring_network#Realtek_No_Link_.2F_WOL_issue



Method 2 - Enable WOL in Win driver

Probably the best and fastest fix is to change this setting in the Windows driver. This way it should be fixed system wide and not only under Arch (eg. live CD's, other OSes). In Windows under device manager, find your Realtek Network adapter and double click it. Under the advanced tab change "wake-on-lan after shutdown" to enable.

In Windows XP (example)
Right click my computer
--> Hardware tab
--> Device Manager
--> Network Adapters
--> "double click" Realtek ...
--> Advanced tab
--> Wake-On-Lan After Shutdown
--> Enable.

gletob
January 3rd, 2009, 09:43 PM
Thanks so much that fixed my problem!

bro-ken
March 31st, 2010, 12:57 PM
what about this problem in Karmic with same adapter?

Dener
April 9th, 2010, 05:59 PM
What about if I don't have xp just Ubuntu 9.10?

Iowan
April 9th, 2010, 10:41 PM
There are a few RTL8139 threads... If none of them help, you might start a new thread. This one is marked [SOLVED], so it may not draw the assistance you hope.