PDA

View Full Version : [ubuntu] Danger of the deep (game) install



marcgh
January 3rd, 2009, 11:53 AM
Now that I am able to do most of my work in Ubuntu I have to start thinking also about relaxing.

i have downloaded (from : http://dangerdeep.sourceforge.net/download.html) the GNU/Linux (x86 & x86-64):- dangerdeep-0.3.0-linux-installer.bin

I was thinking install would start when I click on the .bin file but I got the following message :

http://ubuntuforums.org/attachment.php?attachmentid=98541&stc=1&d=1230979932

What did I did wrong?
Thanks in advance for any help

linux_tech
January 3rd, 2009, 12:14 PM
in terminal, type
ls as needed to locate the dangerdeep-0.3.0-linux-installer.bin file

then cd to that directory
for example, if you downloaded to the desktop then type:

cd Desktop

then type:


chmod +x dangerdeep-0.3.0-linux-installer.bin
next type:

./dangerdeep-0.3.0-linux-installer.bin
and then install should begin

marcgh
January 3rd, 2009, 12:28 PM
Thanks, Linux_tech.
Problem solved.
Happy new year!

marcgh
January 3rd, 2009, 12:49 PM
Sorry to bother again.
I think install ( following above instructions) went well.
But when I click on the created desktop icon...thats what I get.

ChristopherDante
January 31st, 2009, 05:13 AM
Yeah - that's as far as I got as well.
Looks to me like root owns everything and I don't see a way of getting around this issue.

..darn...!

abasel
February 13th, 2009, 11:42 PM
My install seems to go well but no shortcut is created so can't work where to find or run the install

abasel
February 13th, 2009, 11:46 PM
Ok so I found the shortcut but it doesn't run

RomeReactor
February 14th, 2009, 01:06 AM
Hi. Did you install Danger From The Deep using sudo, or as a regular user? Is your Ubuntu installation 32 bit or 64? If you're unsure about this last part, run the following from a terminal:

uname -m
If it returns x86_64, you have Ubuntu 64 bit, in which case the executable should be dangerdeep_x86-64; otherwise, you have Ubuntu 32 bit, and the executable is just dangerdeep. Run the executable from the terminal, and post any errors you get there.

If the error you get is "command not found", run this for Ubuntu 32 bit:

sudo updatedb; locate dangerdeep
or, for Ubuntu 64 bit:

sudo updatedb; locate dangerdeep_x86-64
When the executable shows up, run it in the terminal using the complete path, and again, if you get errors, please post them.

pro-guide
February 14th, 2009, 07:09 PM
This is the error I get when trying to run danger from the deep.


$ /usr/games/dangerdeep_x86-64
/usr/games/dangerdeep_x86-64: error while loading shared libraries: libSDL_image-1.2.so.0: cannot open shared object file: No such file or directory

RomeReactor
February 14th, 2009, 11:40 PM
This is the error I get when trying to run danger from the deep.


$ /usr/games/dangerdeep_x86-64
/usr/games/dangerdeep_x86-64: error while loading shared libraries: libSDL_image-1.2.so.0: cannot open shared object file: No such file or directory

Install libsdl-image1.2:

sudo aptitude install libsdl-image1.2

pro-guide
February 21st, 2009, 06:15 AM
Thanks! :popcorn: