PDA

View Full Version : [ubuntu] 8.10 wireless problem



smoggie
January 2nd, 2009, 11:59 PM
hi, been researching this, but now need to ask. I have network controller showing BCM 4306, and am running ubuntu 8.10

when i click the wirelss icon everything is enabled, and I have entered my network name and passkey, but getting a disabled error message.

I'm keen to get going with Ubuntu (pure install on a new s/h machine, but have no experience.

any suggestions?

Neil

jbrown96
January 3rd, 2009, 12:10 AM
I'm not sure what you mean by "disabled error". Could you post the exact error message? Some additional info would also help. Could you post the output of the following commands?

iwlist scan
ifconfig
iwconfig
Are there any drivers listed in the manager (System-->Admin-->Hardware Drivers)?
If its still not working, you might try (temporarily) disabling/switching encryption and see if that works.

handydan918
January 3rd, 2009, 12:11 AM
First, disable security on your router, and get your card configured without wep or wpa or whatever. Then, after you are up and running, set up security.

melojo
January 3rd, 2009, 12:18 AM
look at this
http://ubuntuforums.org/showpost.php?p=6077792&postcount=72

smoggie
January 3rd, 2009, 12:28 AM
jbrown - ta, but i am using laptop to talk to you so can't cut and paste easily.
iwlist scan ( I just typed that into terminal box)
l0 doesnt support scanning
eth0 doesnt support scanning
pan0 " "
wlan no scan results


iconfig
command not found
l0 no wireless extensions
eth0 " "
wlan iee 802 11bg ESSID " " - which I saw previously was significant.

When I left click the network icon next to the date, I get a drop down with wired network, wireless network and auto eth all grayed out. only vpn is available. I did what I could there with the name and passkey, but no connection

DarkReaper79
January 3rd, 2009, 12:38 AM
Right click on the network icon, then edit connections. All the connections should be there, for you to change.

smoggie
January 3rd, 2009, 12:43 AM
ta melojo

did as recommended and rebooted pc. it did do something, but the icon still wont let me connect. I now am getting a keyring password message that I cant clear by using my admin password. I have also tried editing the network comnnections, I already did this, and still no luck. Not sure if I need to input more info into the boxes, but have done what I know to do

smoggie
January 3rd, 2009, 12:47 AM
did that, but no change - is there some further info I need to add? I am clicking wirelss, network name, then getting an unlock keyring message. I have tried my ubuntu passowrd, then my network passkey, bu the nm-connection editor keeps asking for teh password - any suggestiopns?

thanks

melojo
January 3rd, 2009, 12:48 AM
ta melojo

did as recommended and rebooted pc. it did do something, but the icon still wont let me connect. I now am getting a keyring password message that I cant clear by using my admin password. I have also tried editing the network comnnections, I already did this, and still no luck. Not sure if I need to input more info into the boxes, but have done what I know to do

Have you rebooted?

You might post the output of this again and see if it changed anything.


iwlist scan
ifconfig
lsmod | grep b43*


| this is a pipe usually located on the backlash

bump_
January 3rd, 2009, 12:52 AM
Do you see the network in the drop down list when you click on the icon? Because your output for iwlist would suggest otherwise.

Is there a way for you for save the output of those commands into a file and bring it over to your laptop with a flash drive or something? Because the exact output would make some things clearer.

smoggie
January 3rd, 2009, 12:53 AM
did that, but no change - is there some further info I need to add? I am clicking wirelss, network name, then getting an unlock keyring message. I have tried my ubuntu passowrd, then my network passkey, bu the nm-connection editor keeps asking for teh password - any suggestiopns?

thanks

DarkReaper79
January 3rd, 2009, 12:55 AM
when you installed Ubuntu, you were asked to make a admin password, then at one point a keyring one, did you make the same password for both?

smoggie
January 3rd, 2009, 01:04 AM
Here we go, hope this is what you need to see!


il@neil-desktop:~$ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 No scan results

pan0 Interface doesn't support scanning.

neil@neil-desktop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:10:dc:f5:99:38
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:19 Base address:0xd000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:480 errors:0 dropped:0 overruns:0 frame:0
TX packets:480 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:30080 (30.0 KB) TX bytes:30080 (30.0 KB)

neil@neil-desktop:~$ lsmod | grep b43*
b43 131356 0
rfkill 17176 2 rfkill_input,b43
mac80211 216820 1 b43
led_class 12164 1 b43
input_polldev 11912 1 b43
ssb 40580 1 b43
neil@neil-desktop:~$

DarkReaper79
January 3rd, 2009, 01:07 AM
Ok, im wired on my laptop, so i went through to set up wifi to see if I can help more.

First I turned wifi on on the laptop

if you have not disabled encryption on your router do so, or get the code

do as you did previously and go to edit connections. you may need to remove your previous set up wifi profile.

type in the ssid of your router (its found in the wireless setting on the router)

Then go to the encryption, I use WEP so i used wep 40/128 and put the network pass code there.

It asked me to make a keyring password so i did, I had to re enter the network passcode in the settings box.


Then it asked if I wanted to apply the keyring to the wireless settings. It connected.

Now if you already made the keyring, and it wont work, sorry im no help.

bump_
January 3rd, 2009, 01:08 AM
It doesn't look like your wireless interface is even up. Try running


sudo ifconfig wlan0 up

and then see if wlan0 was added to the output of


ifconfig

jbrown96
January 3rd, 2009, 01:10 AM
If you can remove the security on the router, try this.

1) stop Network Manager
sudo /etc/init.d/NetworkManager stop

2) try connecting manually.
sudo iwconfig wlan0 essid "YOUR ESSID" obviously replace with your essid but you do need the quotes.

3) try to renew your ip
sudo dhclient

4) try pinging a website or just use firefox to test

What type of wireless security are you using? A lot of people have trouble with WEP because there are at least two modes (hex and passphrase). Have you tried all the types?

smoggie
January 3rd, 2009, 01:34 AM
you must be right, dark reaper, though I had forgotten. I entered an old password and have gotten in. I am in editing connections and have my network name in the ssid box, the mode is infrastructure. no bssid, and no mac address. MTU is auto. securitry is wep 40/128 bit. I entered passkey and hit connect, and a quick message from the network icon states that I am disconnected. No further info there.

smoggie
January 3rd, 2009, 01:46 AM
thanks again

I am trying to cover all the suggestions here.
I do know my network passphrase, and my network ID name, but don't know the SSID or how to get it from the router.
I don't know how to remove the security from teh router, but as I am not even having ubuntu pick it up, I don't suppose I should.
I am trying to connect to a hidden network, and am putting in the name of the one I know I run, but it is not detecting any local signals.
I don't know what a ping is, or how to do it.
I ran sudo ifconfig and it came up with SIOCSIFFLAGS no such file or directory

alphaakenny1
January 3rd, 2009, 01:57 AM
smoggie

I can confirm this works for a Broadcom 4306 card (Rev02), check this by typing lspci in the terminal:


echo 'blacklist bcm43xx' | sudo tee -a /etc/modprobe.d/blacklist
sudo apt-get install ndiswrapper-utils-1.9
mkdir ~/bcm43xx; cd ~/bcm43xx

wget http://myspamb8.googlepages.com/WPC54Gv2_40826-pruned.zip
unzip WPC54Gv2_40826-pruned.zip

sudo ndiswrapper -i bcmwl5.inf
ndiswrapper -l
sudo depmod -a
sudo modprobe ndiswrapper
sudo cp /etc/network/interfaces /etc/network/interfaces.orig
echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces
sudo ndiswrapper -m
echo 'ndiswrapper' | sudo tee -a /etc/modules
echo 'ENABLED=0' | sudo tee -a /etc/default/wpasupplicant

sudo aptitude remove b43-fwcutter

sudo gedit /etc/init.d/wirelessfix.sh

#!/bin/bash
modprobe -r b44
modprobe -r b43
modprobe -r b43legacy
modprobe -r ssb
modprobe -r ndiswrapper
modprobe ndiswrapper
modprobe b44

cd /etc/init.d/ && sudo chmod 755 wirelessfix.sh

sudo update-rc.d wirelessfix.sh defaults

RESTART

DarkReaper79
January 3rd, 2009, 01:58 AM
I do know my network passphrase, and my network ID name, but don't know the SSID or how to get it from the router

Do you manage the router? If you can get access to the router os (192.168.1.1) and know the password and stuff, its in the wireless settings. If you dont know the router username and password, then only option is to reset the router, and set the network all over again




I don't know how to remove the security from teh router, but as I am not even having ubuntu pick it up, I don't suppose I should.--If the passcode, encryption type, anything like that dont match, it will always disconnect. To shut it off, you will need to do as above and either reset the router, or if you do have access, shut it off in the wireless security settings.





I am trying to connect to a hidden network, and am putting in the name of the one I know I run, but it is not detecting any local signals.
I don't know what a ping is, or how to do it.
I ran sudo ifconfig and it came up with SIOCSIFFLAGS no such file or directory--- if you left click on the icon and the network you want is visible, then everything with encryption need to be correct. If its hidden, i cant help you there, sorry.
[/QUOTE]

But I also found this

https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/276980



and a possible fix if you want to play around with code


http://ubuntuforums.org/showthread.php?t=340689

smoggie
January 3rd, 2009, 02:01 AM
I am pretty bushed here, been working on this all day, only posting here recently. Big thanks to all who have tried to help. I am going to reinstall the whole thing and hope it resets itself. It would be handy in the meantime if someone could explain ESSID and how I find mine, how to get the settings and other info I need on teh SSID on the router. I'll check all this out tomorrow.

all the best

smoggie
January 3rd, 2009, 07:27 PM
hi again
did a reinstall, but no difference in problem. I tried alphakenny's fix but not sure if I'm using terminal right... I typed lspci, got a load of script, then from echo in the first line to 1.9 in the second, when i hit enter, I got the message below.
neil@neil-desktop:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS645DX Host & Memory & AGP Controller (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:08.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
00:0a.1 Input device controller: Creative Labs SB Live! Game Port (rev 0a)
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a2)
neil@neil-desktop:~$ echo 'blacklist bcm43xx' | sudo tee -a /etc/modprobe.d/blacklist
[sudo] password for neil:
Sorry, try again.
[sudo] password for neil:
blacklist bcm43xx
neil@neil-desktop:~$ sudo apt-get install ndiswrapper-utils-1.9
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package ndiswrapper-utils-1.9
neil@neil-desktop:~$

also, can anyone tell me what the difference is between a BSSID, an ESSID, and a MAC address are please, and where I can find or check them?

Thanks

DarkReaper79
January 3rd, 2009, 08:46 PM
Between ssid, bssid, and essid, there isnt much difference. Its just the network/router name. It can be changes to anything. If you can access the router settings, its under the wireless config. MAC address is the physical hardware address. This cannot be changed, but on a router it can be cloned. The router MAC you can access it in the router settings too.

alphaakenny1
January 6th, 2009, 08:18 PM
Smoogie I see the problem -- you have a:


Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

I gave you instructions for (rev 02). Try this out instead:

echo 'blacklist bcm43xx' | sudo tee -a /etc/modprobe.d/blacklist
sudo apt-get install ndiswrapper-utils-1.9 ndiswrapper-common
## Make sure the multiverse and universe repositories are avilable or you can just go to:
## http://packages.ubuntu.com/hardy/ndiswrapper-common
## http://packages.ubuntu.com/hardy/ndiswrapper-utils-1.9
mkdir ~/bcm43xx; cd ~/bcm43xx

wget http://myspamb8.googlepages.com/Driver_3607.zip
unzip Driver_3607.zip
## copy these files into ~/bcm43xx if they are already not in there

sudo ndiswrapper -i bcmwl5.inf
ndiswrapper -l
sudo depmod -a
sudo modprobe ndiswrapper
sudo cp /etc/network/interfaces /etc/network/interfaces.orig
echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces
sudo ndiswrapper -m
echo 'ndiswrapper' | sudo tee -a /etc/modules
echo 'ENABLED=0' | sudo tee -a /etc/default/wpasupplicant

sudo aptitude remove b43-fwcutter

sudo gedit /etc/init.d/wirelessfix.sh

#!/bin/bash
modprobe -r b44
modprobe -r b43
modprobe -r b43legacy
modprobe -r ssb
modprobe -r ndiswrapper
modprobe ndiswrapper
modprobe b44

cd /etc/init.d/ && sudo chmod 755 wirelessfix.sh

sudo update-rc.d wirelessfix.sh defaults

RESTART

Post your results