PDA

View Full Version : [ubuntu] Intrrepid - No IP connectivity on Wireless



Tony Flury
January 2nd, 2009, 11:22 AM
Ok - i have an up to date Intrepid Ibex installation.

Wired Ethernet connection works fine - everything here is wireless only.

The wireless connectivity is being a pain - in that :

The Wireless network is found :



tony@laptop:~$ iwconfig
wlan1 IEEE 802.11bg ESSID:"BTHomeHub-A8AB"
Mode:Managed Frequency:2.412 GHz Access Point: 00:1D:68:09:9B:69
Bit Rate=54 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality=28/100 Signal level:-57 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


The interface is being assigned an IP Address :


tony@laptop:~$ ifconfig wlan1
wlan1 Link encap:Ethernet HWaddr 00:1e:2a:b6:71:9b
inet addr:192.168.1.66 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21e:2aff:feb6:719b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:130 errors:0 dropped:0 overruns:0 frame:0
TX packets:51 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7103 (7.1 KB) TX bytes:7005 (7.0 KB)


and the connection is even being told which name server to use :


tony@laptop:~$ cat /etc/resolv.conf
# Generated by NetworkManager
domain home
search home
nameserver 192.168.1.254


However if I ping anything by name (www.google.com for instance) the ping fails :


tony@laptop:~$ ping www.google.com
ping: unknown host www.google.com


and if I ping by IP Addresss :


tony@laptop:~$ ping -c3 216.239.59.103
PING 216.239.59.103 (216.239.59.103) 56(84) bytes of data.

--- 216.239.59.103 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2013ms


I can't even ping the nameserver :


tony@laptop:~$ ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
From 192.168.1.66 icmp_seq=9 Destination Host Unreachable


That works fine from the Wired connection

There is no firewall running on this machine


tony@laptop:~$ sudo iptables --list
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


and I can't see anything on the router that would treat wireless connections differently (in-fact this same laptop/wireless combo connects seamlessly on Windows XP)

HotShotDJ
January 2nd, 2009, 11:50 AM
tony@laptop:~$ cat /etc/resolv.conf
# Generated by NetworkManager
domain home
search home
nameserver 192.168.1.254
This doesn't look right. It looks like your /etc/resolv.conf file is not being properly generated. It SHOULD look something like this:
# Generated by NetworkManager
domain hsd1.ct.comcast.net.
search hsd1.ct.comcast.net.
nameserver 68.87.71.226
nameserver 68.87.73.242
nameserver 68.87.64.146I believe your problem is related to Bug #269340 (https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/269340) which is in turn related to Bug #284298 (https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/284298)

My best recommendation is for you to browse through those two bug reports and try out some of the recommended work arounds. From what I understand, the bug has been fixed upstream, but has not filtered down to the Intrepid repositories yet.

Tony Flury
January 2nd, 2009, 03:07 PM
I will have a read of these - thanks.

as a matter of interest which do you think that my /etc/resolv.conf looks odd - the version i have when i am using my wired connection looks very similar - the only difference is that it had two nameserver entries.

HotShotDJ
January 2nd, 2009, 09:25 PM
as a matter of interest which do you think that my /etc/resolv.conf looks oddIt points to your wireless router. The domain and search lines should contain fully qualified domain names and the nameserver should point to an IP address outside of your home network. The IP address in your file is to your router, not a nameserver.

Tony Flury
February 5th, 2009, 08:17 PM
Sorry for not replying earlier. I found another wireless dongle that did give me connectivity - but that was problematic.

Ok - although i can see what you mean about expecting the namesever to be external, when i am connected to a wired connection - resolv.conf looks exactly the same (nameserver is the same local address). I assume the router (actually a BT Home Hub) has a DNS proxy on board, and therefore it is correct when it advertises the DNS name as it does. Certainly a wired connection works fine.

If your or someone else can suggest any other routes then let me know.

cariboo907
February 5th, 2009, 08:29 PM
Can you check what the dns settings on the router look like?

If worse comes to worse you could always add the dns entries from your router manually to /etc/resolv.conf

Jim

Tony Flury
February 5th, 2009, 09:16 PM
There is no way i can tell the dns settings on the router. The whole point of the Home Hub is that it is zero touch.

I do know two things -

1) Other wireless adapater have not had this problem
2) and the wired link to the Hub has not had this problem


This is also not a DNS problem - I can't even ping IP adresses on my local network, and i know enough to know that DNS is not used when you try to ping an explicit IP address.

Tony Flury
February 6th, 2009, 05:24 PM
ANyone able to help ?

This is frustrating, as the same dongle connecting to the same router works seamlessly in Windows XP.

Tony Flury
February 9th, 2009, 12:49 PM
I am trying to resist bumping this - but any help would be appreciated.

clive littlewood
February 9th, 2009, 02:12 PM
Hi don't know if this helps but my resolv.conf is as follows, from a working wireless connection.

Very much like yours

Would not want you going in the wrong direction if not ness





clive@clive-laptop:~$ cat /etc/resolv.conf
# Generated by NetworkManager
domain Belkin
search Belkin
nameserver 192.168.2.1

Tony Flury
February 10th, 2009, 08:55 AM
clive : Thanks for this - that confirms my suspicion that there is nothing wrong with my resolv.conf. It looks like your router proxies for DNS servers (just like mine).

The fact that with that dongle plugged in that I can't even ping an IP adress suggests that DNS is not my problem.

I would guess it is a driver issue (as the dongle works fine in Windows), but i am not sure how to prove it - or solve it.