PDA

View Full Version : [ubuntu] Dell A840 Vostro - Atheros Communication Inc 802.11abg Wireless PCI Express Adapter



noob03
December 27th, 2008, 07:31 PM
Hello,

I must be the newest Ubuntu user in the whole world, cos I just installed it a few minutes ago. I have never worked on Linux before and the only technical thing I know is to turn on a computer.

My problem: My Dell notebook cannot detect wireless network in my home. My other laptop which works on Windows is connected to this network.

My config:

Notebook: Dell Vostro A840
OS: Ubuntu 8.04
Wireless adapter: Atheros Communication Inc 802.11abg Wireless PCI Express Adapter

Observations:
1. I can connect to internet through hard wired connection.

2. The System>Administration>Hardware Drivers shows:
Atheros Hardware Access Layer (HAL) - Enabled - In use
Support for Atheros 802.11 wireless LAN cards. - In use

Please take a look at the attachment for a screenshot of what I see in Network Manager and Wireless Networks.

I need all the help you can give! Thank you all.

Anupam

er.sunilsharma
March 29th, 2009, 03:12 PM
I am also having same problem......please help

danu
April 29th, 2009, 06:29 PM
try this http://madberry.org/2008/08/how-to-get-atheros-ar242x-wireless-to-work-2/
it should help to solve the problem

when you do step
sudo modprobe wlan_scan_sta
maybe you will receive error message but don't worry just restart your Vostro
and you will able to user your Atheros...
but the led didn't work

just try it... :)

SuperNoa
April 29th, 2009, 06:37 PM
Try installing linux-backports-modules-hardy-generic